Bug 213166 - error of vm save command cannot be fed back to user
error of vm save command cannot be fed back to user
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Martin Jenner
:
Depends On: 212272
Blocks: 216893
  Show dependency treegraph
 
Reported: 2006-10-30 20:07 EST by nickyu
Modified: 2008-01-22 10:52 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.5.3-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nickyu 2006-10-30 20:07:10 EST
Description of problem:
When I use save button on screen to save a running hvm domain.
no any error messge show up, even though the save action failed.

Version-Release number of selected component (if applicable):
FC6GA
virt-manager-0.2.3-2.fc6


How reproducible:
Every time, it can be reproduced.

Steps to Reproduce:
1. Start a hvm domain
2. Select the save button and input the path where image will be located with 
virt-manager.
3. Push "save"
  
Actual results:
 Nothing show up, even though the save acction failed.
 The following log was got from the xend.log showing the save action failed
 and image was not saved. 
 -----
 [2006-10-27 14:13:43 xend 2459] DEBUG (XendCheckpoint:83)    
                      [xc_save]: /usr/lib/xen/bin/xc_save 21 6 0 0 0
 [2006-10-27 14:13:43 xend 2459] ERROR (XendCheckpoint:236) Couldn't
                      map p2m_frame_list_list (errno 14): 14
 [2006-10-27 14:13:43 xend 2459] ERROR (XendCheckpoint:236) Save exit rc=1
 [2006-10-27 14:13:43 xend 2459] ERROR (XendCheckpoint:106) Save failed
                      on domain Full_FC6GA_CD (6).
                      Traceback (most recent call last):
  -----


Expected results:
 If the save command failed, the error message should be output to user.
 
Additional info:
 For the reason why save command failed, that's a different issue from
 virt-manager, and will be reported with different bug.
Comment 1 Daniel Berrange 2007-01-04 14:10:48 EST
Fixing this first requires sensible error reporting in libxc (see bug  212272).
Once that's done, some more work is needed in XenD to actually capture the error
& feed it back to libvirt, before virt-manager stands a chance of seeing it.
Comment 2 Red Hat Bugzilla 2007-07-24 22:06:33 EDT
change QA contact
Comment 3 Cole Robinson 2007-12-04 11:20:40 EST
This is now fixed upstream.

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=a52007787308
Comment 4 Fedora Update System 2008-01-11 17:23:29 EST
virt-manager-0.5.3-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'
Comment 5 Fedora Update System 2008-01-22 10:52:10 EST
virt-manager-0.5.3-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.