Bug 216893 - error of vm save command cannot be fed back to user
Summary: error of vm save command cannot be fed back to user
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 212272 213166
Blocks: 222399 246258
TreeView+ depends on / blocked
 
Reported: 2006-11-22 15:59 UTC by Chris Lalancette
Modified: 2008-06-16 16:33 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0480
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 17:27:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0480 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2008-05-20 13:36:50 UTC

Description Chris Lalancette 2006-11-22 15:59:53 UTC
+++ This bug was initially created as a clone of Bug #213166 +++

Description of problem:
When I use save button on screen to save a running hvm domain.
no any error messge show up, even though the save action failed.

Version-Release number of selected component (if applicable):
FC6GA
virt-manager-0.2.3-2.fc6


How reproducible:
Every time, it can be reproduced.

Steps to Reproduce:
1. Start a hvm domain
2. Select the save button and input the path where image will be located with 
virt-manager.
3. Push "save"
  
Actual results:
 Nothing show up, even though the save acction failed.
 The following log was got from the xend.log showing the save action failed
 and image was not saved. 
 -----
 [2006-10-27 14:13:43 xend 2459] DEBUG (XendCheckpoint:83)    
                      [xc_save]: /usr/lib/xen/bin/xc_save 21 6 0 0 0
 [2006-10-27 14:13:43 xend 2459] ERROR (XendCheckpoint:236) Couldn't
                      map p2m_frame_list_list (errno 14): 14
 [2006-10-27 14:13:43 xend 2459] ERROR (XendCheckpoint:236) Save exit rc=1
 [2006-10-27 14:13:43 xend 2459] ERROR (XendCheckpoint:106) Save failed
                      on domain Full_FC6GA_CD (6).
                      Traceback (most recent call last):
  -----


Expected results:
 If the save command failed, the error message should be output to user.
 
Additional info:
 For the reason why save command failed, that's a different issue from
 virt-manager, and will be reported with different bug.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
This issue still exists in RHEL-5, with virt-manager 0.2.6; basically, when an
"xm save" fails, there is no error message back to the user in the GUI.

Comment 1 RHEL Product and Program Management 2006-11-28 02:26:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Daniel Berrange 2007-01-04 19:08:45 UTC
Fixing this first requires sensible error reporting in libxc (see bug  212272).
Once that's done, some more work is needed in XenD to actually capture the error
& feed it back to libvirt, before virt-manager stands a chance of seeing it.


Comment 5 Issue Tracker 2007-08-27 14:26:18 UTC
Hi Chris,

Though Fujitsu tested this issue, but this was reproduced on 5.1 beta,
unfortunately.

Internal Status set to 'Waiting on SEG'

This event sent from IssueTracker by mmatsuya 
 issue 107359

Comment 6 RHEL Product and Program Management 2007-09-07 19:58:53 UTC
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Comment 8 Cole Robinson 2008-01-17 18:18:06 UTC
We've rebased to virt-manager 0.5.3, which contains the fix for this bug:

Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-1.el5                  dist-5E-qu-candidate  berrange

Comment 11 Cole Robinson 2008-04-24 14:47:43 UTC
I've tested this on my own and it works to the full extent that virt-manager can
manage. By editing the libvirt python bindings and forcing the save command to
fail, an error box pops up as expected.

Ex. edit /usr/lib64/python2.4/site-packages/libvirt.py and have save() return -1.

Gurhan, can you check ~/.virt-manager/virt-manager.log and see if any exception
was logged there? If so, virt-manager has an issue. If not (which I am
suspecting), this is either a xen bug (not properly returning the error) or
libvirt bug (not properly catching it).

Comment 13 Gurhan Ozen 2008-04-25 07:54:27 UTC
(In reply to comment #11)
> 
> Gurhan, can you check ~/.virt-manager/virt-manager.log and see if any exception
> was logged there? If so, virt-manager has an issue. If not (which I am
> suspecting), this is either a xen bug (not properly returning the error) or
> libvirt bug (not properly catching it).

There are no errors about this in virt-manager.log.. All I see is:
[Fri, 25 Apr 2008 03:44:01 virt-manager 26251] DEBUG (console:434) Trying
console login
[Fri, 25 Apr 2008 03:44:01 virt-manager 26251] DEBUG (console:444) Graphics
console configured at vnc://127.0.0.1:5906
[Fri, 25 Apr 2008 03:44:01 virt-manager 26251] DEBUG (console:457) Starting
connect process for 127.0.0.1 5906
[Fri, 25 Apr 2008 03:44:01 virt-manager 26251] DEBUG (console:368) VNC initialized
[Fri, 25 Apr 2008 03:44:25 virt-manager 26251] DEBUG (connection:580) Couldn't
fetch domain id 6; it probably went away
[Fri, 25 Apr 2008 03:44:26 virt-manager 26251] DEBUG (connection:580) Couldn't
fetch domain id 6; it probably went away
[Fri, 25 Apr 2008 03:44:26 virt-manager 26251] DEBUG (console:354) VNC disconnected
[Fri, 25 Apr 2008 03:44:27 virt-manager 26251] DEBUG (console:434) Trying
console login
[Fri, 25 Apr 2008 03:44:27 virt-manager 26251] DEBUG (console:444) Graphics
console configured at vnc://127.0.0.1:5906
[Fri, 25 Apr 2008 03:44:27 virt-manager 26251] DEBUG (console:457) Starting
connect process for 127.0.0.1 5906
[Fri, 25 Apr 2008 03:44:27 virt-manager 26251] DEBUG (console:354) VNC disconnected

Over and over again.. I'll verify this particular bug against virt-manager and 
 open up another one against xend/libvirtd for not reporting/catching it properly.

Comment 15 errata-xmlrpc 2008-05-21 17:27:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0480.html



Note You need to log in before you can comment on or make changes to this bug.