Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 213219 - KWin focus goes berzerk
KWin focus goes berzerk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 214265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 06:00 EST by Tim Smith
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: FC5/FC6 release
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-02 09:30:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch for kde bug #135250 (2.34 KB, patch)
2006-11-02 07:58 EST, Rex Dieter
no flags Details | Diff

  None (edit)
Description Tim Smith 2006-10-31 06:00:16 EST
Description of problem:
When using any of KWin's focus-follows-mouse type modes (i.e. not 
click-to-focus), KWin can go insane flipping the focus between the new window 
and the previously active window, when the windows overlap. This renders the 
entire desktop unusable until it sorts itself out, which can take some 
minutes. The more widgets there are in the affected windows, the longer it 
takes. For example, when the KDE control panel is involved, you might as well 
go make a cup of tea...

As a workaround, setting a non-zero focus delay (e.g. 10ms) appears to make 
things behave normally.

Version-Release number of selected component (if applicable):
kdebase-3.5.5-0.1.fc6

How reproducible: 100%

Steps to Reproduce:
1. Set KWin to focus-follows-mouse using Control Panel
2. Turn focus-delay OFF
3. Turn Auto-Raise OFF
4. Set up any two windows so that they overlap.
5. Waggle the mouse so that focus flips between them.
6. Watch the fun.
  
This problem appears on i686 and x86_64. It does not appear (AFAICT) on a KDE 
3.5.5 from the kde-redhat repository.
Turning focus-stealing prevention off does not fix it. I haven't tried 
increasing it beyond "low".
Comment 1 Need Real Name 2006-10-31 11:49:28 EST
Reproducible with kdebase-3.5.5-0.1.fc5 x86_64
This bug is described as resolved in 
http://bugs.kde.org/show_bug.cgi?id=135250

Someone should probably backport the patch listed there.
Comment 2 Need Real Name 2006-10-31 12:18:47 EST
I rebuilt kdebase-3.5.5-0.1.fc5 rebuilt with the patch mentioned.  Focus 
problem goes away.

I did have to change the diff header in the patch to add the kwin 
subdirectory.
Comment 3 Rex Dieter 2006-11-02 07:58:12 EST
Created attachment 140120 [details]
upstream patch for kde bug #135250
Comment 4 Rex Dieter 2006-11-02 07:59:02 EST
I can confirm the upstream patch works as advertised.
Comment 5 Ngo Than 2006-11-02 09:30:34 EST
I will push new kdebase including this fix into FC5/FC6 update today. Many 
thanks for your report. Rex, thank for verifying this patch!
Comment 6 Ngo Than 2006-11-07 10:39:58 EST
*** Bug 214265 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.