Bug 213245 - Kickstart Post Scripts execute in different sequence each time
Kickstart Post Scripts execute in different sequence each time
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
410
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
: Reopened
Depends On:
Blocks: 429319
  Show dependency treegraph
 
Reported: 2006-10-31 09:06 EST by Steven Warfield
Modified: 2010-10-22 02:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat511
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-13 14:59:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Warfield 2006-10-31 09:06:52 EST
Description of problem:
The post scripts of a kickstart file do not execute in the same sequence every
time that they are run.  For example, when I have 4 post scripts in a single
kickstart profile, if I download the kickstart file several times, I will see
different execution sequences for the post scripts in each file.

Version-Release number of selected component (if applicable):
rhn 4.1.4 on redhat as 3 update 8

How reproducible:
every time

Steps to Reproduce:
1. create kickstart profile
2. create multiple kickstart post scripts
3. acccess the kickstart file in whatever manner you wish, and compare the order
of kickstart post scripts.
  
Actual results:

The post scripts will vary in execution order

Expected results:

The post scripts will execute in the same order every time.

Additional info:

This is certainly a large problem for the installation of software but it is
exacerbated by the fact that the post scripts are limited to only 2000
characters.  In version 4.0.6 there wasn't a 2000 character limit.  Bug # 204246
Comment 1 Mike McCune 2007-01-18 01:20:55 EST

*** This bug has been marked as a duplicate of 215711 ***
Comment 2 g.stroh 2007-06-07 20:47:21 EDT
I don't have access to 215711 has this bug been resolved in later releases of 
Satellite?
Comment 3 Steven Warfield 2007-06-08 08:35:08 EDT
This bug is present in 4.2.0 I have not tested it yet in 4.2.1 .

1. Created kickstart file
2. Created 3 post scripts in kickstart file
3. Retrieved kickstart file 5 times, had a different order 3 of the times (some
duplication is expected)

With the newer versions of the satellite they at least allow you to have 150K+
characters so you can work around it by having all config done in one post script
Comment 8 Shannon Hughes 2008-05-08 14:59:51 EDT
added logic to sort kickstart scripts based on db insertion order. ready to move
to qa
Comment 10 Shannon Hughes 2008-06-11 11:42:05 EDT
mass move to onqa
Comment 11 Preethi Thomas 2008-06-12 14:52:17 EDT
verified
Comment 12 Jesus M. Rodriguez 2008-07-23 11:39:16 EDT
release pending, scripts remain in order as applied.
Comment 13 Brandon Perkins 2008-08-13 14:59:54 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.
Comment 14 Brandon Perkins 2008-08-13 15:05:52 EDT
5.1.1 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.