Bug 213253 - "cal -3" generates improperly formatted output
"cal -3" generates improperly formatted output
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 238502 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 09:41 EST by Fulko Hew
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.13-0.52.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 16:57:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fulko Hew 2006-10-31 09:41:28 EST
Description of problem:

cal -3  generates improperly formatted output

Version-Release number of selected component (if applicable):

unknown

How reproducible:

every time

Steps to Reproduce:
1.  ensure system clock is Oct 31, 2006
2.  issue 'cal -3'
  
Actual results:

  September 2006         October 2006         November 2006
Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa
                1  2   1  2  3  4  5  6  7            1  2  3  4
 3  4  5  6  7  8  9   8  9 10 11 12 13 14   5  6  7  8  9 10 11
10 11 12 13 14 15 16  15 16 17 18 19 20 21  12 13 14 15 16 17 18
17 18 19 20 21 22 23  22 23 24 25 26 27 28  19 20 21 22 23 24 25
24 25 26 27 28 29 30  29 30 31     26 27 28 29 30


Expected results:

  September 2006         October 2006         November 2006
Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa  Su Mo Tu We Th Fr Sa
                1  2   1  2  3  4  5  6  7            1  2  3  4
 3  4  5  6  7  8  9   8  9 10 11 12 13 14   5  6  7  8  9 10 11
10 11 12 13 14 15 16  15 16 17 18 19 20 21  12 13 14 15 16 17 18
17 18 19 20 21 22 23  22 23 24 25 26 27 28  19 20 21 22 23 24 25
24 25 26 27 28 29 30  29 30 31              26 27 28 29 30

Additional info:

This appears to fail on a number of Fedora distributions, not just FC5.
Comment 1 Karel Zak 2007-03-14 16:46:29 EDT
The problem will be fixed in the next upstream release. Thanks.
Comment 2 Karel Zak 2007-04-30 18:33:05 EDT
*** Bug 238502 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2007-07-11 11:17:11 EDT
util-linux-2.13-0.52.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-07-18 16:57:34 EDT
util-linux-2.13-0.52.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.