Bug 21332 - installer crashes on reading packages and loses track of USB floppy
installer crashes on reading packages and loses track of USB floppy
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-25 17:12 EST by James Scanlan
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-29 14:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Scanlan 2000-11-25 17:12:56 EST
Install RH 7.0 failed on Sony Vaio PCG-Z505SX.  Install was attempted by
downloading RPMS and base directories and using a boot floppy. Floppy is
USB.

This laptop has a memory stick which is viewed as a hard disk. The
installer complained that partition table was not readable (I have no
memory sticks), but proceeded after "skip drive" was selected.

Partition was edited with disk druid to:

4.5M win95 fat32 (NOT mounted)
132M linux swap
1.262M linux native (mounted /)

Note: The installer crashes before actually writing this to disk, during
"reading package information"

I cannot save the exception to disk, since the installer seems to lose
track of the USB floppy. Thus, trying the 'linux updates' disk did not work
either.

Here is the output:

Traceback (innermost last):
 File "/usr/bin/anaconda.real",
line 438, in ?
   intf.run(todo, test = test)
File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py",line1030, in run
File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 33, in __call__
File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py",line 539, in
getCompsList
 File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py",line 43, in
readComps
File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py",line 459, in
__init__
File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py",line 428, in
readCompsFile
File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py",line 101, in
__getitem__
KeyError: qt1x
Comment 1 Michael Fulbright 2000-11-29 14:46:44 EST
The USB floppy is not supported in 7.0.

The other error is due to something being corrupt in the install tree you
created for the hard drive install. Be sure you have all the required files and
have downloaded them with a binary safe method.

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.