Bug 213329 - Decimal point on numeric pad, Estonian keyboard, doesn't work in oocalc
Decimal point on numeric pad, Estonian keyboard, doesn't work in oocalc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 16:05 EST by Fred New
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4-5.5.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 03:25:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2006-10-31 16:05:20 EST
Description of problem:
I am unable to use the "decimal point" key on the numeric pad of an Estonian
keyboard for entering numbers.  Although this key indicates a period, the
Estonian locale uses a comma for its "decimal separator key".  That is, if you
entered "123.45" using the numeric keypad, it used to get translated to "123,45"
in previous releases of oocalc (version 2).  Now it stays as "123.45".  This
problem may appear for other locales that use the comma as the decimal separator.

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.0.4-5.3
gnome-desktop-2.16.0-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. You may need to install openoffice.org-langpack-et_EE (Estonian).
2. You may also need to tell gnome that you are using an Estonian keyboard.
3. Start oocalc.
4. Go to Tools -> Options -> Language Settings -> Languages
 Change the Locale setting to Estonian.
5. Click OK and exit oocalc.
6. Start oocalc again.
7. Turn on Num Lock.
8. Using the numeric pad, enter 123.45 in a cell.
9. Enter 123,45 in a different cell.
  
Actual results:
The 123.45 gets entered as a (left justified) character string because it
contains a period.
The 123,45 gets entered as a (right justified) number.

Expected results:
Both cells should contain (right justified) numbers appearing as 123,45.

Additional info:
Comment 1 Caolan McNamara 2006-11-01 03:49:18 EST
This was supposed to work out of the box and give a 123,45 when 123.45 was
entered from a numeric keypad.

http://qa.openoffice.org/issues/show_bug.cgi?id=1820
Comment 2 Fred New 2006-11-01 04:20:58 EST
Exactly.  Didn't work with OOo v1, but started working with OOo v2.  I didn't
test this in the FC6 test versions, so I don't know when it stopped working, but
it works correctly in FC5.

Maybe something in xkeyboard-config that changed what oocalc receives when the
numeric decimal is pressed.  I'm currently at xkeyboard-config-0.8-7.fc6.
Comment 3 Fred New 2006-11-01 06:01:37 EST
In case it helps, here are the scan codes for numeric pad decimal key when
running "showkey -s" on a virtual console:

0x53  (down)
0xd3  (up)
Comment 4 Caolan McNamara 2006-11-01 07:04:05 EST
The problem here is that another fix, that of bug 203872 conflicts with the "."
to "," conversion. Fix checked into to devel and FC-6 updates, will be in next
update for OOo

Note You need to log in before you can comment on or make changes to this bug.