Bug 213391 - screen corruption playing videos with desktop effesct enabled
screen corruption playing videos with desktop effesct enabled
Status: CLOSED DUPLICATE of bug 200270
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 04:40 EST by filippo david
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 18:16:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mplayer fullscreen (98.65 KB, image/jpeg)
2006-11-01 04:40 EST, filippo david
no flags Details
moving mplayer window around (214.94 KB, image/jpeg)
2006-11-01 04:41 EST, filippo david
no flags Details
mplayer on the cube (127.09 KB, image/jpeg)
2006-11-01 04:42 EST, filippo david
no flags Details
moving totem window (186.87 KB, image/jpeg)
2006-11-01 04:43 EST, filippo david
no flags Details
Video plays with wrong colors (442.30 KB, image/png)
2006-11-03 11:58 EST, Alexey Titov
no flags Details

  None (edit)
Description filippo david 2006-11-01 04:40:02 EST
Description of problem:With desktop effects enabled playing videos and moving
around windows creates artifacts on the screen. This happens with totem, mplayer
xine using both Xv and gl drivers, while it works ok with X11(No Xv) driver.


Version-Release number of selected component (if applicable):
compiz-0.0.13-0.32.20060817git.fc6

with both the xorg-x11-drv-i810-1.6.5-9.fc6 and with an updated
xorg-x11-drv-i810-1.7.2 driver (with the 1.6.5 driver Xv didn't work).



How reproducible:just play any video and move the window or go fullscreen, this
happen always


  
Actual results: screen corruption, see attachments.


Expected results: no screen corruption


Additional info: my hardware is an Intel DG965WH motherboard (g965 express chipset).
Comment 1 filippo david 2006-11-01 04:40:02 EST
Created attachment 139957 [details]
mplayer fullscreen
Comment 2 filippo david 2006-11-01 04:41:33 EST
Created attachment 139958 [details]
moving mplayer window around
Comment 3 filippo david 2006-11-01 04:42:28 EST
Created attachment 139959 [details]
mplayer on the cube
Comment 4 filippo david 2006-11-01 04:43:12 EST
Created attachment 139961 [details]
moving totem window
Comment 5 Alexey Titov 2006-11-03 11:57:20 EST
I have the same problem... Besides, video plays with wrong colors. I use
totem-xine with opengl driver.
Comment 6 Alexey Titov 2006-11-03 11:58:49 EST
Created attachment 140275 [details]
Video plays with wrong colors
Comment 7 Kristian Høgsberg 2007-08-14 18:16:55 EDT

*** This bug has been marked as a duplicate of 200270 ***

Note You need to log in before you can comment on or make changes to this bug.