Bug 213411 - usb 1-1 error -71 message on boot
usb 1-1 error -71 message on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 215352 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 06:52 EST by Mike Cohler
Modified: 2012-05-24 17:36 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 15:48:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg in F7 after boot with edited mkinitrd (19.90 KB, text/plain)
2007-09-18 15:24 EDT, Mike Cohler
no flags Details

  None (edit)
Description Mike Cohler 2006-11-01 06:52:24 EST
Description of problem:Message during boot that usb 1-1 device has error -71


Version-Release number of selected component (if applicable):


How reproducible:Every time


Steps to Reproduce:
1. Boot machine
2. Get error at start of boot process 
3. Boot continues normally
  
Actual results:Get message: usb 1-1: device not accepting address 2, error -71


Expected results: Should not get error message


Additional info: Running FC6 clean install, Dell 5150.

Relevant section of messages file is:
Oct 31 13:45:26 gestalt kernel: ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI
1.00, driver 10 Dec 2004
Oct 31 13:45:26 gestalt kernel: usb usb5: configuration #1 chosen from 1 choice
Oct 31 13:45:26 gestalt kernel: hub 5-0:1.0: USB hub found
Oct 31 13:45:26 gestalt kernel: hub 5-0:1.0: 8 ports detected
Oct 31 13:45:26 gestalt kernel: SCSI subsystem initialized
Oct 31 13:45:26 gestalt kernel: ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
Oct 31 13:45:26 gestalt kernel: ACPI: PCI Interrupt 0000:00:1f.2[C] -> GSI 20
(level, low) -> IRQ 233
Oct 31 13:45:26 gestalt kernel: ata1: SATA max UDMA/133 cmd 0xFE00 ctl 0xFE12
bmdma 0xFEA0 irq 233
Oct 31 13:45:26 gestalt kernel: ata2: SATA max UDMA/133 cmd 0xFE20 ctl 0xFE32
bmdma 0xFEA8 irq 233
Oct 31 13:45:26 gestalt kernel: scsi0 : ata_piix
Oct 31 13:45:26 gestalt kernel: usb 1-1: device not accepting address 2, error -71
Oct 31 13:45:26 gestalt kernel: ata1.00: ATA-7, max UDMA/133, 312500000 sectors:
LBA48 NCQ (depth 0/32)
Oct 31 13:45:26 gestalt kernel: ata1.00: ata1: dev 0 multi count 8
Oct 31 13:45:26 gestalt kernel: ata1.00: configured for UDMA/133
Oct 31 13:45:26 gestalt kernel: scsi1 : ata_piix
Oct 31 13:45:26 gestalt kernel: ATA: abnormal status 0x7F on port 0xFE27
Oct 31 13:45:26 gestalt kernel:   Vendor: ATA       Model: ST3160812AS      
Rev: 3.AD
Oct 31 13:45:26 gestalt kernel:   Type:   Direct-Access                     
ANSI SCSI revision: 05
Oct 31 13:45:26 gestalt kernel: SCSI device sda: 312500000 512-byte hdwr sectors
(160000 MB)
Oct 31 13:45:26 gestalt kernel: sda: Write Protect is off
Oct 31 13:45:26 gestalt kernel: SCSI device sda: drive cache: write back
Oct 31 13:45:26 gestalt kernel: SCSI device sda: 312500000 512-byte hdwr sectors
(160000 MB)
Oct 31 13:45:26 gestalt kernel: sda: Write Protect is off
Oct 31 13:45:26 gestalt kernel: SCSI device sda: drive cache: write back
Oct 31 13:45:26 gestalt kernel:  sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 >
Oct 31 13:45:26 gestalt kernel: sd 0:0:0:0: Attached scsi disk sda
Oct 31 13:45:26 gestalt kernel: usb 1-1: new low speed USB device using uhci_hcd
and address 4
Oct 31 13:45:26 gestalt kernel: kjournald starting.  Commit interval 5 seconds
Oct 31 13:45:26 gestalt kernel: EXT3-fs: mounted filesystem with ordered data mode.
Comment 1 John Mahowald 2006-11-01 13:33:53 EST
Almost the exact same thing on a Dell Optiplex GX270, except usb 1-2. dmesg snippit:


uhci_hcd 0000:00:1d.0: UHCI Host Controller
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:1d.0: irq 177, io base 0x0000ff80
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.1[B] -> GSI 19 (level, low) -> IRQ 185
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: UHCI Host Controller
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:1d.1: irq 185, io base 0x0000ff60
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.2[C] -> GSI 18 (level, low) -> IRQ 169
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: UHCI Host Controller
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:1d.2: irq 169, io base 0x0000ff40
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI Interrupt 0000:00:1d.3[A] -> GSI 16 (level, low) -> IRQ 177
PCI: Setting latency timer of device 0000:00:1d.3 to 64
uhci_hcd 0000:00:1d.3: UHCI Host Controller
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
uhci_hcd 0000:00:1d.3: irq 177, io base 0x0000ff20
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 1-2: new low speed USB device using uhci_hcd and address 2
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt 0000:00:1d.7[D] -> GSI 23 (level, low) -> IRQ 193
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
ehci_hcd 0000:00:1d.7: debug port 1
PCI: cache line size of 128 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: irq 193, io mem 0xffa80800
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 8 ports detected
Comment 2 filippo david 2006-11-05 08:16:44 EST
same with intel DG965WH:

usb 3-1: device not accepting address 2, error -71
Comment 3 skyblue9 2006-12-02 23:40:18 EST
Same thing here.  It will alternate between:

usb 1-1: device not accepting address 2, error -110

and

usb 1-1: device descriptor read/all, error -110

This is on ASRock socket 939 motherboard with Opteron cpu.
Comment 4 Valdis Kletnieks 2006-12-06 12:51:59 EST
Also being seen on a Dell D820.

% dmesg | grep usb

usbcore: registered new driver usbfs
usbcore: registered new driver hub
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
usb usb1: configuration #1 chosen from 1 choice
usb usb2: configuration #1 chosen from 1 choice
usb usb3: configuration #1 chosen from 1 choice
usb usb4: configuration #1 chosen from 1 choice
usb 1-2: new full speed USB device using uhci_hcd and address 2
usb usb5: configuration #1 chosen from 1 choice
usb 1-2: device not accepting address 2, error -71
usb 5-8: new high speed USB device using ehci_hcd and address 4
SELinux: initialized (dev usbfs, type usbfs), uses genfs_contexts
usb 5-8: configuration #1 chosen from 1 choice
usb 1-2: new full speed USB device using uhci_hcd and address 4
usb 1-2: configuration #1 chosen from 1 choice
usb 2-1: new full speed USB device using uhci_hcd and address 2
usb 2-1: configuration #1 chosen from 1 choice
usb 5-8.1: new low speed USB device using ehci_hcd and address 5
usb 5-8.1: configuration #1 chosen from 1 choice
input: USB HID v1.00 Mouse [Microsoft Microsoft Trackball Optical®] on
usb-0000:00:1d.7-8.1
usb 2-1.2: new full speed USB device using uhci_hcd and address 3
usb 2-1.2: configuration #1 chosen from 1 choice

% lsusb
Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 004: ID 413c:a005 Dell Computer Corp. 
Bus 002 Device 003: ID 0b97:7762 O2 Micro, Inc. Oz776 SmartCard Reader
Bus 002 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 0b97:7761 O2 Micro, Inc. 
Bus 003 Device 001: ID 0000:0000  
Bus 004 Device 001: ID 0000:0000  
Bus 005 Device 004: ID 413c:0058 Dell Computer Corp. 
Bus 005 Device 001: ID 0000:0000  
Bus 005 Device 005: ID 045e:0023 Microsoft Corp. Trackball Optical

% uname  -a
Linux turing-police.cc.vt.edu 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:39:22 EDT
2006 x86_64 x86_64 x86_64 GNU/Linux

Comment 5 Will Woods 2007-01-15 11:35:58 EST
*** Bug 215352 has been marked as a duplicate of this bug. ***
Comment 6 Luis Felipe Marzagao 2007-01-21 15:46:47 EST
Same error message on my *DELL GX620*.

USB devices seems to work. But I'm experimenting some problems with automount
feature (as described here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=215657)

I don't know if the problems are related. Here's information about my hardware
and software:


My Hardware:

id:	localhost.localdomain
description: 	Mini Tower Computer
product: 	OptiPlex GX620
vendor: 	Dell Inc.
serial: 	5WQY091
width: 	32 bits
capabilities: 	smbios-2.3 dmi-2.3
configuration:	
administrator_password	=	enabled
boot	=	normal
chassis	=	mini-tower
power-on_password	=	enabled
uuid	=	44454C4C-5700-1051-8059-B5C04F303931
id:	
core
description: 	Motherboard
product: 	0X9682
vendor: 	Dell Inc.
physical id: 	0
serial: 	..BR4810559F00CB.
id:	firmware
description: 	BIOS
vendor: 	Dell Inc.
physical id: 	0
version: 	A11 (11/30/2006)
size: 	64KB
capacity: 	448KB
capabilities: 	pci pnp apm upgrade shadowing cdboot bootselect edd
int13floppytoshiba int5printscreen int9keyboard int14serial int17printer acpi
usb ls120boot biosbootspecification netboot
id:	cpu
description: 	CPU
product: 	Intel(R) Pentium(R) D CPU 3.60GHz
vendor: 	Intel Corp.
physical id: 	400
bus info: 	
cpu@0
version: 	15.6.4
serial: 	0000-0F64-0000-0000-0000-0000
slot: 	Microprocessor
size: 	3600MHz
capacity: 	4GHz
width: 	64 bits
clock: 	800MHz
capabilities: 	fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx x86-64
constant_tsc pni monitor ds_cpl vmx est cid cx16 xtpr lahf_lm cpufreq
configuration:	
id	=	0
id:	cache:0
description: 	L1 cache
physical id: 	
700
size: 	16KB
capacity: 	16KB
capabilities: 	internal write-back data
id:	cache:1
description: 	L2 cache
physical id: 	
701
size: 	4MB
capacity: 	4MB
capabilities: 	internal varies unified
id:	logicalcpu:0
description: 	Logical CPU
physical id: 	0.1
width: 	64 bits
capabilities: 	logical
id:	logicalcpu:1
description: 	Logical CPU
physical id: 	0.2
width: 	64 bits
capabilities: 	logical
id:	memory
description: 	System Memory
physical id: 	
1000
slot: 	System board or motherboard
size: 	3GB
id:	bank:0
description: 	DIMM DDR Synchronous 533 MHz (1.9 ns)
vendor: 	7F98000000000000
physical id: 	0
serial: 	670A716A
slot: 	DIMM_1
size: 	1GB
width: 	64 bits
clock: 	533MHz (1.9ns)
id:	bank:1
description: 	DIMM DDR Synchronous 533 MHz (1.9 ns)
product: 	M3 78T6553CZ3-CD5
vendor: 	CE00000000000000
physical id: 	1
serial: 	F50569B8
slot: 	DIMM_3
size: 	512MB
width: 	64 bits
clock: 	533MHz (1.9ns)
id:	bank:2
description: 	DIMM DDR Synchronous 533 MHz (1.9 ns)
vendor: 	7F98000000000000
physical id: 	2
serial: 	A00A0665
slot: 	DIMM_2
size: 	1GB
width: 	64 bits
clock: 	533MHz (1.9ns)
id:	bank:3
description: 	DIMM DDR Synchronous 533 MHz (1.9 ns)
product: 	M3 78T6553CZ3-CD5
vendor: 	CE00000000000000
physical id: 	3
serial: 	F5056949
slot: 	DIMM_4
size: 	512MB
width: 	64 bits
clock: 	533MHz (1.9ns)
id:	pci
description: 	Host bridge
product: 	82945G/GZ/P/PL Memory Controller Hub
vendor: 	Intel Corporation
physical id: 	100
bus info: 	
pci@0000:00:00.0
version: 	02
width: 	32 bits
clock: 	33MHz
configuration:	
driver	=	agpgart-intel
id:	pci:0
description: 	PCI bridge
product: 	82945G/GZ/P/PL PCI Express Root Port
vendor: 	Intel Corporation
physical id: 	1
bus info: 	
pci@0000:00:01.0
version: 	02
width: 	32 bits
clock: 	33MHz
capabilities: 	pci pm msi pciexpress normal_decode bus_master cap_list
configuration:	
driver	=	pcieport-driver
id:	display
description: 	VGA compatible controller
product: 	NV43 [GeForce 6600 GT]
vendor: 	nVidia Corporation
physical id: 	0
bus info: 	pci@0000:01:00.0
version: 	a2
width: 	64 bits
clock: 	33MHz
capabilities: 	pm msi pciexpress vga bus_master cap_list
configuration:	
driver	=	nvidia
latency	=	0
module	=	nvidia
id:	pci:1
description: 	PCI bridge
product: 	82801G (ICH7 Family) PCI Express Port 1
vendor: 	Intel Corporation
physical id: 	1c
bus info: 	pci@0000:00:1c.0
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	pci pciexpress msi pm normal_decode bus_master cap_list
configuration:	
driver	=	pcieport-driver
id:	network
description: 	Ethernet interface
product: 	NetXtreme BCM5751 Gigabit Ethernet PCI Express
vendor: 	Broadcom Corporation
physical id: 	0
bus info: 	pci@0000:02:00.0
logical name: 	eth1
version: 	01
serial: 	00:12:3f:fe:3e:e2
size: 	100MB/s
capacity: 	1GB/s
width: 	64 bits
clock: 	33MHz
capabilities: 	pm vpd msi pciexpress bus_master cap_list ethernet physical mii
10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration:	autonegotiation	=	on
broadcast	=	yes
driver	=	tg3
driverversion	=	3.69
duplex	=	full
firmware	=	5751-v3.44a
ip	=	192.168.0.52
latency	=	0
link	=	yes
module	=	tg3
multicast	=	yes
port	=	twisted pair
speed	=	100MB/s
id:	pci:2
description: 	PCI bridge
product: 	82801G (ICH7 Family) PCI Express Port 2
vendor: 	Intel Corporation
physical id: 	1c.1
bus info: 	pci@0000:00:1c.1
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	pci pciexpress msi pm normal_decode bus_master cap_list
configuration:	
driver	=	pcieport-driver
id:	usb:0
description: 	USB Controller
product: 	82801G (ICH7 Family) USB UHCI #1
vendor: 	Intel Corporation
physical id: 	1d
bus info: 	pci@0000:00:1d.0
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	uhci bus_master
configuration:	
driver	=	uhci_hcd
latency	=	0
module	=	uhci_hcd
id:	usbhost
product: 	UHCI Host Controller
vendor: 	Linux 2.6.19-1.2895.fc6 uhci_hcd
physical id: 	1
bus info: 	usb@1
logical name: 	usb1
version: 	2.06
capabilities: 	usb-1.10
configuration:	
driver	=	hub
maxpower	=	0mA
slots	=	2
speed	=	12.0MB/s
id:	
usb:0
description: 	Keyboard
product: 	DELL USB Keyboard
vendor: 	DELL
physical id: 	1
bus info: 	
usb@1:1
version: 	1.04
capabilities: 	usb-1.10
configuration:	
driver	=	usbhid
maxpower	=	100mA
speed	=	1.5MB/s
id:	usb:1
description: 	Mouse
product: 	Optical USB Mouse
vendor: 	Logitech
physical id: 	2
bus info: 	
usb@1:2
version: 	3.40
capabilities: 	usb-2.00
configuration:	
driver	=	usbhid
maxpower	=	100mA
speed	=	1.5MB/s
id:	usb:1
description: 	USB Controller
product: 	82801G (ICH7 Family) USB UHCI #2
vendor: 	Intel Corporation
physical id: 	1d.1
bus info: 	pci@0000:00:1d.1
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	uhci bus_master
configuration:	
driver	=	uhci_hcd
latency	=	0
module	=	uhci_hcd
id:	usbhost
product: 	UHCI Host Controller
vendor: 	Linux 2.6.19-1.2895.fc6 uhci_hcd
physical id: 	1
bus info: 	usb@2
logical name: 	usb2
version: 	2.06
capabilities: 	usb-1.10
configuration:	
driver	=	hub
maxpower	=	0mA
slots	=	2
speed	=	12.0MB/s
id:	usb
description: 	Generic USB device
product: 	PC Camera
vendor: 	Z-Star Corp.
physical id: 	1
bus info: 	usb@2:1
version: 	1.00
capabilities: 	usb-1.10
configuration:	
driver	=	zc0301
maxpower	=	160mA
speed	=	12.0MB/s
id:	usb:2
description: 	USB Controller
product: 	82801G (ICH7 Family) USB UHCI #3
vendor: 	Intel Corporation
physical id: 	1d.2
bus info: 	pci@0000:00:1d.2
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	uhci bus_master
configuration:	
driver	=	uhci_hcd
latency	=	0
module	=	uhci_hcd
id:	usbhost
product: 	UHCI Host Controller
vendor: 	Linux 2.6.19-1.2895.fc6 uhci_hcd
physical id: 	1
bus info: 	usb@3
logical name: 	usb3
version: 	2.06
capabilities: 	usb-1.10
configuration:	
driver	=	hub
maxpower	=	0mA
slots	=	2
speed	=	12.0MB/s
id:	usb:3
description: 	USB Controller
product: 	82801G (ICH7 Family) USB UHCI #4
vendor: 	Intel Corporation
physical id: 	1d.3
bus info: 	pci@0000:00:1d.3
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	uhci bus_master
configuration:	
driver	=	uhci_hcd
latency	=	0
module	=	uhci_hcd
id:	usbhost
product: 	UHCI Host Controller
vendor: 	Linux 2.6.19-1.2895.fc6 uhci_hcd
physical id: 	1
bus info: 	usb@4
logical name: 	usb4
version: 	2.06
capabilities: 	usb-1.10
configuration:	
driver	=	hub
maxpower	=	0mA
slots	=	2
speed	=	12.0MB/s
id:	usb:4
description: 	USB Controller
product: 	82801G (ICH7 Family) USB2 EHCI Controller
vendor: 	Intel Corporation
physical id: 	1d.7
bus info: 	pci@0000:00:1d.7
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	pm debug ehci bus_master cap_list
configuration:	
driver	=	ehci_hcd
latency	=	0
module	=	ehci_hcd
id:	usbhost
product: 	EHCI Host Controller
vendor: 	Linux 2.6.19-1.2895.fc6 ehci_hcd
physical id: 	1
bus info: 	usb@5
logical name: 	usb5
version: 	2.06
capabilities: 	usb-2.00
configuration:	
driver	=	hub
maxpower	=	0mA
slots	=	8
speed	=	480.0MB/s
id:	usb
description: 	Mass storage device
product: 	LaCie DVDRW USB
vendor: 	LaCie
physical id: 	7
bus info: 	usb@5:7
logical name: 	scsi2
version: 	0.00
serial: 	10000E000C4D6693
capabilities: 	usb-2.00 scsi emulated scsi-host
configuration:	
driver	=	usb-storage
maxpower	=	0mA
speed	=	480.0MB/s
id:	cdrom
description: 	SCSI CD-ROM
product: 	CD/DVDW SH-S162L
vendor: 	TSSTcorp
physical id: 	0.0.0
bus info: 	scsi@2:0.0.0
version: 	LC01
capabilities: 	removable
id:	pci:3
description: 	PCI bridge
product: 	82801 PCI Bridge
vendor: 	Intel Corporation
physical id: 	1e
bus info: 	pci@0000:00:1e.0
version: 	e1
width: 	32 bits
clock: 	33MHz
capabilities: 	pci subtractive_decode bus_master cap_list
id:	network
description: 	Ethernet interface
product: 	RTL-8139/8139C/8139C+
vendor: 	Realtek Semiconductor Co., Ltd.
physical id: 	2
bus info: 	pci@0000:04:02.0
logical name: 	eth0
version: 	10
serial: 	00:e0:7d:ca:43:1f
size: 	100MB/s
capacity: 	100MB/s
width: 	32 bits
clock: 	33MHz
capabilities: 	pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd
100bt 100bt-fd autonegotiation
configuration:	
autonegotiation	=	on
broadcast	=	yes
driver	=	8139too
driverversion	=	0.9.28
duplex	=	full
latency	=	64
link	=	yes
maxlatency	=	64
mingnt	=	32
module	=	8139too
multicast	=	yes
port	=	MII
speed	=	100MB/s
id:	multimedia
description: 	Multimedia audio controller
product: 	82801G (ICH7 Family) AC'97 Audio Controller
vendor: 	Intel Corporation
physical id: 	1e.2
bus info: 	pci@0000:00:1e.2
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	pm bus_master cap_list
configuration:	
driver	=	Intel ICH
latency	=	0
module	=	snd_intel8x0
id:	isa
description: 	ISA bridge
product: 	82801GB/GR (ICH7 Family) LPC Interface Bridge
vendor: 	Intel Corporation
physical id: 	1f
bus info: 	pci@0000:00:1f.0
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	isa bus_master cap_list
configuration:	
latency	=	0
id:	ide:0
description: 	IDE interface
product: 	82801G (ICH7 Family) IDE Controller
vendor: 	Intel Corporation
physical id: 	1f.1
bus info: 	pci@0000:00:1f.1
version: 	01
width: 	32 bits
clock: 	33MHz
capabilities: 	ide bus_master
configuration:	
driver	=	PIIX_IDE
latency	=	0
id:	
ide
description: 	IDE Channel 0
physical id: 	0
bus info: 	ide@0
logical name: 	
ide0
clock: 	33MHz
id:	
cdrom
description: 	DVD writer
product: 	HL-DT-ST DVD+/-RW GWA4164B
physical id: 	0
bus info: 	ide@0.0
logical name: 	/dev/hda
version: 	D108
capabilities: 	packet atapi cdrom removable nonmagnetic dma lba iordy audio cd-r
cd-rw dvd dvd-r
configuration:	
mode	=	udma2
status	=	nodisc
id:	
ide:1
description: 	IDE interface
product: 	82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE
vendor: 	Intel Corporation
physical id: 	1f.2
bus info: 	pci@0000:00:1f.2
logical name: 	scsi0
logical name: 	scsi1
version: 	01
width: 	32 bits
clock: 	66MHz
capabilities: 	ide pm bus_master cap_list emulated
configuration:	
driver	=	ata_piix
latency	=	0
module	=	ata_piix
id:	disk:0
description: 	SCSI Disk
product: 	WDC WD1600JS-75M
vendor: 	ATA
physical id: 	0
bus info: 	scsi@0:0.0.0
logical name: 	/dev/sda
version: 	03.0
serial: 	WD-WMANM1309447
size: 	149GB
capabilities: 	partitioned partitioned:dos
configuration:	
ansiversion	=	5
id:	volume:0
description: 	HPFS/NTFS partition
physical id: 	1
bus info: 	scsi@0:0.0.0,1
logical name: 	/dev/sda1
capacity: 	59GB
capabilities: 	primary bootable
id:	volume:1
description: 	Linux filesystem partition
physical id: 	2
bus info: 	
scsi@0:0.0.0,2
logical name: 	/dev/sda2
capacity: 	101MB
capabilities: 	primary
id:	volume:2
description: 	Linux filesystem partition
physical id: 	3
bus info: 	scsi@0:0.0.0,3
logical name: 	/dev/sda3
capacity: 	89GB
capabilities: 	primary
id:	disk:1
description: 	SCSI Disk
product: 	ST3200822AS
vendor: 	ATA
physical id: 	1
bus info: 	scsi@1:0.0.0
logical name: 	/dev/sdb
version: 	3.01
serial: 	5LJ143PY
size: 	186GB
capabilities: 	partitioned partitioned:dos
configuration:	
ansiversion	=	5
id:	volume:0
description: 	HPFS/NTFS partition
physical id: 	1
bus info: 	scsi@1:0.0.0,1
logical name: 	/dev/sdb1
capacity: 	3333MB
capabilities: 	primary bootable
id:	volume:1
description: 	Linux swap / Solaris partition
physical id: 	2
bus info: 	scsi@1:0.0.0,2
logical name: 	/dev/sdb2
capacity: 	1098MB
capabilities: 	primary nofs
id:	volume:2
description: 	Linux filesystem partition
physical id: 	3
bus info: 	scsi@1:0.0.0,3
logical name: 	/dev/sdb3
capacity: 	181GB
capabilities: 	primary
id:	serial
description: 	SMBus
product: 	82801G (ICH7 Family) SMBus Controller
vendor: 	Intel Corporation
physical id: 	1f.3
bus info: 	pci@0000:00:1f.3
version: 	01
width: 	32 bits
clock: 	33MHz
configuration:	
driver	=	i801_smbus
latency	=	0
module	=	i2c_i80



[root@localhost ~]# uname -rm
2.6.19-1.2895.fc6 i686



[root@localhost ~]# dmesg | grep -i usb
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
usbcore: registered new interface driver libusual
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
USB Universal Host Controller Interface driver v3.0
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
usb 1-1: new low speed USB device using uhci_hcd and address 2
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb5: configuration #1 chosen from 1 choice
hub 5-0:1.0: USB hub found
usb 1-1: device not accepting address 2, error -71
Initializing USB Mass Storage driver...
usb 5-7: new high speed USB device using ehci_hcd and address 5
usb 5-7: configuration #1 chosen from 1 choice
libusual: request for usb-storage succeeded, but module is not present
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb 1-1: new low speed USB device using uhci_hcd and address 4
usb 1-1: configuration #1 chosen from 1 choice
input: DELL DELL USB Keyboard as /class/input/input0
input: USB HID v1.10 Keyboard [DELL DELL USB Keyboard] on usb-0000:00:1d.0-1
usb 1-2: new low speed USB device using uhci_hcd and address 5
usb 1-2: configuration #1 chosen from 1 choice
input: Logitech Optical USB Mouse as /class/input/input1
input: USB HID v1.10 Mouse [Logitech Optical USB Mouse] on usb-0000:00:1d.0-2
usb 2-1: new full speed USB device using uhci_hcd and address 2
usb 2-1: configuration #1 chosen from 1 choice
usb-storage: device scan complete
usb 2-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8/0x301B)
usb 2-1: PB-0330 image sensor detected
usb 2-1: Initialization succeeded
usb 2-1: V4L2 device registered as /dev/video0
usbcore: registered new interface driver zc0301



[root@localhost ~]# lsusb
Bus 002 Device 001: ID 0000:0000  
Bus 002 Device 002: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam
Bus 004 Device 001: ID 0000:0000  
Bus 003 Device 001: ID 0000:0000  
Bus 005 Device 001: ID 0000:0000  
Bus 005 Device 005: ID 059f:0663 LaCie, Ltd 
Bus 001 Device 001: ID 0000:0000  
Bus 001 Device 005: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Bus 001 Device 004: ID 413c:2005 Dell Computer Corp. 
Comment 7 Steve 2007-01-22 01:15:41 EST
my usb error went away, i have kernel:
2.6.18-1.2869.fc6
Comment 8 Luis Felipe Marzagao 2007-01-22 08:18:47 EST
Hello, Steve. What was your error message?

Mine is "usb 1-1: device not accepting address 2, error -71" and it´s there 
even after the 2.6.19-1.2895.fc6 kernel.

My machine: Dell GX620, as described above.
Comment 9 Steve 2007-02-20 22:43:11 EST
usb 1-1: device not accepting address 2, error -71

with kernel
2.6.19-1.2895.fc6

Sorry for the misinformation on #7, the error never went away, I stopped
noticing it on bootup but i checked dmesg and its still there

again this usb error was not present in FC5
probably a kernel config error? doesn't appear to have any affect on usb ports,
all work. and most likely im guessing this will be sorted out in Fedora 7 as its
probably something really simple.
Comment 10 Mike Cohler 2007-09-18 11:11:49 EDT
It is still there in F7. So not resolved.
Comment 11 Pete Zaitcev 2007-09-18 14:13:06 EDT
I'm pretty sure it's the mkinitrd. The easy way to test is to edit /sbin/mkinitrd
and make sure all "findmodule ehci_hcd" are first (there should be only one where
it's in the back, in another instance it's in front already). This was fixed in
Rawhide, but I doubt anyone would port it to F7. After all the error is purely
cosmetic.
Comment 12 Mike Cohler 2007-09-18 15:03:45 EDT
Thank you Pete,
I presume that you mean where in F7 the three lines of relevance are:
if [ "$withusb" == "1" ]; then
    findmodule uhci-hcd
    findmodule ohci-hcd
    findmodule ehci-hcd
I checked the current rawhide mkinitrd and they are in a different order i.e.
if [ "$withusb" == "1" ]; then
    findmodule ehci-hcd
    findmodule ohci-hcd
    findmodule uhci-hcd
I will be away from that machine until the weekend but can test this when I get
back and report back. As you say this is cosmetic. If this simple change does
remove the boot message then I will close this bug.
Mike

Comment 13 Mike Cohler 2007-09-18 15:23:45 EDT
I managed to squeeze in a test this evening - changed the mkinitrd but the
message remains. Using 2.6.22.5-76.fc7. Hand edited mkinitrd to put ehci-hcd
line first.
I will attach the dmesg file.
Comment 14 Mike Cohler 2007-09-18 15:24:54 EDT
Created attachment 198751 [details]
dmesg in F7 after boot with edited mkinitrd
Comment 15 Mike Cohler 2007-09-18 15:26:07 EDT
Hardware profile is at
http://smolt.fedoraproject.org/show?UUID=4f808a9b-fa8a-48b5-8170-4a531cc1e107
Comment 16 Pete Zaitcev 2007-09-18 15:28:26 EDT
But did you re-generate the initrd? The dmesg shows that ehci_hcd is loaded
last so perhaps you didn't. You'll need to do something like:

cd /boot
mv initrd-2.6.22.5-76.fc7.img initrd-2.6.22.5-76.fc7.img.save
mkinitrd initrd-2.6.22.5-76.fc7.img 2.6.22.5-76.fc7
reboot
Comment 17 Mike Cohler 2007-09-18 15:39:17 EDT
I just realised I probably need to do more than just reboot (which is all I
did!) - I presume that it is necessary to create a new initrd using the modified
mkinitrd? However I will need to do some reading and that will have to wait
until next weekend. If you could give a guide as to the the steps needed to do
this I would appreciate it if you could post here ( or point to a link ?).

Or is it easier to boot to the previous kernel, and re-install the new kernel
with the amended mkinitrd in place?

Thanks
Mike
Comment 18 Mike Cohler 2007-09-18 15:40:49 EDT
Yes - our edits crossed!  Indeed I will do exactly that (i.e. from #16) and
report back!
Comment 19 Mike Cohler 2007-09-18 15:48:51 EDT
Following the commands in #16 to regenerate initrd this now resolves this bug
and the boot message goes away as you correctly suggested. Therefore this bug
can be closed as resolved for next release.
Many thanks
Mike

Note You need to log in before you can comment on or make changes to this bug.