Bug 213435 - (radeon-gart-size) Radeon (ATI) garbage with composite WM
Radeon (ATI) garbage with composite WM
Status: CLOSED DUPLICATE of bug 203282
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 09:50 EST by Jeppe R. Andersen
Modified: 2009-07-24 08:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 18:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.62 KB, text/plain)
2006-12-30 09:14 EST, Jeppe R. Andersen
no flags Details
Xorg.0.log corresponding to xorg.conf (44.90 KB, text/plain)
2006-12-30 09:16 EST, Jeppe R. Andersen
no flags Details
Xorg.0.log corresponding to no xorg.conf (46.48 KB, text/plain)
2006-12-30 09:17 EST, Jeppe R. Andersen
no flags Details

  None (edit)
Description Jeppe R. Andersen 2006-11-01 09:50:35 EST
Description of problem:
If the composite window manager and Desktop Effects are enabled when resolution
is above 1024x768 then the right hand side of the screen becomes garbage (and
panels stop functioning as a result). Using
Radeon R250 [Mobility FireGL 9000] (rev 02)

Version-Release number of selected component (if applicable):
All packages up-to-date as of Nov 1.

How reproducible:
every time

Steps to Reproduce:
1. Choose resolution above 1024x768
2. Enable Desktop effects

Actual results:
right hand side of screen garbage

Expected results:
nice desktop effects.

Additional info:
Comment 1 Bill Case 2006-11-11 12:58:17 EST
Same problem (kinda).  Re-installed from FC5 to FC6; display resolution changed
from 1280x1024 to 1600x1200.

My display has ground almost to a halt.  Screen redrawing is painfully
slow.  Various application gui are missplacing themselves on the screen
even after repositioning them after installing a higher resolution and
bunch of other small config things are going wrong.  Saving sessions
isn't working.

'Desktop Effects' cannot be enabled.

I am using a wallpaper (*.jpg) on my desktop.  I have an ATI rage 128
SM/4x AGP/4x Expert 2000.  My # Xorg configuration created by
system-config-display says:

Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "r128"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1600x1200" "1600x1200" "1600x1024" "1600x1024"
"1440x900"
"1440x900" "1400x1050" "1400x1050" "1280x1024" "1280x1024" "1280x960"
"1280x960" "1280x800" "1280x800" "1152x864" "1152x864" "1152x768"
"1152x768" "1024x768" "1024x768" "800x600" "800x600" "640x480" "640x480"
        EndSubSection
EndSection

FC6 installed the display at 1600x1200 resolution when it was previously
running 1280x1024 in FC5.  (I prefer the 1600x1200 now that I've gotten
used to it.)  I have a Compaq V90 monitor, installed as a generic CRT.

Some other problems that may be related
- TV reception using tvtime is unstable.
- slow redraw
- 'Chess' crashes; command line says GL: Warning: RenderTexture size is
restricted to size of framebuffer. If you are on Linux, consider using
GLX instead of SDL.
- 'Stellarium' produces unclear text
- Sessions problems
        - evolution 2.8.1.1 doesn't save its sizing
        - can't start as panel icons - insist on starting maximum
                - notecase [filename]
                - stickynotes_applet
                - xchat-gnome
        - want to start background wallpaper first
- mail summary opens at random positions not top right as configured

I have added the following lines to xorg.conf.  They are a direct lift
from the FC5 xorg.conf I used to use.

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "COMPAQ V90"
        DisplaySize 350 270
 ### Comment all HorizSync and VertSync values to use DDC:
        HorizSync    30.0 - 94.0
        VertRefresh  48.0 - 160.0
        Option      "dpms"
EndSection

Section "DRI"
        Group        0
        Mode         0666
EndSection      

I seemed to be missing monitor, DRI and compiz components, but I am not
sure they are necessary.
Comment 2 Martin K. Petersen 2006-11-25 21:01:38 EST
If I enable desktop effects on my Mac mini (G4, Radeon 9200, FC6) the screen
becomes garbled.  compiz works, but the display is distorted color-wise.  It
also looks like the width of the display is being truncated to (my guess) 640px.
 The GNOME panels and all windows shrink accordingly.  The height of the display
is unchanged.

After reading this bugzilla ticket I tried to reduce the resolution to below
1024x768 but the display remains garbled regardless of resolution.  I also tried
16-bit instead of 24.  No go.  Just for kicks I tried EXA instead of XAA but
that doesn't work at all (X server dies instantly).
Comment 3 Matěj Cepl 2006-12-28 16:30:17 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Jeppe R. Andersen 2006-12-30 09:14:30 EST
Created attachment 144578 [details]
xorg.conf
Comment 5 Jeppe R. Andersen 2006-12-30 09:16:26 EST
Created attachment 144579 [details]
Xorg.0.log corresponding to xorg.conf
Comment 6 Jeppe R. Andersen 2006-12-30 09:17:03 EST
Created attachment 144580 [details]
Xorg.0.log corresponding to no xorg.conf
Comment 7 Bill Case 2006-12-30 13:04:30 EST
Resloved the problems (somewhat) by buying a Radeon 9600 video card and a ATI TV
wonder 550.  Each of them now have their own problems.
Comment 8 Martin K. Petersen 2007-01-27 22:17:26 EST
Aside from my G4 Mac mini mentioned above, this problem also occurs on:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE] (1002:5159)

as well as

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
(1002:4c59)

Both cases on i386 with all updates.

Comment 9 Adam Jackson 2007-04-02 18:07:18 EDT
This appears to be the classic texture sizing bug.  I'm working on code to size
the GART aperture more intelligently so we'll hit this less often.
Comment 10 Joachim Frieben 2007-09-15 10:12:10 EDT
Looks like a duplicate of bug 203282 where a workaround [namely adding a
suitable drirc file] is described.
Comment 11 Matěj Cepl 2007-10-05 18:19:31 EDT

*** This bug has been marked as a duplicate of 203282 ***

Note You need to log in before you can comment on or make changes to this bug.