Bug 203282 - Window size is limited to maximum texture size
Window size is limited to maximum texture size
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
bzcl34nup
:
: 201630 203602 212605 radeon-gart-size (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-20 11:53 EDT by Joachim Frieben
Modified: 2008-08-07 08:27 EDT (History)
10 users (show)

See Also:
Fixed In Version: compiz-0.7.6-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 20:45:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-08-20 11:53:22 EDT
Description of problem:
Using "compiz" on my desktop systen sporting an "Radeon 7200 PCI (R100)"
graphics card, the screen is essentially corrupted. The right third of
the screen exhibits a random bluish patter which is probably somehow
related to the chosen "Blue type" background. The "GNOME" panels are
visible with drop shadows but without any icons; they are simply grey
bars stretching horizontally over 2/3 of the visible screen.
Moreover, it's not possible to access any menu. Similarly, no icon is
shown on the desktop. However, upon clicking the right mouse button,
it is possible to open a new folder and access already existing folders,
too. In this way, a "GNOME Terminal" window can be opened and moved.
It exhibits visual effects such as drop shadows, wobbling, and
transparency.

Version-Release number of selected component (if applicable):
compiz-0.0.13-0.16.20060817git.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Log in "GNOME" session.
  
Actual results:
The desktop is rendered, but it is partially corrupted, and the
panels are rendered grey only and do not respond.

Expected results:
A functional "GNOME" desktop is displayed.

Additional info:
Apart from the current issue, hardware rendering works nicely for the
affected "R100" chip. In particular, "OpenGL" screen savers are fully
operational when hardware rendering is active. The system corresponds
to "FC6T2 plus numerous "rawhide" updates including current:
"xorg-x11-server-Xorg-1.1.1-24.fc6", "mesa-*-6.5-22.20060818cvs.fc6",
and "compiz-0.0.13-0.16.20060817git.fc6".
Comment 1 Joachim Frieben 2006-08-23 07:42:54 EDT
The "drirc" file provided by K. Høgsberg in:

https://www.redhat.com/archives/fedora-devel-list/2006-August/msg00786.html

resolves the issue. After adding this file, the desktop is rendered
correctly with all compositing effects (apart from a system lock-up when
the desktop effects get again disabled (bug 203707)). It might be worth
considering adding this "drirc" file somehow to the standard setup.
Moreover, this would allow to get rid of these annoying "mesa" complaints
about "/etc/drirc" or "$HOME/.drirc" missing!
Comment 2 Kristian Høgsberg 2006-08-23 14:51:01 EDT
This is a known problem and we're trying to come up with a better solution than
the /etc/drirc file.
Comment 3 Kristian Høgsberg 2006-08-28 15:45:04 EDT
*** Bug 203602 has been marked as a duplicate of this bug. ***
Comment 4 Kristian Høgsberg 2006-09-18 13:57:25 EDT
Editing summary, making this bug the master bug for the texture size limit bug.
Comment 5 Kristian Høgsberg 2006-09-18 13:57:32 EDT
*** Bug 201630 has been marked as a duplicate of this bug. ***
Comment 6 Joachim Frieben 2007-02-03 15:30:30 EST
Issue still present for "F7T1".
Comment 7 Joachim Frieben 2007-06-10 04:25:25 EDT
Issue still present for "F7" final.
Comment 8 Matěj Cepl 2007-10-05 18:19:32 EDT
*** Bug 213435 has been marked as a duplicate of this bug. ***
Comment 9 Matěj Cepl 2007-10-05 18:25:45 EDT
*** Bug 212605 has been marked as a duplicate of this bug. ***
Comment 10 Bug Zapper 2008-04-03 13:59:45 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 11 Bug Zapper 2008-05-06 20:45:30 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp
Comment 12 Joachim Frieben 2008-08-06 12:57:59 EDT
I have had the possibility to install current F9 w/updates on the test system equipped with a Radeon R100 QD [Radeon 7200] being connected to an HP A4576A running at 1400x1050@24bpp. Desktop effcts now work as expected across the entire screen.
Comment 13 Greg Wasson 2008-08-06 18:58:14 EDT
(In reply to comment #12)
> I have had the possibility to install current F9 w/updates on the test system
> equipped with a Radeon R100 QD [Radeon 7200] being connected to an HP A4576A
> running at 1400x1050@24bpp. Desktop effcts now work as expected across the
> entire screen.

Works for me also with F9, 1400x1050@24bpp, but performance is so slow that it is not usable. With F7 I could run the same resolution, but at 16bpp and the response was great. Under F9, if I try running at 16bpp Desktop Effects cannot be enabled. Changing to 24bpp allows them to be enabled, but the desktop response is too slow to be used.
Comment 14 Joachim Frieben 2008-08-07 08:27:51 EDT
(In reply to comment #13)
> .. but the desktop response is too slow to be used.

Check you Xorg.0.log file:

(II) RADEON(0): Max desktop size set to 2048x1200
(II) RADEON(0): For a larger or smaller max desktop size, add a Virtual
                line to your xorg.conf
(II) RADEON(0): If you are having trouble with 3D, reduce the desktop
                size by adjusting the Virtual line to your xorg.conf

After setting "Virtual 1408 1056", even the workspace cube is usable
for me.

Note You need to log in before you can comment on or make changes to this bug.