Bug 213444 - system-config-display does not change resolution in FC6
system-config-display does not change resolution in FC6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
: 215082 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 10:13 EST by Richard Steck
Modified: 2008-08-02 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: f7-current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 19:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Steck 2006-11-01 10:13:00 EST
Description of problem:

In FC6, system-config-display does not change display resolutions. Display 
resolution persists at its initial 1280x1024 even though the generic CRT 
monitor is capable of lower resolutions.

My FC6 is installed on an Intel DG965SS motherboard with an Intel Integrated 
Graphics Controller and model i810 Integrated Graphics chipset.  FC6 works well 
in all respects except this display resolution issue.

When I select 1024 x 768, system-config-display changes /etc/X11/xorg.conf from:

--------------------
Section "Device"
Identifier "Videocard0"
Driver "i810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
--------------------

to:

--------------------
Section "Device"
Identifier "Videocard0"
Driver "i810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "1024x7
68" "800x600" "800x600" "640x480" "640x480"
EndSubSection
EndSection

--------------------

Version-Release number of selected component (if applicable):


How reproducible:  Please see steps below.
   
Steps to Reproduce:
1. In FC6 Gnome, go to System > Administration > Display. 

2. Change resolution from default 1280x1024 to another resolution, say  
1024x768.

3.Reboot.

4. Resolution should change to new value.  It does not.
  
Actual results:
Screen resolution does not change after reboot.

Expected results:
Screen resolution should change to 1024x768 after reboot.

Additional info:

I even tried  installing Linux with  a   resolution=1024x768   install 
parameter but the resolution stayed glued to 1280x1024.   

Also tried option "UseEDID" "false"  without success.
Comment 1 John E. Harbold 2006-11-02 21:05:01 EST
I too have this same problem.  After upgrading to Fedora Core 6, I tried to
change the screen resolution using Ctrl-Alt-'+' and Ctrl-Alt-'-' to no avail. 
This feature was available from Fedora Core 5 and below.  Some of us don't have
the visual acuity we had in earlier years.  I need this feature to read the fine
print on some webpages.
Comment 2 Douglas Otis 2006-12-03 07:32:22 EST
With a Viewsonic VX2035mx-1 (1680x1050) lcd display and an Nvidia Geforce2 400mx
display adapter, setup fails to detect the lcd resolution and sets it at 800x600
and 640x480.  When  "1680x1050" "1280x1024" "1024x768" are prepended to the
Modes line in the xorg.conf file, the display defaults to 1440x1050 but shows
1680x1050.  To obtain 1680x1050, 1440x150 must be selected and then the display
adapter runs at 1680x1050.  The screen is then scrambled when a password prompt
pops up after the screen saver shuts down the diaplay.

The VIA UniChrome Pro video adapter embedded in the VT8237 chipset and the evesa
driver would not permit a setting that kept the horizontal settings from 90khz
even with HorizSync 30.0 - 82.0 and VertRefresh  50.0 - 85.0 lines added to the
Monitor section.
Comment 3 John E. Harbold 2006-12-14 21:14:08 EST
Thank you for fixing this bug!  You are a true mensch!  I finally can read the
punchlines of Zippy the Pinhead!  Are we changing resolutions yet?
Comment 4 Matthias Clasen 2007-02-02 14:05:02 EST
*** Bug 215082 has been marked as a duplicate of this bug. ***
Comment 5 Matěj Cepl 2007-10-02 17:46:06 EDT
Since this bugzilla report was filed, there have been several updates, which may
have resolved this issue. Users who have experienced this problem are encouraged
to upgrade their system to the latest version of their distribution available.

Please, if you experience this problem on the up-to-date system, let us now in
the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as
INSUFFICIENT_DATA. Thank you.
Comment 6 Richard Steck 2007-10-02 19:52:44 EDT
Problem resolved in F7  and current kernel.
Thank you.

Note You need to log in before you can comment on or make changes to this bug.