Bug 213500 - Flash 9.0.21.78 Deadlock 100% Reproducible Deadlock
Flash 9.0.21.78 Deadlock 100% Reproducible Deadlock
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: flash-plugin (Show other bugs)
4.4
All Linux
high Severity urgent
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: flash_el4
  Show dependency treegraph
 
Reported: 2006-11-01 13:21 EST by Warren Togami
Modified: 2007-11-16 20:14 EST (History)
4 users (show)

See Also:
Fixed In Version: flash-plugin-9.0.31.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 13:32:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-11-01 13:21:05 EST
http://www.ft.com/cms/s/0d46fa52-68f6-11db-b4c2-0000779e2340.html

Visiting this article on ft.com causes the entire browser to deadlock after it
has rendered most of the page.

(gdb) bt
#0  0x00c815d9 in __lll_mutex_lock_wait () from /lib/libpthread.so.0
#1  0x00c7f480 in pthread_cond_signal@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x022b3c47 in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#3  0x02463371 in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#4  0x024644d6 in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#5  0x024648e6 in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#6  0x02464c1f in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#7  0x025b00a8 in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#8  0x02296deb in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#9  0x0222a02e in NP_Shutdown () from /usr/lib/flash-plugin/libflashplayer.so
#10 0x054d9916 in g_source_get_current_time () from /lib/libglib-2.0.so.0
#11 0x054d9342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#12 0x054dc31f in g_main_context_check () from /lib/libglib-2.0.so.0
#13 0x054dc6c9 in g_main_loop_run () from /lib/libglib-2.0.so.0
#14 0x058adbe4 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x00821feb in nsAppShell::Run (this=0x9aad818) at nsAppShell.cpp:139
#16 0x004c1f86 in nsAppStartup::Run (this=0x9aad7d8) at nsAppStartup.cpp:150
#17 0x0804f66f in XRE_main (argc=3, argv=0xbff59de4, aAppData=0x8065480) at
nsAppRunner.cpp:2374
#18 0x0804ab90 in main (argc=Cannot access memory at address 0x0
) at nsBrowserApp.cpp:61
#19 0x00b19f2c in __libc_start_main () from /lib/libc.so.6
#20 0x0804aae1 in _start ()

This gdb traceback indicates that the deadlock happens due to Flash Player. 
Removal of flash-plugin confirms this, as the page avoids the browser deadlock.

http://people.redhat.com/wtogami/temp/ft-flash-deadlock.tar.bz2
I saved the HTML and all components into this .tar.bz2.  Unpack this into a
directory and open it with the browser.  Interestingly, the behavior here too
causes a deadlock, but also other behavior.

http://people.redhat.com/wtogami/temp/ft-flash1.png
http://people.redhat.com/wtogami/temp/ft-flash2.png
Sometimes one or both of these windows pop-up before the browser deadlocks. 
Sometimes the browser just deadlocks after it has fully rendered the page. 
Perhaps these warning pop-ups are related to this problem?

Software Versions
=================
firefox-1.5.0.7-8.fc6
flash-plugin-9.0.21.55
Comment 1 Warren Togami 2006-11-21 11:35:53 EST
The original FT.com link mentioned above was 'fixed' by the publication to
longer use the offending Flash.  But I am still able to reproduce this deadlock
using the tar.bz2 archived copy of that page with the Flash 9 beta2 (9.0.21.78).
 Please advise.
Comment 2 Warren Togami 2006-11-27 13:29:35 EST
Unfortunately, I am running into exactly this Flash induced deadlock in many
other sites now.  This is a quite critical issue.
Comment 3 Warren Togami 2006-12-11 23:48:35 EST
Hello Adobe,

Is this issue known and being tracked by your testing and development?

This deadlock is becoming far too prevalent and is unfortunately crippling for
the web experience.
Comment 4 Warren Togami 2006-12-12 17:39:52 EST
Great, Adobe informs me that they have fixed this issue.  Verification is
forthcoming.

Note You need to log in before you can comment on or make changes to this bug.