Bug 213557 - gnome-settings-daemon crashes when loggin in
gnome-settings-daemon crashes when loggin in
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libxklavier (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
: 213814 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 18:05 EST by Christophe Lambin
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.0-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 06:37:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug buddy report (6.46 KB, text/plain)
2006-11-01 18:05 EST, Christophe Lambin
no flags Details
gnome-settings-daemon-bugreport with debuginfo (7.94 KB, text/plain)
2006-11-03 06:48 EST, Denis
no flags Details
backtrace from bug-buddy (7.39 KB, text/plain)
2006-11-03 14:51 EST, Sertaç Ö. Yıldız
no flags Details
bug buddy report about gnome-settings-daemon crash (7.34 KB, text/plain)
2006-11-04 07:32 EST, Alexey Bozrikov
no flags Details
Debug information from gnome-settings-daemon (3.37 KB, text/plain)
2007-01-14 20:27 EST, Brian Wright
no flags Details

  None (edit)
Description Christophe Lambin 2006-11-01 18:05:50 EST
Description of problem:
When I log in, bug buddy's reporting that gnome-settings-daemon has crashed.

Version-Release number of selected component (if applicable):
control-center-2.16.0-9.fc6

How reproducible:
Always
Comment 1 Christophe Lambin 2006-11-01 18:05:50 EST
Created attachment 140054 [details]
bug buddy report
Comment 2 Eric Lambart 2006-11-02 23:43:41 EST
looks like version should be fc6
Comment 3 Ray Strode [halfline] 2006-11-02 23:54:15 EST
*** Bug 213814 has been marked as a duplicate of this bug. ***
Comment 4 Denis 2006-11-03 06:48:57 EST
Created attachment 140235 [details]
gnome-settings-daemon-bugreport with debuginfo
Comment 5 Denis 2006-11-03 06:50:09 EST
same thing on fc6 x86_64
Comment 6 Sertaç Ö. Yıldız 2006-11-03 14:51:35 EST
Created attachment 140305 [details]
backtrace from bug-buddy

me, too...

I can reproduce with 'killall -vs 1 gnome-panel'. Only happens if keyboard
layout switching applet is on the panel.
Comment 7 Eric Lambart 2006-11-03 15:02:03 EST
I should mention that I also use the keyboard layout switching applet.

Perhaps I should have mentioned that before, since a problem appeared with the
applet about the same time as this gnome-settings-daemon problem started occurring:
  Instead of the former labels of "US", "DE" and "IT" it is now saying things
like "us" (lowercase), "de (no dead keys)" and "it (no dead keys").  I'm not
sure about the exact text because I am at work but the extra text is causing the
applet to take up 4-5 times as much space on my panel.

Additionally, this error may NOT have been triggered by a yum-update as I
suggested in bug #213814.  I do know I went into the keyboard preferences about
the same time, and changed a few things, so it may be the *saving* of new KB
preferences that triggers the issue.

Comment 8 Alexey Bozrikov 2006-11-04 07:32:39 EST
Created attachment 140349 [details]
bug buddy report about gnome-settings-daemon crash
Comment 9 Alexey Bozrikov 2006-11-04 07:34:08 EST
Same situation on my thinkpad notebook. Version:
control-center-2.16.0-9.fc6

when trying to add Russian Typewriter layout, gnome-settings-daemon crashes
immediately and being caught by Bug Buddy. The output of bug buddy is attached.
Layouts are being shown in lowercase afterwards. Removing
~/.gconf/desktop/gnome/peripherals/keyboard directory helps until I try to add
keyboard layout again.
Comment 10 Sertaç Ö. Yıldız 2006-11-05 07:29:53 EST
rebuilding the rawhide libxklavier-3.1-2 rpm fixed this for me. This might be a
duplicate of bug #213419.
Comment 11 Matthias Clasen 2006-11-05 08:42:47 EST
Please try the libxklavier-3.0-2.fc6 that is in updates-testing now.
Comment 12 petrosyan 2006-11-06 13:31:49 EST
I can't find libxklavier-3.0-2.fc6 in updates-testing
Comment 13 Miloš Komarčević 2006-11-06 18:35:30 EST
I can confirm here that libxklavier-3.0-2.fc6 from updates-testing works for me
after logout/login.
Comment 14 Eric Lambart 2006-11-07 00:27:41 EST
Yes, also worked for me although I had to restart the machine; logging out, and
even killing X, wouldn't work--when I tried to log in the UI froze each time. 
Strange.

Anyway, looks fine now after a reboot and thank you very much!

Ani/petrosyan--you should check the repository again--I assume the file took
some time to propogate to the mirrors.  I had to wait 24+hours before it appeared.
Comment 15 Vitaliy S 2006-11-10 11:16:31 EST
> I can confirm here that libxklavier-3.0-2.fc6 from updates-testing works for me
> after logout/login.

Updateing libxklavier from updates-testing does not work for me.


Comment 16 antonio montagnani 2006-11-16 06:04:29 EST
Same problem here:
How to you create a report? please note that I can't open a Terminal
Comment 17 antonio montagnani 2006-11-17 02:23:37 EST
I solved my problem re-installing d-bus packages (after latest updates I had a
gnome-settings-daemon crashing with some d-bus connected messages!!!
Googling around I found the solution (similar problem also in different distros)
Comment 18 Christophe Lambin 2006-11-18 11:02:32 EST
Haven't seen this since updating to libxklavier-3.0-2.fc6. The original problem
seems to be fixed.
Comment 19 Brian Wright 2007-01-14 20:27:33 EST
Created attachment 145547 [details]
Debug information from gnome-settings-daemon
Comment 20 Bastien Nocera 2007-02-15 06:37:03 EST
As the original reporter says that the problem is fixed, closing.

If you have other problems with gnome-settings-daemon crashing, please open new
bugs.

Note You need to log in before you can comment on or make changes to this bug.