Bug 213572 - Unable to add eclipse update sites
Unable to add eclipse update sites
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
: 214417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-01 20:22 EST by Russell Harrison
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.1-23.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 14:19:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Harrison 2006-11-01 20:22:43 EST
Description of problem:
I'm trying to add the EPIC update site so I can use it in the eclipse deployed
with FC6.  This worked in FC5.

Version-Release number of selected component (if applicable):
eclipse-platform-3.2.1-4.fc6

How reproducible:
Every time you atempt to add an update site.

Steps to Reproduce:
1. Open the eclipse workspace
2. Select : Help --> Software Updates --> Find and Install. . .

Actual results:
This error dialog is repeated every step:

Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.jdt.source_3.2.1.r321_v20060905-R4CM1Znkvre9wC-/".
[/usr/share/eclipse/features/org.eclipse.jdt.source_3.2.1.r321_v20060905-R4CM1Znkvre9wC-/feature.xml
(No such file or directory)]

Expected results:
I would be able to add a new update site and install the features in it.

Additional info:
Comment 1 Ben Konrath 2006-11-03 01:59:51 EST
This is a known bug. We will be releasing an update shortly to address this.
Thanks for the bug report.
Comment 2 Ben Konrath 2006-11-07 11:31:39 EST
*** Bug 214417 has been marked as a duplicate of this bug. ***
Comment 3 Russell Harrison 2006-11-19 10:10:50 EST
Any status on this update?  I saw on the dependent bug that there seems to be a
file missing that is present in the sdk?  Doesn't indicate there is only a
packaging issue?
Comment 4 Ben Konrath 2006-11-20 14:27:42 EST
The problem is that these file references are being cached at build time and put
in a location that users can't write to (/usr/share/eclipse/configuration/". We
removed this cache and the references will be created in "~/.eclipse/". You can
try test packages by doing this:

yum --enablerepo=updates-testing update 'eclipse*'

Please note that you will need to remove '~/.eclipse' for this update to work
correctly.
Comment 5 Russell Harrison 2006-11-20 16:32:32 EST
I can verify that the packages in updates-testing do fix the issue.
Comment 6 Ben Konrath 2006-12-06 14:19:44 EST
Great, thanks for your help :) We finnally pushed this fix to FC-6 updates
(3.2.1-23.fc6). 

Note You need to log in before you can comment on or make changes to this bug.