Bug 214417 - Eclipse update manager whines if no eclipse-rcp-sdk installed
Eclipse update manager whines if no eclipse-rcp-sdk installed
Status: CLOSED DUPLICATE of bug 213572
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 10:34 EST by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 11:31:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mary Ellen Foster 2006-11-07 10:34:44 EST
Description of problem:
With the default set of Eclipse packages installed -- platform, jdt, cdt, plus
dependencies -- trying to load the Eclipse update manager results in warnings
about missing features like the following:

Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.rcp.source_3.2.1.r321_v20060801-clWbqCmjexIWDqg/".
[/usr/share/eclipse/features/org.eclipse.rcp.source_3.2.1.r321_v20060801-clWbqCmjexIWDqg/feature.xml
(No such file or directory)]

Indeed, that file doesn't exist; it comes from the eclipse-rcp-sdk RPM.
Installing that made the warnings go away. I didn't check if this made the
update manager actually not work, but regardless it's an ugly warning.


Version-Release number of selected component (if applicable):
eclipse-platform-3.2.1-4.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install eclipse from FC6
2. Help -> Software Updates -> Find and Install
  
Actual results:
Dialogue box with above warning

Expected results:
No warning
Comment 1 Ben Konrath 2006-11-07 11:31:36 EST

*** This bug has been marked as a duplicate of 213572 ***
Comment 2 Francois Aucamp 2006-11-08 02:49:15 EST
Just to add some extra info, the "find & install updates" option worked fine for
me on a *fresh* Fedora Eclipse install; on later attempts I got the same error
message.
After installing eclipse-rcp-sdk, the updates worked fine, and I was able to
install PyDev. However, when I tried to update again later, I got a different
error message:

Error creating feature
"file:/usr/share/eclipse/features/org.eclipse.platform.source_3.2.1.r321_v20060921-MGDh_08KUYM-Bvn/".
[/usr/share/eclipse/features/org.eclipse.platform.source_3.2.1.r321_v20060921-MGDh_08KUYM-Bvn/feature.xml
(No such file or directory)]

This missing file is provided (according to yum) by "eclipse-platform-sdk". I
installed this (it pulls in 44MB with dependencies :-/ ), and now everything
works perfectly.

Note You need to log in before you can comment on or make changes to this bug.