Bug 213625 - libacl.la contains incorrect information on libattr.la place
libacl.la contains incorrect information on libattr.la place
Status: CLOSED DUPLICATE of bug 171114
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: acl (Show other bugs)
4.4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 06:39 EST by Andrey Klyachkin
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-27 14:29:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Klyachkin 2006-11-02 06:39:15 EST
Description of problem: 
/usr/lib/libacl.la from libacl-devel in RHEL4 contains incorrect information 
about location of libattr.la. 
 
$ cat /usr/lib/libacl.la | grep libattr.la 
dependency_libs=' /lib/libattr.la' 
$ find /lib -name 'libattr.la' 
$ find /usr/lib -name 'libattr.la' 
/usr/lib/libattr.la 
$ rpm -qf /usr/lib/libattr.la 
libattr-devel-2.4.16-3 
$ rpm -ql libattr-devel | grep libattr.la 
/usr/lib/libattr.la 
$ rpm -qf /usr/lib/libacl.la 
libacl-devel-2.2.23-5 
$ rpm -ql libacl-devel | grep libacl.la 
/usr/lib/libacl.la 
 
Version-Release number of selected component (if applicable): 
2.2.23-5 
 
How reproducible: 
 
 
Steps to Reproduce: 
1. $ cat /usr/lib/libacl.la | grep libattr.la 
dependency_libs=' /lib/libattr.la' 
   
Actual results: 
dependency_libs=' /lib/libattr.la' 
 
Expected results: 
dependency_libs=' /usr/lib/libattr.la' 
 
Additional info: 
Fix - rebuild acl packages with the following lines added to acl.spec in 
%build section: 
sed -e 's/\/lib\/libattr.la/\/usr\/lib\/libattr.la/g' libacl/.libs/libacl.lai 
>libacl.lai.tmp 
mv -f libacl.lai.tmp libacl/.libs/libacl.lai
Comment 1 Matthew Miller 2006-11-27 14:18:05 EST
This is a dup of bug #171114. However, I don't have the power to resolve it as such.

Comment 2 Jindrich Novy 2006-11-27 14:29:34 EST

*** This bug has been marked as a duplicate of 171114 ***

Note You need to log in before you can comment on or make changes to this bug.