Bug 21369 - RAID installation fails
RAID installation fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-27 04:11 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-19 09:01:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-27 04:11:51 EST
Trying to install RedHat Linux 7.0 from CD-ROM on a Compaq PC with two 15G
IDE disk drives. Disks are partitioned identically and configured as RAID1
mirrors with the following layout:
md0	/	2048M
md1	swap	124M
md2	/opt	12240M

After creating the RAID devices and formatting the partitions, installation
fails when trying to mount the filesystems, displaying an "Invalid
argument" error and Anaconda traceback.

The problem manifests itself both with and without update-disk-20001009.

Anaconda traceback (with update-disk-20001009):

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1491, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/tmp/updates/fstab.py", line 715, in mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 255969
fsystem: ext2
self: <fstab.GuiFstab instance at 829c940>
msg: Invalid argument
doFormat: 1
errno: 22
device: md0
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-11-29 14:34:15 EST
This looks like a dupe of bug 16686.

Passing to QA to reproduce.
Comment 2 Need Real Name 2000-11-30 05:06:09 EST
One of the two hard disk drives turned out to be defective.
After replacing both drives with known good ones, the problem went away.
So this is really just an error handling issue.
(Display a helpful message instead of a Python traceback.)
Comment 3 Brock Organ 2000-12-19 09:01:47 EST
thanks for your update ... glad to know you have things working ...

we are constantly trying to improve the installer error messages and warnings,
so hopefully future releases are less cryptic when they fail due to faulty
hardware ... 

thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.