Bug 213772 - pkg-config problem with the buildsys
pkg-config problem with the buildsys
Status: CLOSED DUPLICATE of bug 220692
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 17:12 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-30 16:57:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log (30.51 KB, text/plain)
2006-11-05 03:36 EST, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2006-11-02 17:12:55 EST
Description of problem:
When I try to pull in pygtk2 for gDeskCal on the buildsys, I find I get the
following error which doesn't occur on FC-6 or rawhide. Is this a buildsys
problem or pygtk2?

checking for pkg-config... no
checking for PYGTK... configure: error: The pkg-config script could not be found
or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

Alternatively, you may set the environment variables PYGTK_CFLAGS
and PYGTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Additional info:
http://buildsys.fedoraproject.org/logs/fedora-5-extras/20790-gdeskcal-1.0-7.fc5/
Comment 1 Matthew Barnes 2006-11-04 11:38:52 EST
Could you please attach your config.log ?  That might give some useful clues.
Comment 2 Paul F. Johnson 2006-11-04 17:51:13 EST
Does it matter that my config log is for rawhide?
Comment 3 Matthew Barnes 2006-11-04 18:24:01 EST
Should be alright, as long as it shows the error you're seeing.
Comment 4 Paul F. Johnson 2006-11-04 18:38:32 EST
The error I'm seeing is coming from the Fedora buildsys. It's building fine on
my system here. 

http://buildsys.fedoraproject.org/logs/fedora-5-extras/20790-gdeskcal-1.0-7.fc5/

contains the buildlog
Comment 5 Matthew Barnes 2006-11-04 18:54:39 EST
Okay, but I'd like to see the config.log file that the configure script is
generating.  It contains more information about how the configure script is
testing for things and (hopefully) why the pkg-config tests are failing.
Comment 6 Paul F. Johnson 2006-11-04 19:00:23 EST
Sure - I'll rebuild it and post the results in the morning.
Comment 7 Paul F. Johnson 2006-11-05 03:36:49 EST
Created attachment 140380 [details]
Build log
Comment 8 Matthew Barnes 2006-12-30 13:56:40 EST
I think this might be a symptom of the problem reported in bug #220692.

Paul, do you concur?
Comment 9 Paul F. Johnson 2006-12-30 16:57:51 EST
Yes. I'll mark this bug as such and close it.

*** This bug has been marked as a duplicate of 220692 ***

Note You need to log in before you can comment on or make changes to this bug.