Bug 220692 - pygtk2-devel doesn't require pkgconfig
pygtk2-devel doesn't require pkgconfig
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 213772 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-23 05:01 EST by Sindre Pedersen Bjørdal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: pygtk2-2.10.3-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-30 21:24:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2006-12-23 05:01:21 EST
Description of problem:
It turns out pygtk2-devel in Fedora Core 5 doesn't require pkgconfig, which
results in failed builds for Extras packages depending on pygtk2-devel. In devel
and FC6, builds succeed. 

Example of failed build logs here:
http://buildsys.fedoraproject.org/logs/fedora-5-extras/24460-solfege-3.6.4-6.fc5/

Succeeded build (FC6):
http://buildsys.fedoraproject.org/logs/fedora-6-extras/24459-solfege-3.6.4-6.fc6/

Version-Release number of selected component (if applicable):
2.8.4-1

How reproducible:
Every time

Steps to Reproduce:
1. Try to build package with pygtk2-devel as a build requires for FC5 in the
Extras buildsys. 
2. Build fails.
3. Compare with same build on FC6 or devel
  
Actual results:
Building packages for FC5 fails in the Extras buildsys

Expected results:
BuildRequires: pygtk2-devel should pull pkgconfig, build should succeed
Comment 1 Matthew Barnes 2006-12-30 10:49:20 EST
Thanks for the bug report.

It looks like even the latest pygtk2-devel package in Rawhide is missing this
requirement, it's just that as of Fedora Core 6 the package pulls in other devel
packages that _do_ require pkgconfig.  Thus the build succeeds.

Changing the version to "devel", but I'll backport the fix to FC-6 and FC-5.
Comment 2 Paul F. Johnson 2006-12-30 16:58:03 EST
*** Bug 213772 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Barnes 2006-12-30 21:24:17 EST
Fixed in:

   pygtk2-2.10.3-7.fc7
   pygtk2-2.10.3-4.fc6
   pygtk2-2.8.6-1.fc5

Note You need to log in before you can comment on or make changes to this bug.