Bug 213861 - Printer commands (clean print heads, self-test page) don't work
Printer commands (clean print heads, self-test page) don't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gutenprint (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FC7Blocker 196989
  Show dependency treegraph
 
Reported: 2006-11-03 09:45 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: gutenprint-5.0.0-0.16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 05:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-11-03 09:45:36 EST
Description of problem:
I've tried using gutenprint to get the printer commands working.  I've installed
gutenprint and gutenprint-cups, and restarted CUPS, and after setting up a new
queue I can see some buttons in the CUPS web interface:

Clean Print Heads
Print Self-Test Page

Neither of these works.  I have seen various errors in error_log, like:

d [03/Nov/2006:14:38:01 +0000] [CGI] printer_state_message[0]="Filter "commandto
epson" for printer "stylus" not available: No such file or directory"

and

E [03/Nov/2006:14:38:22 +0000] [Job 84] /undefined in #CUPS-COMMAND

Are printer commands expected to work currently?

Version-Release number of selected component (if applicable):
gutenprint-5.0.0-0.15.fc6

How reproducible:
100%

Steps to Reproduce:
1. Set up new queue
2. Use CUPS web interface to clean print heads or print self-test page
Comment 1 Tim Waugh 2006-11-05 05:43:44 EST
In fact it's worse than that:

printer stylus disabled since Sun 05 Nov 2006 10:08:34 GMT -
        Filter "commandtoepson" for printer "stylus" not available: No such file
or directory

and gutenprint.spec actually removes this filter deliberately:

rm -rf %{buildroot}%{cups_serverbin}/filter/commandtocanon
rm -rf %{buildroot}%{cups_serverbin}/filter/commandtoepson

We should be shipping these command filters shouldn't we?
Comment 2 Parag AN(पराग) 2006-11-05 08:35:57 EST
Tim,
   This package is targetted to FC7 core replacing gimp-print. Though this has
not been discussed on any Fedora mailing list for its entry in FC7 core yet but
to get test results of this package before it goes to Core repo and to maintain
existing gimp-print package in Core, those files are removed.
   Its kind of making parallel installation of gutenprint with gimp-print. So
you can remove existing gimp-print and recompile gutenprint and use it.
    In case you fine any thing need to be improved or changed, kindly tell me. I
know you are the maintainer of gimp-print so you must be having good experience
for printing packages.
    Write back in case you need any more help. Hope this gives answer to this
bug query.
Comment 3 Tim Waugh 2006-11-06 13:01:30 EST
Ah, it's to fix a conflict with gimp-print-cups (which I didn't have installed).
 Thanks for the clarification.

I'm investigating what needs to be done before gutenprint can be brought into
Core.  So one of the things is that gutenprint needs to take ownership of these
filters when it replaces gimp-print.  I've changed 'version' to 'devel' to
reflect that.
Comment 4 Tim Waugh 2006-11-06 13:06:46 EST
I'll take ownership of this bug too.
Comment 5 Parag Nemade 2006-11-06 23:10:40 EST
Looks like i was removed from this bug.
What do you mean by ownership of this bug? I think this bug is already resolved
after i gave explanation. you mean to take maintainership of this package?
Comment 6 Tim Waugh 2006-11-07 04:04:55 EST
Once it is in Core, yes.  I took ownership of this bug because there's nothing
we can do about the file conflict until gutenprint is in Core, so I don't expect
you to make any package changes as a result of this bug.

Sorry -- I didn't mean to drop you from the CC list; that must have been a
mistake. :-(
Comment 7 Tim Waugh 2006-11-13 09:03:48 EST
Parag: do you think gutenprint-cups should require gimp-print-cups for FC6? 
That way the filters would at least get installed, even though they aren't the
gutenprint ones.
Comment 8 Parag Nemade 2006-11-14 00:43:13 EST
(In reply to comment #7)
> Parag: do you think gutenprint-cups should require gimp-print-cups for FC6? 
Yes if its a parallel testing of gutenprint and gimp-print. Those filters are
removed from gutenprint-cups to resolve conflicts in both packages installation.

> That way the filters would at least get installed, even though they aren't the
> gutenprint ones.

yes. you can do that.
Comment 9 Parag Nemade 2006-11-14 01:34:55 EST
I am not understanding why gutenprint is not using filters from gimp-print-cups
package. Did you get any further info on this issue?
Comment 10 Tim Waugh 2006-11-14 06:10:28 EST
Because it doesn't require the gimp-print-cups package.  You need to add a
'Requires: gimp-print-cups' line to gutenprint.spec.
Comment 11 Parag Nemade 2006-12-13 05:49:24 EST
Fixed in next version of gutenprint so Closing this bug for now.

Note You need to log in before you can comment on or make changes to this bug.