Bug 21395 - The command 'service mysqld stop' doesn't.
Summary: The command 'service mysqld stop' doesn't.
Status: CLOSED DUPLICATE of bug 17956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-27 21:24 UTC by ckloiber
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 16:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ckloiber 2000-11-27 21:24:21 UTC
Discovered this while setting up phpMyAdmin, after updating to the latest
errata verisons of the mysql packeges:

mysql-3.23.24-1
mysql-devel-3.23.24-1
mysql-server-3.23.24-1
php-mysql-4.0.3pl1-1

I changed the root mysql password within phpMyAdmin, and needed to restart
the mysql daemon. I used the commands:

service mysqld stop
service mysqld start

But when I returned to phpMyAdmin it complained about being unable to
access the server through the mysql.sock. I shut the server down again with
'service mysqld stop' then ran 'ps aux | grep mysql' to find that the
daemons did not stop at all. I had to kill them manually with:
'killall -v /usr/libexec/mysqld'. I added this line just before the return
in the stop() section of the init script for now until it's fixed. Ugly,
but it works.

Comment 1 Trond Eivind Glomsrxd 2000-11-28 16:19:21 UTC
This should be fixed in Rawhide some time ago (3.23.25 and newer).

Comment 2 Trond Eivind Glomsrxd 2000-11-28 16:20:54 UTC

*** This bug has been marked as a duplicate of 17956 ***


Note You need to log in before you can comment on or make changes to this bug.