Bug 213973 - tdfx: undefined symbol: getsecs
Summary: tdfx: undefined symbol: getsecs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-tdfx (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
: 213994 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-04 03:32 UTC by Torin Ford
Modified: 2018-04-11 11:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 20:24:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Torin Ford 2006-11-04 03:32:52 UTC
Description of problem:
Running startx results in a screen with some X type stuff displayed, but no
keyboard or mouse messages are processed, cannot get back to virtual consoles, etc.

Version-Release number of selected component (if applicable):
xorg-x11-drv-tdfx-1.2.1-3.1

How reproducible:
Always.

Steps to Reproduce:
1.  Install a voodoo 3 2000 video card
2.  Configure X to use this card
3.  run "startx 2>&1 > xcrash
  
Actual results:
X will appear to start, then hang killing keyboard and mouse.  xcrash will
contain the output of running startx.  In that output you will see:

X: symbol lookup error: /usr/lib/xorg/modules/drivers/tdfx_drv.so: undefined
symbol: getsecs

Expected results:
X to start normally.

Additional info:
This is related to some change made between FC5 and FC6, the tdfx driver worked
just fine in FC5

Comment 1 David G. Mackay 2006-11-06 01:47:35 UTC
A quick google for linux tdfx getsecs shows that there was an upstream fix back
in June.  Basically, getsecs (in tdfx_priv.c from
xorg-x11-drv-tdfx-1.2.1-3.1.src.rpm ) should be xf86getsecs

Comment 2 Matěj Cepl 2006-11-09 13:29:50 UTC
*** Bug 213994 has been marked as a duplicate of this bug. ***

Comment 3 Matěj Cepl 2006-11-09 13:39:35 UTC
Duplicate bug 213994 mentions patch in
http://lists.freedesktop.org/archives/xorg/2006-August/017472.html

Comment 4 Roc Halbasch 2006-11-20 20:52:08 UTC
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=212741 seems to be a
duplicate as well.

Comment 5 Wojciech Kazubski 2006-11-22 12:12:03 UTC
The patch on freedesktop works for me.

Another solution I was using was to downgrade to a version from FC5 but this 
requires rebuilding the SRPM due to xorg version mismatch.

Comment 6 Adam Jackson 2006-12-01 20:24:37 UTC
Fixed in xorg-x11-drv-tdfx 1.3.0


Note You need to log in before you can comment on or make changes to this bug.