Bug 213975 - Windows have border even when maximized.
Windows have border even when maximized.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
:
: 222434 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 00:43 EST by J.B. Nicholson-Owens
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: compiz-0.3.6-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 19:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.B. Nicholson-Owens 2006-11-04 00:43:54 EST
Description of problem:
With metacity, maximized windows have no border.  It's easy to move the cursor
to the edge of the screen and move a scrollbar in a web browser (for example). 
With compiz, maximized windows have a border.  It's not as easy to scroll up or
down because slamming the mouse against the right edge misses the scrollbar and
hovers over a window border (thus turning the cursor to arrows, which is odd
considering the window is maximized).

Version-Release number of selected component (if applicable):
0.0.13

How reproducible:
Every time.

Steps to Reproduce:
1. Disable desktop effects.  Start Firefox and open a long webpage, maximize the
window.  Move pointer to the rightmost edge and you can scroll around.
2. Enable desktop effects.  Maximize the Firefox window if it's not maximized
already.  Move pointer to the rightmost edge.
  
Actual results:
You can't scroll around because you're hovering over the window border.

Expected results:
You can scroll around because you're hovering over the scrollbar area.

Additional info:
Compiz should behave more like metacity on issues like this to ease the
transition.  Ordinary users shouldn't have to get used to two different ways to
do the same thing and become aware of window managers.
Comment 1 k3dzngrp8w2xtc9 2007-01-12 18:35:57 EST
*** Bug 222434 has been marked as a duplicate of this bug. ***
Comment 2 k3dzngrp8w2xtc9 2007-01-12 18:47:40 EST
p.s. Wow I'm actually amazed at how closely I duplicated your bug report!
Comment 3 k3dzngrp8w2xtc9 2007-02-26 03:25:22 EST
This can be now closed as it's fixed in compiz-0.3.6-2.fc6
Comment 4 Matěj Cepl 2007-10-11 19:25:29 EDT
No arguments from reporter about comment 3, so closing.

Note You need to log in before you can comment on or make changes to this bug.