Bug 213976 - Compiz makes video players not work properly.
Compiz makes video players not work properly.
Status: CLOSED DUPLICATE of bug 200270
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 00:56 EST by J.B. Nicholson-Owens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 18:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.B. Nicholson-Owens 2006-11-04 00:56:17 EST
Description of problem:
Using desktop effects (compiz), video players (like VLC, Totem) don't display
the video for the movie unless the window is moved to a particular location. 
This location repeats across the screen.  I vaguely remember a similar problem
on NeXT hardware running NeXTSTEP if that rings any bells for the people working
on this bug.

I'm using the free software ATI Radeon driver that ships with FC6's x.org and an
ATI Radeon 9200 SE video card (an AGP card).

Version-Release number of selected component (if applicable):
0.0.13

How reproducible:
Every time.

Steps to Reproduce:
1. Enable desktop effects.
2. Start a movie player and watch a movie.
3. Odds are good you won't see the movie until you scoot the window into a
particular position on the screen.  There are many such positions on the screen
and they seem to be spaced regularly, but I don't know how regularly.
  
Actual results:
The video display is blank.  Moving the window shows odd flickers of portions of
frames.  Then when the window is in the "right place" you see the image you
should see.

Expected results:
The movie displays no matter where the window is.

Additional info:
Disabling desktop effects makes the video display work normally.
Comment 1 W. Michael Petullo 2006-11-18 09:13:36 EST
I don't seem to have this problem.  I can play a video with totem and it
displays correctly no matter where the window is placed.  In fact, it continues
to play even as the window is resized and moved.  It even plays in the
application switcher (ALT-tab).  I am using Fedora Core 6, updated as of 18 Nov
06.  My computer is a PowerPC iBook with a video card identified by X as ATI
Technologies Inc M9+ 5C63 [Radeon Mobility 9200 (AGP)].

Playback seems to drop frames when the video is scaled large, but this is a
separate issue (because XVideo is not supported by compiz?)
Comment 2 Kristian Høgsberg 2007-08-14 18:31:33 EDT

*** This bug has been marked as a duplicate of 200270 ***

Note You need to log in before you can comment on or make changes to this bug.