Bug 213977 - OpenGL program windows display oddly and leave old frames behind when compiz is on.
OpenGL program windows display oddly and leave old frames behind when compiz ...
Status: CLOSED DUPLICATE of bug 222262
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 01:10 EST by J.B. Nicholson-Owens
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 10:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.B. Nicholson-Owens 2006-11-04 01:10:36 EST
Description of problem:
Compiz doesn't show OpenGL program windows correctly.  Disabling compiz makes
the program window display correctly.

Version-Release number of selected component (if applicable):
compiz 0.0.13

How reproducible:
Every time.

Steps to Reproduce:
1. Enable desktop effects.  Install Celestia (or use any other OpenGL program
you can run in a window).  I'll use Celestia for this example.
2. Open Celestia.  Notice how the program doesn't render smoothly.
3. Move the window around.

Actual results:
The old frames are left behind.

Expected results:
The window's OpenGL would work normally and the desktop effects would "wobble"
the window if that's enabled.

Additional info:
No OpenGL program I've seen works well when compiz is enabled.  I understand
that compiz uses OpenGL to do its work, but it seems like there's some serious
problem using OpenGL to transform the windows in real-time as compiz does when
that window has OpenGL output.
Comment 1 filippo david 2006-11-13 04:52:16 EST
I have the same problem (with glxgears).
I also have the same problem playing videos, see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=213391

xorg-x11-drv-i810-1.6.5-10.fc6
compiz-0.0.13-0.32.20060817git.fc6
mesa-libGLU-6.5.1-8.fc6
mesa-libGL-6.5.1-8.fc6

and i have an intel dg965wh motherboard with a g965 video chipset.
Comment 2 Kristian Høgsberg 2007-10-12 10:47:58 EDT

*** This bug has been marked as a duplicate of 222262 ***

Note You need to log in before you can comment on or make changes to this bug.