Bug 222262 - (redirected-glx) GLX isn't redirected properly yet
GLX isn't redirected properly yet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: FutureFeature
: 213977 239022 329081 468393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-11 02:58 EST by Alex W. Jackson
Modified: 2009-06-10 17:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 17:30:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (686 bytes, text/plain)
2007-01-11 10:37 EST, Alex W. Jackson
no flags Details
Xorg.0.log produced using above xorg.conf (69.73 KB, text/plain)
2007-01-11 10:39 EST, Alex W. Jackson
no flags Details
Xorg.0.log produced with no xorg.conf (73.30 KB, text/plain)
2007-01-11 10:40 EST, Alex W. Jackson
no flags Details

  None (edit)
Description Alex W. Jackson 2007-01-11 02:58:07 EST
Description of problem:
On my Radeon 9200SE card, passing the option "EnablePageFlip" in xorg.conf gives
 a very large performance boost to OpenGL applications (as much as 100% in some
applications) which is very nice.  However, when using desktop effects (compiz)
this speed boost goes away, and moreover, glitches occur (parts of the desktop
becoming corrupted) when I run an OpenGL application.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-47.2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Run glxgears with no desktop effects and without "EnablePageFlip" in
xorg.conf.  Note FPS.
2. Add Option "EnablePageFlip" "1" to xorg.conf "Device" section, and restart X
server.
3. Run glxgears again.  Note FPS--it should be significantly higher than before.
4. Enable desktop effects.
5. Run glxgears again.  Note FPS--it has reverted to the low value from step 1.
 Also, glitches now appear on desktop when glxgears is run
6. Remove "EnablePageFlip" option from xorg.conf, and restart X server
7. Run glxgears with desktop effects and without EnablePageFlip.  FPS is the
same as step 1, and there are no glitches.  This proves that it is the
combination of EnablePageFlip and compiz that produces the glitches, and not
compiz alone.

Summary of results:
PageFlip  Compiz  glxgears  Glitches
off       off     slow      no
on        off     fast      no
off       on      slow      no
on        on      slow      yes
Comment 1 Matěj Cepl 2007-01-11 06:20:17 EST
Thanks for the bug report, but I think we could some more information to
diagnose your issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Alex W. Jackson 2007-01-11 10:37:24 EST
Created attachment 145357 [details]
xorg.conf
Comment 3 Alex W. Jackson 2007-01-11 10:39:18 EST
Created attachment 145358 [details]
Xorg.0.log produced using above xorg.conf
Comment 4 Alex W. Jackson 2007-01-11 10:40:21 EST
Created attachment 145359 [details]
Xorg.0.log produced with no xorg.conf
Comment 5 Adam Jackson 2007-01-29 18:09:31 EST
This is expected.  GLX applications do not work properly yet when the
compositing manager is running.
Comment 6 Adam Jackson 2007-05-08 12:07:15 EDT
*** Bug 239022 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2007-07-27 18:10:31 EDT
*** Bug 240956 has been marked as a duplicate of this bug. ***
Comment 8 Kristian Høgsberg 2007-10-12 10:45:04 EDT
Reassigning to xserver, though it's really, xserver, libdrm, kernel, mesa and
all ddx drivers.
Comment 9 Kristian Høgsberg 2007-10-12 10:47:59 EDT
*** Bug 213977 has been marked as a duplicate of this bug. ***
Comment 10 Kristian Høgsberg 2007-10-12 10:48:16 EDT
*** Bug 329081 has been marked as a duplicate of this bug. ***
Comment 11 Kristian Høgsberg 2007-10-12 10:49:24 EDT
Btw, we're working on fixing this, but it's a long term effort.  See
http://hoegsberg.blogspot.com/2007/08/redirected-direct-rendering.html for some
background on this problem.
Comment 12 Bug Zapper 2008-04-03 14:52:48 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 13 Kristian Høgsberg 2008-04-03 15:02:12 EDT
Go away, stupid bot.
Comment 14 Bug Zapper 2008-05-13 22:32:48 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Mads Kiilerich 2008-11-13 17:09:58 EST
*** Bug 468393 has been marked as a duplicate of this bug. ***
Comment 16 Mads Kiilerich 2008-11-13 17:14:50 EST
This issue should be changed back to version rawhide and have the tag FutureFeature
Comment 17 Adam Jackson 2009-06-10 17:30:26 EDT
This works with DRI2-enabled drivers.  Yay!

Note You need to log in before you can comment on or make changes to this bug.