Bug 213996 - n-up printing does not work from OOo Impress
Summary: n-up printing does not work from OOo Impress
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 6
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL: http://www.serviza.com/
Whiteboard:
Keywords:
: 216507 (view as bug list)
Depends On:
Blocks: FC6Update
TreeView+ depends on / blocked
 
Reported: 2006-11-04 12:49 UTC by Tim Jowers
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: 2.0.4-5.5.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 08:25:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
effcups bug report in the morning (7.10 KB, text/plain)
2006-11-05 14:36 UTC, Tim Jowers
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2080 None None None Never
OpenOffice.org 65491 None None None Never

Description Tim Jowers 2006-11-04 12:49:22 UTC
Description of problem:
Try to print. Nothing is printed. Others on Scribus email list have this problem
with FC6 after upgrade from FC5. I have this problem on fresh install of FC6.
Another also has this problem with OpenOffice.org's Impress after a fresh
upgrade.                                                                       
                                                                               
          

Version-Release number of selected component (if applicable):


How reproducible:
Every tiume.

Steps to Reproduce:
1. Open OO Impress. Choose the template "new product"
2. Choose the slides
3. Try to print... choose the second tab and 2-up printing.
4. Try to print.
Using HP-PSC 2175 printer with HP PSC 2170 driver. Also others are using other
printers.
  
Actual results:
Job shows in lpq but never goes to printer.

Expected results:
printout

Additional info:
OO Writer and Draw will print.

Comment 1 Tim Waugh 2006-11-05 00:10:04 UTC
Yes, I see this here too -- thanks for reporting it.  Will investigate.

Comment 2 Tim Jowers 2006-11-05 14:36:15 UTC
Created attachment 140394 [details]
effcups bug report in the morning

Maybe related to printing as this occurred after trying to print with OO
impress - albeit this occurred several ohours later and was seen the next
morning.

Comment 3 Tim Waugh 2006-11-05 15:04:30 UTC
No, this is not related.  Please report that eggcups crash as a separate bug
report, against the 'desktop-printing' component.

FWIW, *this* bug seems to be in foomatic; at least, printing to a non-foomatic
queue seems to avoid the problem.

Comment 4 Tim Waugh 2006-11-06 12:05:39 UTC
Hmm, no, this really is a CUPS bug, not foomatic.

Comment 5 Tim Waugh 2006-11-06 12:45:42 UTC
Reported upstream.

Comment 6 Tim Waugh 2006-11-07 15:27:14 UTC
Seems like this might be an OpenOffice.org problem of some kind.

Comment 7 Caolan McNamara 2006-11-07 17:24:14 UTC
So this only with 2-up printing, i.e. if you use impress, print and don't select
that it works ? 

If so, what happens if you print to file (without 2-up), use evince to open that
.ps and use print there and 2-up printing ? Does that work ?

Comment 8 Tim Waugh 2006-11-07 17:58:41 UTC
If I do that, evince only shows there being one page. :-)

If I print it using 'lp -onumber-up=2 -dstylus' I get the same problem as before.

Comment 9 Greg Pittman 2006-11-08 00:36:33 UTC
In Scribus, the workaround is to check Alternative Printing Command in printing
requester, then enter 'lp -dprintername'

Comment 10 Caolan McNamara 2006-11-08 16:17:10 UTC
I *think* what I see is postscript where for some reason "%%EndResource" is not
at the start of the line but appended to the previous line, that might explain this

Comment 11 Tim Waugh 2006-11-08 16:24:15 UTC
I see that too, and it's certainly a bug.  However, editing the PostScript to
put the '%%EndResource' on the next line doesn't seem to fix it. 'lp
-onumber-up=2 -dstylus' gives the same GhostScript error as before in error_log.

Comment 12 Caolan McNamara 2006-11-09 09:33:20 UTC
Well psnup on a sample .ps gives a renderable output.ps while lp -onumber-up=2
doesn't

Comment 13 Caolan McNamara 2006-11-09 10:56:39 UTC
oky doky, a mixture of openoffice.org issuezilla 65491 and a little sprinkling
of my own crack. Fix checked in, will be in next update.

Though clearly any remaining problem in scribus is outside my control

Comment 14 Tim Waugh 2006-11-11 11:02:19 UTC
Fix confirmed here with openoffice.org-core-2.0.4-5.5.2.

Tim: if you are also having problems with Scribus, please file a separate bug
report for that.  Thanks.

Comment 15 Caolan McNamara 2006-11-21 09:45:43 UTC
*** Bug 216507 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.