This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 21400 - Anaconda crashing during upgrade to RH7.0
Anaconda crashing during upgrade to RH7.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-27 17:24 EST by Heinz Ruffieux
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-01 11:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump file (1.04 KB, text/plain)
2000-11-27 17:25 EST, Heinz Ruffieux
no flags Details

  None (edit)
Description Heinz Ruffieux 2000-11-27 17:24:32 EST
Hi,
I'm trying to upgrade a RH6.2 installation to 7.0 on a Compaq Armada 1750
Laptop. I'm using downloaded RPMS on the local harddisc. I can choose the
partition from were to install, the language and the keyboard. During the
search for the existing RH installation it crashed with the information
below (dump to diskette). 

Any help on this?

Thanks a lot

Heinz

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in
upgradeFindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43,
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: openssl ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I0
sS'fnames'
p9
(dp10    

<failed>
Comment 1 Heinz Ruffieux 2000-11-27 17:25:47 EST
Created attachment 5750 [details]
Anaconda dump file
Comment 2 Michael Fulbright 2000-11-29 14:30:11 EST

*** This bug has been marked as a duplicate of 18019 ***
Comment 3 Heinz Ruffieux 2000-11-30 16:17:32 EST
Hi,

I tried all the bug fixes and workaround indicated by 18019. But unfortunately I
still get the same error.

Can you help me on this?

Thanks a lot

Heinz
Comment 4 Heinz Ruffieux 2000-11-30 16:47:10 EST
Please find below the diagnostic information of the updated anaconda installer:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in
__call__
  File "/tmp/updates/todo.py", line 941, in upgradeFindPackages
    self.getCompsList ()
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in
readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: openssl  
Local variables in innermost frame:
self: <comps.HeaderList instance at 81e2958>
item: openssl

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'   
p8
I0
sS'fnames'
p9
(dp10

<failed>
Comment 5 Michael Fulbright 2000-12-01 11:29:37 EST
There is not a fix available for this problem. It is caused by a corrupt or
incomplete hard drive image of the install tree. Make sure you have all of the
required files and have downloaded them in a binary safe fashion.

Note You need to log in before you can comment on or make changes to this bug.