Bug 214206 - hal advertises suspend on xen kernels
hal advertises suspend on xen kernels
Status: CLOSED DUPLICATE of bug 216977
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 10:45 EST by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 10:37:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-11-06 10:45:08 EST
I had the suspend menuitem, but it did not work.
Trying pm-suspend, I see it bail out early because /sys/power/disk is missing.
I think hal should do the same sanity checks pm-suspend does and not
advertise suspend support if that file is missing.

It is a different question why the xen kernel puts lies in /sys/power/state...
Comment 1 David Zeuthen 2006-11-06 11:06:34 EST
> It is a different question why the xen kernel puts lies in /sys/power/state...

Disagree. Why paper over it in hal when it can be fixed in the kernel?

Reassigning to kernel. Thanks.
Comment 2 Jay Turner 2006-11-21 13:48:55 EST
QE ack to fix the kernel in RHEL5.
Comment 3 Linda Wang 2006-12-01 10:37:07 EST
similiar issues are reported in 216977 for rhel5, and 205241 in FC6, so dup to
216977. 

*** This bug has been marked as a duplicate of 216977 ***

Note You need to log in before you can comment on or make changes to this bug.