Bug 2144186 - Fedora 37 cannot be installed on Intel Macs - cannot set EFI boot target error.
Summary: Fedora 37 cannot be installed on Intel Macs - cannot set EFI boot target error.
Keywords:
Status: CLOSED DUPLICATE of bug 2142968
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 37
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2239537 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-19 17:57 UTC by Merlin Cooper
Modified: 2023-12-06 15:25 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-12-06 11:28:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
install log (42.47 KB, text/plain)
2022-11-22 23:55 UTC, Tim Elliott
no flags Details
efibootmgr -v output (1.33 KB, text/plain)
2022-11-22 23:55 UTC, Tim Elliott
no flags Details

Description Merlin Cooper 2022-11-19 17:57:58 UTC
Description of problem:

On my MacBook Air (old 2015 Intel model), a fresh install of Fedora 37 will always end up with the “cannot set EFI boot target” error and the installed system is unbootable.

Version-Release number of selected component (if applicable):
Fedora 37

How reproducible:
Always

Steps to Reproduce:
1. Create install media of any Fedora version (Workstation, Spins, Everything, etc) using Fedora Media Writer
2. Attempt to install the system as normal on an Intel Mac 
3. See the error

Actual results:
Anaconda gives an error stating that it cannot set the EFI boot target and the resulting system will be unbootable. 

Expected results:
The system should be installable without issues and work normally as it did in Fedora 36. 

Additional info:

Comment 1 Merlin Cooper 2022-11-22 14:05:51 UTC
I decided to try installing from the Fedora 37 *beta* image (you can get it off the Internet Archive) and that works. So something changed between the beta and final that's causing this issue.

Comment 2 Tim Elliott 2022-11-22 23:54:38 UTC
I am also experiencing this issue on an intel mac - iMac 13,1.

I am attaching log output from the installer as well as efibootmgr output.

Comment 3 Tim Elliott 2022-11-22 23:55:21 UTC
Created attachment 1926536 [details]
install log

Comment 4 Tim Elliott 2022-11-22 23:55:59 UTC
Created attachment 1926537 [details]
efibootmgr -v output

Comment 5 Tim Elliott 2022-11-23 00:08:53 UTC
I believe this bug is a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=2142968

Comment 6 Mehrad 2023-03-21 10:59:42 UTC
I'm experiencing the same issue (bug reporter said it is duplicate of this issue but it failed to create a new comment). I tried to install Fedora37 Gnome and also Plasma Spin on my MacbookPro 2012 Intel and regardless of how I create partitions and etc. it keeps failing with the same error. I also created the bootable USB using Balena Etcher 1.18.4.

The following is the sha256sum of the last iso file I downloaded and tried:


❯  sha256sum Fedora-KDE-Live-x86_64-37-1.7.iso
773677e3940a972e8f2c62b1e9907579ad1e5a380466ce4e751bd52a3e1e427a  Fedora-KDE-Live-x86_64-37-1.7.iso

I hope these info helps addressing the issue easier.

Comment 7 Jiri Konecny 2023-04-13 11:48:23 UTC
Added bootloader team on CC. Could you please take a look on this issue what could be wrong?

Comment 8 Katerina Koukiou 2023-09-25 16:22:55 UTC
*** Bug 2239537 has been marked as a duplicate of this bug. ***

Comment 9 Aoife Moloney 2023-11-23 00:33:15 UTC
This message is a reminder that Fedora Linux 37 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora Linux 37 on 2023-12-05.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
'version' of '37'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, change the 'version' 
to a later Fedora Linux version. Note that the version field may be hidden.
Click the "Show advanced fields" button if you do not see it.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora Linux 37 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora Linux, you are encouraged to change the 'version' to a later version
prior to this bug being closed.

Comment 10 Aoife Moloney 2023-12-06 11:28:09 UTC
Fedora Linux 37 entered end-of-life (EOL) status on None.

Fedora Linux 37 is no longer maintained, which means that it
will not receive any further security or bug fix updates. As a result we
are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora Linux
please feel free to reopen this bug against that version. Note that the version
field may be hidden. Click the "Show advanced fields" button if you do not see
the version field.

If you are unable to reopen this bug, please file a new report against an
active release.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 11 Adam Williamson 2023-12-06 15:25:56 UTC

*** This bug has been marked as a duplicate of bug 2142968 ***


Note You need to log in before you can comment on or make changes to this bug.