Bug 21446 - Anaconda coping problem.
Anaconda coping problem.
Status: CLOSED DUPLICATE of bug 18470
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 15:03 EST by Need Real Name
Modified: 2007-03-26 23:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-05 15:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-28 15:03:47 EST
I first upgraded the RAID controller bios to 4.5.0.05 on my IBM Netfinity
M20 21Y.
I'm using a driverdisk (also 4.5.0.05) for my RAID controller at install
time (with the "linux dd" installation method, since the "expert"
installation method doesn't work !). Everything is working fine, untill
anaconda tries to copy the ips module, (at the end of the coping process)
which was also loaded by the driverdisk.
I'm trying to install from an IDE cdrom drive with the original RedHat 
7.0  cdrom.

I'm desperate and need help, 
Thanx in advance...

Here's the Anaconda bug report :

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1630, in
doInstall
    self.copyExtraModules()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1348, in
copyExtraModules
    os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
fromFile: /mnt/sysimage/lib/modules/2.2.16-22smp/ips.o
kernelVersions: ['2.2.16-22smp', '2.2.16-22']
path: /tmp/modules/ips
names:  ips.o ips.o
command: cd /mnt/sysimage/lib/modules; gunzip <
/tmp/modules/ips/modules.cgz | /mnt/sysimage/bin/cpio  --quiet -iumd 
2.2.16-22smp/ips.o 2.2.16-22/ips.o
version: 2.2.16-22
subdir: scsi
to: /mnt/sysimage/lib/modules/2.2.16-22smp/scsi/ips.o
n: 2.2.16-22smp
self: <todo.ToDo instance at 84a1878>
pattern:  2.2.16-22smp/ips.o 2.2.16-22/ips.o
name: ips

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
Comment 1 Michael Fulbright 2000-11-29 14:10:12 EST
Passing to QA to reproduce.
Comment 2 Brock Organ 2000-12-04 18:15:36 EST
hmmm ... I was unable to reproduce this problem in our test lab, using an older
revision of firmware ... did it work properly for you with 7.0 using the older
firmware ...?
Comment 3 Brock Organ 2000-12-04 18:19:04 EST

*** This bug has been marked as a duplicate of 18470 ***
Comment 4 Need Real Name 2000-12-05 15:46:30 EST
It didn't work at all with any version of both firmware nor RedHat, the only
combination which worked was firmware version 4.5.0.05 and RedHat 7.0, without
using the driverdisk.
Anyway, I've installed everything, and it's running like a Harley Davidson on a
sunny day in California.
Thanks a lot for your time, and if you're still trying to hunt this down, I am
available for questions/comments.

Note You need to log in before you can comment on or make changes to this bug.