Bug 214469 - "Focus follows mouse" broke in kdebase-3.5.5-0.1.fc6
"Focus follows mouse" broke in kdebase-3.5.5-0.1.fc6
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
6
ppc64 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 214466 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 14:21 EST by Linus Torvalds
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 05:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linus Torvalds 2006-11-07 14:21:33 EST
Description of problem:

Enabling "Focus follows Mouse" with overlapping windows will make
focus go crazy quite often. It will switch between windows at a high
rate, and the window manager ends up useless.

For some reason, kwin doesn't seem to realize that focus should go
only to the TOP window.


Version-Release number of selected component (if applicable):

kdebas-3.5.5-0.1.fc6

How reproducible:

Totally. Just enable "focus follows mouse" in Control Center, and
have lots of overlapping windows. Then, move the mouse around to
a place where two or more windows overlap. Eventually the focus
thing will start going crazy.

Steps to Reproduce:
1. See above
2. ...
3. Profit!
  
Actual results:

Crazy focus

Expected results:

Focus on the top-most window under the mouse

Additional info:

Sorry about possible other reports - I tried it out as I was writing
this report, and the crazy focus ended up causing me to press enter
in the wrong window..
Comment 1 Ngo Than 2006-11-08 05:21:54 EST
*** Bug 214466 has been marked as a duplicate of this bug. ***
Comment 2 Ngo Than 2006-11-08 05:33:25 EST
Linus, i have already pushed new kdebase-3.5.5-0.2.fc6, including the fix for 
this issue, into FC6 update testing last week. It will be moved in FC6 update 
soon. If you don't want to wait on it you could update it from FC6 update 
testing now. Thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.