Bug 21449 - Anaconda and DPT Wrestling
Anaconda and DPT Wrestling
Status: CLOSED DUPLICATE of bug 27550
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-11-28 15:52 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-05 10:52:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda Error Dump (1.15 KB, text/plain)
2000-11-28 15:56 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-11-28 15:52:41 EST
Error occured while loading RH7.0 on an i386 system with DPT Raid5 and 
dual Adaptec 2940 adapters.

Since DPT driver ( dpt_i2o.o ) is on a floppy, must run in either linux 
dd, expert, text dd.  Same error occured with each method and at the same 
point in the installation.  That is, right after all the files were loaded 
and before the boot floppy could be created.

Here is a copy of the anacdump.txt output:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1630, in 
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1348, in 
    os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
fromFile: /mnt/sysimage/lib/modules/2.2.16-22smp/dpt_i2o.o
kernelVersions: ['2.2.16-22smp', '2.2.16-22']
path: /tmp/modules/dpt_i2o
names:  dpt_i2o.o dpt_i2o.o
command: cd /mnt/sysimage/lib/modules; gunzip < 
/tmp/modules/dpt_i2o/modules.cgz | /mnt/sysimage/bin/cpio  --quiet -iumd  
2.2.16-22smp/dpt_i2o.o 2.2.16-22/dpt_i2o.o
version: 2.2.16-22
subdir: scsi
to: /mnt/sysimage/lib/modules/2.2.16-22smp/scsi/dpt_i2o.o
n: 2.2.16-22smp
self: <todo.ToDo instance at 82021d8>
pattern:  2.2.16-22smp/dpt_i2o.o 2.2.16-22/dpt_i2o.o
name: dpt_i2o

ToDo object:


Any ideas?
Murrah Boswell
Comment 1 Need Real Name 2000-11-28 15:56:18 EST
Created attachment 5808 [details]
Anaconda Error Dump
Comment 2 Michael Fulbright 2000-11-29 14:09:42 EST
Passed to QA to reproduce.
Comment 3 Need Real Name 2000-11-29 17:27:36 EST
Hardware Configuration for this machine:
ASUS P3BF mb,  Intel Pentium III 600 [single processor NOT smp]
Adaptec AHA-2940U (narrow) for CDROM, Tape drive, Zip drive
DPT SmartRaid V (Century) PM2654U2-R w/three IBM 17gb U2 drives
Comment 4 Michael Fulbright 2001-02-20 10:29:32 EST
Do we have this hardware in house (the DPT SmartRaid V (Century) PM2654U2-R )?
Comment 5 David Lawrence 2001-02-20 11:20:33 EST
I do not have readily available in our test lab hardware repository, I will have
to look around for one.
Comment 6 David Lawrence 2001-02-20 11:25:15 EST
I do not have readily available in our test lab hardware repository, I will have
to look around for one.
Comment 7 Michael Fulbright 2001-02-27 17:52:36 EST
Waiting on hw.
Comment 8 Michael Fulbright 2001-03-02 17:55:45 EST
Is the hw available?
Comment 9 David Lawrence 2001-03-05 10:52:42 EST
Not one of that particular model number. The only one I have right now is a
PM3754U2 Smartraid V Millenium. I am not sure this would be of much help for
this problem so we will need to order one like the above. I have found one at
CDW for 939.00. I will talk to management to see if we can order one.
Comment 10 Matt Wilson 2001-04-03 18:21:13 EDT

*** This bug has been marked as a duplicate of 27550 ***

Note You need to log in before you can comment on or make changes to this bug.