Bug 27550 - anaconda fails on uniprocessor and "Install everything"
Summary: anaconda fails on uniprocessor and "Install everything"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 21449 27570 30559 33488 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-14 08:20 UTC by Ernst-Heinrich Klaas
Modified: 2007-03-27 03:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 22:34:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ernst-Heinrich Klaas 2001-02-14 08:20:18 UTC
The installation program crashes when a driver disk containing smp
drivers is used on a uniprocessor installation and the option
"Install everything" is selected.

This problem is reproducable using RedHat Linux 7.0 ("install dd") and
the dd160.img LSILogic driver disk for SYM53C1010 based systems on a
uniprocessor.

Anaconda apparently hasn't generated the
/mnt/sysimage/lib/modules/2.2.16-22smp subtree, but it attempts to copy
the .../lib/modules/2.2.16-22smp/sym53c8xx.o driver into the
scsi-subdirectory.


Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1630, in doInstall
    self.copyExtraModules()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1348, in copyExtraModules
    os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
fromFile: /mnt/sysimage/lib/modules/2.2.16-22smp/sym53c8xx.o
kernelVersions: ['2.2.16-22smp', '2.2.16-22']
path: /tmp/modules/sym53c8xx
names:  sym53c8xx.o sym53c8xx.o
command: cd /mnt/sysimage/lib/modules; gunzip < /tmp/modules/sym53c8xx/modules.cgz | /mnt/sysimage/bin/cpio  --quiet -iumd  
2.2.16-22smp/sym53c8xx.o 2.2.16-22/sym53c8xx.o
version: 2.2.16-22
subdir: scsi
to: /mnt/sysimage/lib/modules/2.2.16-22smp/scsi/sym53c8xx.o
n: 2.2.16-22smp
self: <todo.ToDo instance at 842ab98>
pattern:  2.2.16-22smp/sym53c8xx.o 2.2.16-22/sym53c8xx.o
name: sym53c8xx

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>

Comment 1 Michael Fulbright 2001-03-02 22:52:10 UTC
If you do not choose install everything does it work ok?


Comment 2 Ernst-Heinrich Klaas 2001-03-15 10:17:54 UTC
It works OK if we install without "install everything".

Comment 3 Michael Fulbright 2001-04-02 15:59:07 UTC
Erik is it possible the enterprise kernel could be causing problems?

Comment 4 Erik Troan 2001-04-02 21:56:21 UTC
No, it seems to be the smp modules getting in the way. We need to test this.

Comment 5 Erik Troan 2001-04-03 22:01:03 UTC
Fixed for next release.

Comment 6 Matt Wilson 2001-04-03 22:18:20 UTC
*** Bug 33488 has been marked as a duplicate of this bug. ***

Comment 7 Matt Wilson 2001-04-03 22:18:32 UTC
*** Bug 27570 has been marked as a duplicate of this bug. ***

Comment 8 Matt Wilson 2001-04-03 22:19:13 UTC
grouping bugs together


Comment 9 Matt Wilson 2001-04-03 22:21:09 UTC
*** Bug 21449 has been marked as a duplicate of this bug. ***

Comment 10 Matt Wilson 2001-04-03 22:21:38 UTC
*** Bug 30559 has been marked as a duplicate of this bug. ***

Comment 11 Matt Wilson 2001-04-03 22:34:40 UTC
download http://people.redhat.com/msw/dd-updates.img and write it to a floppy
disk.  This is an "anaconda updates" disk.  Use "linux updates dd" along with
the driver disk you are using.  You will be prompted to insert the disk.  This
will prevent the traceback.



Note You need to log in before you can comment on or make changes to this bug.