Bug 214538 - USB HID devices not recognised with SMP kernel
USB HID devices not recognised with SMP kernel
Status: CLOSED DUPLICATE of bug 214537
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 21:32 EST by Ben Stringer
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 14:05:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Stringer 2006-11-07 21:32:29 EST
Description of problem:
USB keyboard and mouse not recognised when booting with SMP kernels. Hardware 
is a Dell Optiplex 280, with hyperthreading-capable Celeron processor.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-22.EL and kernel-smp-2.6.9-42.0.3.EL

How reproducible:
This is occurring consistently. Booting with the equivalent UP kernel versions 
works as expected.

Steps to Reproduce:
1. Boot with SMP kernel
2. After GRUB screen, keyboard and mouse are unresponsive.
3. Boot with UP kernel - keyboard and mouse work as expected.
  
Actual results:
SMP kernels do not recognise USB HID devices.

Expected results:
USB HID devices should be recognised and work.

Additional info:

When booting with UP kernel, the following is logged in /var/log/messages:

  kernel: input: USB HID v1.10 Keyboard ...
  kernel: input: USB HID v1.10 Mouse ...

When booting with an SMP kernel, these lines are not logged.
Comment 1 Jason Baron 2006-11-30 14:05:06 EST

*** This bug has been marked as a duplicate of 214537 ***

Note You need to log in before you can comment on or make changes to this bug.