Bug 214580 - perl package should own %{perl_vendorlib}/auto
perl package should own %{perl_vendorlib}/auto
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
David Lawrence
: Reopened
: 213561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 09:43 EST by Paul Howarth
Modified: 2008-02-20 21:56 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.8.8-33.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 21:55:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2006-11-08 09:43:58 EST
The main perl package should own the %{perl_vendorlib}/auto directory, as
discussed in Bug #73970 and on fedora-perl-devel-list:

http://www.redhat.com/archives/fedora-perl-devel-list/2006-November/msg00000.html
Comment 1 Paul Howarth 2006-11-08 09:48:56 EST
*** Bug 213561 has been marked as a duplicate of this bug. ***
Comment 2 Paul Howarth 2008-01-30 05:46:15 EST
Any chance of this getting done for Fedora 9?
Comment 3 Tom "spot" Callaway 2008-01-30 09:53:34 EST
Sure! I didn't see this until now, sorry. 5.10.0-4 will own this directory in F9.
Comment 4 Ralf Corsepius 2008-01-30 21:24:13 EST
I'd say this change should also be applied it to all other active Fedora
branches,  such that this directory will be correctly owned (and thus removed)
during distro upgrades rsp. perl upgrades.

(Note */auto is versioned and therefore would stay in case of perl rsp. Fedora
upgrades).
Comment 5 Tom "spot" Callaway 2008-01-31 11:18:19 EST
(In reply to comment #4)
> I'd say this change should also be applied it to all other active Fedora
> branches,  such that this directory will be correctly owned (and thus removed)
> during distro upgrades rsp. perl upgrades.

Sure. I can tackle that today.
Comment 6 Fedora Update System 2008-01-31 14:51:38 EST
perl-5.8.8-28.fc7 has been submitted as an update for Fedora 7
Comment 7 Fedora Update System 2008-01-31 14:52:23 EST
perl-5.8.8-33.fc8 has been submitted as an update for Fedora 8
Comment 8 Fedora Update System 2008-02-02 03:58:28 EST
perl-5.8.8-28.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1251
Comment 9 Fedora Update System 2008-02-20 21:55:41 EST
perl-5.8.8-33.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-02-20 21:56:35 EST
perl-5.8.8-28.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.