Bug 214615 - dependencies error with pirut
dependencies error with pirut
Status: CLOSED DUPLICATE of bug 213421
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 12:31 EST by bochecha
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 11:07:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bochecha 2006-11-08 12:31:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.7) Gecko/20061027 Fedora/1.5.0.7-8.fc6 Firefox/1.5.0.7

Description of problem:
When I cancel install of packages and then install again, necessary dependencies are not installed.

Version-Release number of selected component (if applicable):
pirut-1.2.5-1

How reproducible:
Always


Steps to Reproduce:
1. Choose to install one package that has dependencies. For example xchat-gnome that needs libsexy and enchant.

2. Apply. Pirut will display chosen packages. Apply.

3. Pirut will now calculate dependencies. It will show a popup window with the 2 packages that are required (libsexy and enchant).

4. This time, you just remembered that you wanted to install one more package, so CANCEL !

5. You are now in the first window, where you can choose the packages to install. Do not choose a new package and apply again.

6. This time, pirut will not display the popup window with the calculated dependencies, and worse, it will install the selected package (xchat-gnome here) without its dependecies.

7. Verify with "rpm -q enchant libsexy xchat-gnome" and you will see that the 2 first are not installed but the last is, which is bad because it requires the 2 others.



Actual Results:
xchat-gnome (or any other package you chose to install) doesn't work because it is missing dependencies

Expected Results:
xchat-gnome should be installed with dependencies and working

Additional info:
In step 5, if you choose to had a new package, dependencies for this new package are calculated, but not those for the first one. The new package is installed with full dependencies and works fine. The same bad result is obtained with xchat-gnome (or any package you chose first)

This applies for every package you would like to install, not only for xchat-gnome (I tried with others)
Comment 1 Jeremy Katz 2006-11-08 13:12:04 EST
Can you try with pirut-1.2.7 in updates-testing?  
Comment 2 bochecha 2006-11-08 17:54:55 EST
I operated exactly the same way.

Here is what I get :

--------------------
[mathieu@bochecha ~]$ rpm -q pirut xchat-gnome libsexy enchant
pirut-1.2.7-1.fc6
xchat-gnome-0.15-1.fc6
le paquetage libsexy n'est pas installé
le paquetage enchant n'est pas installé
--------------------

Of course :

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xchat-gnome             i386       0.15-1.fc6       extras            1.9 M
Installing for dependencies:
 enchant                 i386       1:1.3.0-1.fc6    extras            128 k
 libsexy                 i386       0.1.10-1.fc6     extras             42 k
--------------------

So it is the same thing with this new version of pirut... :-?
Comment 3 Jeremy Katz 2006-11-09 11:07:20 EST
Aha, that's because this is the bug that I fixed post 1.2.7 and haven't built
1.2.8 for yet :-)

Will be fixed in 1.2.8

*** This bug has been marked as a duplicate of 213421 ***
Comment 4 bochecha 2006-11-09 12:15:42 EST
Really ?

I don't see how it is the same bug but if you say so...

Sorry for the duplicate :)
Comment 5 bochecha 2006-11-13 07:09:10 EST
Fixed with 1.2.8

Thanx :)

Note You need to log in before you can comment on or make changes to this bug.