Bug 21463 - error mounting to hda8 - invalid argument
error mounting to hda8 - invalid argument
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
All Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 22:10 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 15:31:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-28 22:10:07 EST
Help!!  New Linux user.  Trying to format partitions after setting up 
mount points with Disk Druid:  got message "error mounting to hda8 - 
invalid argument"  dialog box says this is probably a bug - report to 
bugzilla.  Here is text of report:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 3076416
fsystem: ext2
self: <fstab.GuiFstab instance at 8499838>
msg: Invalid argument
doFormat: 0
errno: 22
device: hda8
instPath: /mnt/sysimage
mntpoint: /

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-11-29 14:17:45 EST
This is a dupe of bug 16686.

Could you give us step by step instructions on how to reproduce this bug, since
we've been having problems coming up with a test case.
Comment 2 Need Real Name 2000-11-30 20:58:26 EST
Sequence of events:

Just put together a new machine:
Will provide hardware details on request.
Instaled Windows 2000 (W2k) without incident.
Very little other software (drivers & Acrobat).
Booted machine using RedHat 7.0
Used Disk Druid (from RH 7 CD) to partition disk further.
Set up some partitions for W2k and for a DOS FAT32 partition.
Ran into some kind of problem with the partitioning.
Went back and used W2k to format the NTFS and FAT32 partitions.
Noticed these partitions were in the proper place - so rebooted
  with RH7 CD and this time used FDISK to set up the partitions.
Seemed to go Ok this is a summary of the partition table

IBM IDE hard disk is 45GB.  255 heads; 63 sectors; 5606 cylinders.
units = cylinders of 16,065 * 512 bytes

hda   ID / Type      start    end    blocks (rounded)  Mount point
1     7    NT            1      382      3.07    3GB   /NT_OS C:
2*    ?    ?           383?     510?        ?    1GB   /boot 
5     5    extended    511     5606     40.93**
5     7    NT          511     2423     15.37   15GB   /NT_user D:
6    83    Linux      2424     3698     10.24   10GB   /usr
7    83    Linux      3699     4718      8.19    8GB   /usr/local
8    83    Linux      4719     5101      3.08    3GB   /
9     6    FAT32      5102     5478      3.08    3GB   /DOS_reserve E:
10    82   <swap>     5479     5606      1.03    1GB   /swap
                                          total 45GB 
*  NT refers to this as hda3
** range of extended partition

Chose all Linux partitions to format
For network config all I entered was host name - skipped all IP stuff
See up administrator password & one user account
By the way - those little checkboxes are stupid.  Can't tell what
  position is select and which is unselect - they look backwards.
  Hard to tell whether I formatted the partitions properly or not
Selected to install Web Server only
Followed the rest of he instructions - went to "Installing"
Then got error message.
Thanks for your help.


Comment 3 Michael Fulbright 2000-12-27 12:27:45 EST
Assigning to developer.
Comment 4 Need Real Name 2001-01-05 16:59:04 EST
I received the same BUG.

I was loading RH 7.0 to a virgin HDD from your retail boxed CD.

I did have a problem with a Delta 50 CD drive and swapped in a
RodeoDrive 45x and the pre-installation seemed to proceed just
fine ... until the actual product installation started and then
this occurred.

More hardware and process details as requested.

Sure hate it when an install fails!  :-(

Doc
Comment 5 Need Real Name 2001-01-05 17:21:57 EST
Just re-ran everything, it is ERROR MOUNTING hda1 not hda8 ... ooops.

I will look for that elsewhere ... though the rest is remarkably similar.

Doc
Comment 6 Brent Fox 2001-01-12 11:01:18 EST
kd4e@arrl.net, can you give me some information about the partitions that you
were trying to make?
Comment 7 Need Real Name 2001-01-12 15:12:24 EST
I ran back through the install a couple of times, then noticed that I had a 
setting incorrect ... finally loaded up fine.

I have moved on to adding devices ... am told I should just recompile the 
Kernel and they should be picked up ... later today ... :-)

Thanks!  Doc
Comment 8 Brent Fox 2001-02-09 15:31:05 EST
We have resolved this issue by improving the error checking code.  Fixed in cvs.
Comment 9 Brock Organ 2001-02-12 15:32:36 EST
sharnish,

I tried to reproduce your problem with a similar partition layout to what you
listed above (see my attempt below) ... I was unable to reproduce the problem
using generic test lab hardware ... :(

(This certainly doesn't mean that you didn't see the error! :)  It just means we
are having a hard time tracking it down to solve it.)

We have added error checking code to the installer (see for example our fisher
public beta!) to tighten our checking for invalid packages and other suspected
media errors ... please feel free to reopen this error if you are unable to
install onto this system as setup above using the fisher public beta, or if you
have any additional information on the current setup that may allow us to
reproduce the problem ... thanks for your report! :)

Disk /dev/hda: 255 heads, 63 sectors, 3737
cylinders                                        
Units = cylinders of 16065 * 512
bytes                                                      
                                                                                            
   Device Boot    Start       End    Blocks   Id 
System                                    
/dev/hda1             1       383   3076416    7 
HPFS/NTFS                                 
/dev/hda2           384       511   1028160   83 
Linux                                     
/dev/hda3           512      3737  25912845    5 
Extended                                  
/dev/hda5           512       639   1028128+   7 
HPFS/NTFS                                 
/dev/hda6           640       767   1028128+  83 
Linux                                     
/dev/hda7           768       895   1028128+  83 
Linux                                     
/dev/hda8           896      1023   1028128+  83 
Linux                                     
/dev/hda9          1024      1151   1028128+   6 
FAT16                                     
/dev/hda10         1152      1279   1028128+  82  Linux
swap                                
                                                                                            

Note You need to log in before you can comment on or make changes to this bug.