Bug 214664 - Firefox update causes dependency problem
Firefox update causes dependency problem
Status: CLOSED DUPLICATE of bug 214659
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 14:58 EST by Michel Alexandre Salim
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 16:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-11-08 14:58:58 EST
Description of problem:
Firefox in Core has been updated to 1.5.0.8, while liferea still depends on
1.5.0.7, causing yum update to break. Please rebuild Liferea

Version-Release number of selected component (if applicable):
1.0.25-1

How reproducible:
Always

Steps to Reproduce:
1. yum install liferea
2. yum update

Additional info:
Is liferea not updated for FC-5 anymore? I think it's Extras policy to support
the same releases as FC if possible.
Comment 1 Konrad Kosmowski 2006-11-08 16:16:07 EST
I have the same issue here.

Why does liferea depend on specific version of Firefox?

Firefox support in liferea is optional. I think it could be splitted into two
excluding themselves packages:

liferea - the application itself
liferea-firefox (with firefox dependency) - for users who want to have firefox
support in liferea

I think it is technically possible, Debian does it.

http://liferea.sourceforge.net/faq.htm

If your Liferea installation was compiled with Mozilla support. In case you did
compile yourself you can check this in the summary output of configure. Note
that some distributions like Debian split the Liferea package into several
parts. To use Liferea with Mozilla on a Debian installation you need the
packages liferea and liferea-mozilla.
Comment 2 Peter Gordon 2006-11-08 16:19:55 EST
Same issue as bug #214659; marking this bug as a duplicate of that. Thanks.

*** This bug has been marked as a duplicate of 214659 ***

Note You need to log in before you can comment on or make changes to this bug.