Bug 214681 - Password dialog with garbled characters in LANG=ja_JP.eucJP system
Password dialog with garbled characters in LANG=ja_JP.eucJP system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 15:54 EST by nakai
Modified: 2008-03-18 14:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
covert pam messages from users locale to utf8 (2.08 KB, patch)
2006-11-09 10:43 EST, Ray Strode [halfline]
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 372707 None None None Never

  None (edit)
Description nakai 2006-11-08 15:54:37 EST
Description of problem:
In the environment of LANG=ja_JP.eucJP, 
``Password''(in fact Japanese characters) is written in garbled characters 
at the password dialog box for unlocking screen.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.16.1-2.fc6

How reproducible:
always

Steps to Reproduce:
for example
1. $ gnome-screensaver-command --exit 
2. $ LANG=ja_JP.eucJP gnome-screensaver
3. $ gnome-screensaver-command --lock
  
Actual results:
please see this picture
http://naka-e.no-ip.com/tmp/garbled.png

Expected results:
http://naka-e.no-ip.com/tmp/utf8.png
(if LANG=ja_JP.UTF-8, it has no problem)

Additional info:
Comment 1 Ray Strode [halfline] 2006-11-08 16:02:01 EST
Hi nakai:

what if you set LANG=ja_JP.utf8 ?
Comment 2 nakai 2006-11-08 16:48:55 EST
(In reply to comment #1)
> Hi nakai:
> 
> what if you set LANG=ja_JP.utf8 ?

Excuse me.
You are telling me to try LANG=ja_JP.utf8 instead of LANG=ja_JP.UTF-8 ?

I tried LANG=ja_JP.utf8, it was same as LANG=ja_JP.UTF-8.
Comment 3 jmccann 2006-11-08 17:28:23 EST
Looks like we're missing a g_locale_to_utf8 call.
Comment 4 Ray Strode [halfline] 2006-11-08 20:25:01 EST
Hi nakai,

I was asking you to try ja_JP.utf8 (or ja_JP.UTF-8, it doesn't matter) instead
of ja_JP.eucJP.

I am just trying to confirm that this problem is because we aren't converting
the pam messages from the user's encoding to the encoding gtk+ expects
internally (which is utf8)

Can you reconfirm that LANG=ja_JP.utf8 *doesn't* work either?  Because if a utf8
locale doesn't work then this bug might not be as straight forward as it seems.
Comment 5 nakai 2006-11-09 00:38:10 EST
(In reply to comment #4)
LANG=ja_JP.utf8 works as expected.

I captured this picture (in ``Expected results'')
as ja_JP.UTF-8.
http://naka-e.no-ip.com/tmp/utf8.png
Comment 6 Ray Strode [halfline] 2006-11-09 10:23:53 EST
Oh I see.

Sorry for the confusion nakai.  Somehow I didn't read the last part of your
initial comment.
Comment 7 Ray Strode [halfline] 2006-11-09 10:43:30 EST
Created attachment 140784 [details]
covert pam messages from users locale to utf8

I think something like the above should fix things up.	I'll push this patch
into updates-testing so you can try it, nakai.

Jon, does this look sane to you?
Comment 8 jmccann 2006-11-09 10:45:15 EST
The upstream patch doesn't fix it?
Comment 9 Ray Strode [halfline] 2006-11-09 10:47:07 EST
ahh, I didn't notice you already fixed this upstream!

Okay, so we'll just roll your fix in with the next 2.16 release we push to updates.
Comment 10 jmccann 2006-11-09 10:54:49 EST
Oh, I need to add your check for when it fails...  I'll add that bit now.

off topic: do you want to get the auth async stuff upstream?  I can't remember
if I have a patch for that or if you think it is ready.

Thanks.
Comment 11 Ray Strode [halfline] 2006-11-09 11:01:02 EST
Yea I definitely want to get it upstream.  I gave you a patch at one point, I
think, but in a downstream report not an upstream one.

I had to disable it in rawhide because it was causing issues with
gnome-screensaver 2.17 (bug 212194) that I haven't had time to look into yet, so
you might want to wait until I get that sorted out.

Comment 12 jmccann 2006-11-09 11:25:14 EST
Yeah it is way better to fix this in gs-auth so I've reverted my patch and
applied one based on yours with tiny fixes for c99ism, casting, and indentation.
  Thanks for the sanity check!  I've attached the patch that was committed to
the gnome  bug.

Sounds good about the other issue.  Let me know.

Thanks Ray.
Comment 13 nakai 2006-11-10 14:58:54 EST
> I'll push this patch
> into updates-testing so you can try it, nakai.

Now, is it available?
I can't find it in
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/6/i386/


By the way, I could make sure that this problem was fixed by patching Ray's one
into gnome-screensaver-2.16.1-2.fc6.src.rpm (and rebuilding it).

However, I can't patch Jon's.
-----------
$ cd gnome-screensaver-2.16.1/
$ patch -p0 < patchfile 
patching file ChangeLog
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file ChangeLog.rej
patching file src/gnome-screensaver-dialog.c
Hunk #1 FAILED at 207.
Hunk #2 FAILED at 255.
2 out of 2 hunks FAILED -- saving rejects to file src/gnome-screensaver-dialog.c.rej
patching file src/gs-auth-pam.c
-----------

How to patch?
Comment 14 Ray Strode [halfline] 2006-11-10 15:26:52 EST
Hey nakai,

So I dropped the ball a bit and didn't end up building the package.  it's going
through the build system now, but it's currently frozen because a tree compose
is underway.

Jons patch likely doesn't apply because of the async auth stuff he mentioned in
comment 10.

If you want, you can comment out those patches
(
%patch2 -p1 -b .better-pam-integration
%patch3 -p1 -b .securitytoken
)

you might have to trim out the changelog part of his patch.

Alternatively, you can wait until tomorrow and the update should be in testing

Comment 15 nakai 2006-11-10 15:51:35 EST
I see.

I will wait.
thanks.
Comment 16 Ray Strode [halfline] 2008-03-18 14:41:10 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.