Bug 214709 - Date::Manip unable to determine TimeZone.
Date::Manip unable to determine TimeZone.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-DateManip (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Robin Norwood
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 17:08 EST by Andrey Subbotin
Modified: 2008-04-04 04:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 04:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Subbotin 2006-11-08 17:08:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061024 Firefox/2.0

Description of problem:
I have set up my timezone as "Asia/Krasnoyarsk" when installing FC6. It corresponds to the KRAT time zone as reported by the date command.

The problem is the perl Date::Manip module isn't recognizing this timezone. If you run perldoc Date::Manip and see the list of the zones it understands, you'll see the KRAT zone isn't listed. Eventually, KRAT is equal to CCT (+0800 China Coast, USSR Zone 7) and echoing CCT to /etc/timezone makes the Date::Manip module happy. But until you do so, all the perl scripts that use Date::Manip fail to run, including /etc/cron.daily/0logwatch.

Version-Release number of selected component (if applicable):
perl-DateManip-5.44-1.2.1

How reproducible:
Always


Steps to Reproduce:
1. Set timezone to KRAT.
2. Run /etc/cron.daily/0logwatch

Actual Results:
ERROR: Date::Manip unable to determine TimeZone.

Execute the following command in a shell prompt:
        perldoc Date::Manip
The section titled TIMEZONES describes valid TimeZones
and where they can be defined.

Expected Results:
The command should run fluently w/o an error.

Additional info:
Comment 1 Steven Pritchard 2006-11-09 16:05:20 EST
This has been reported upstream already.

  http://rt.cpan.org/NoAuth/Bug.html?id=16360

This is a duplicate of bug 174984 and bug 100786.  Bug 100786 was closed CANTFIX
since it was opened against RH9.  Can someone reopen that and change the
product/version?  (Or maybe it should just be marked a duplicate of this ticket.)
Comment 2 Robin Norwood 2006-11-09 18:29:32 EST
I went ahead and added a simple patch to perl-DateManip to include the requested
timezone.  This should be available in FC6-testing in the next day or two. 
Andrey, if you could verify that this fixes your issue, I'll push it as an
update to FC6.
Comment 3 Robin Norwood 2006-11-09 18:31:06 EST
Steven, I reopened bug #100786 as you requested, and assigned it to me.  Thanks
for digging it up!
Comment 4 Fedora Update System 2006-11-10 09:44:56 EST
perl-DateManip-5.44-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Andrey Subbotin 2006-11-10 17:28:05 EST
(In reply to comment #2)
> Andrey, if you could verify that this fixes your issue, I'll push it as an
> update to FC6.

Yup. It now works just fine.
Comment 6 Fedora Update System 2006-11-10 21:00:32 EST
perl-DateManip-5.44-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Robin Norwood 2006-12-01 10:28:44 EST
fwiw, the maintainer of Date::Manip has added the new TZ to the next version.
Comment 8 Peter A. Shevtsov 2006-12-06 23:42:12 EST
My FC6 uses the lates version of perl-DateManip (perl-DateManip-5.44-2.fc6).
My time zone is "Asia/Novosibirsk" (NOVT) and running /etc/cron.daily/0logwatch
outputs the same error message as Andrey provided: ERROR: Date::Manip unable to
determine TimeZone.
Comment 9 CK Ng 2007-05-21 22:49:24 EDT
Redhat EL 5 and perl-DateManip-5.44-1.2.1 having same error on 
/etc/cron.daily/0logwatch. Time zone is "Asia/Kuala_Lumpur" (GMT+8).
Comment 10 Dominik Sandjaja 2007-09-13 22:38:24 EDT
Also getting this error on Fedora 7, perl-DateManip-5.44-3.fc7 . My current
timezone is Makassar (GMT-8 I think). I didn't have that problem when being back
in Germany, Berlin timezone.
Comment 11 Nicole Dai 2008-01-21 00:30:55 EST
Reproduced the bug with perl-DateManip-5.44-1.2.1 on FC6 and verified no such
error occurred when execute logwatch with perl-DateManip-5.44-2.fc6 by using
"Asia/Krasnoyarsk" timezone. But same error prompted by using "Asia/Novosibirsk"
with perl-DateManip-5.44-2.fc6. So assign it back. 
Comment 12 Bug Zapper 2008-04-04 00:32:37 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 13 Marcela Mašláňová 2008-04-04 04:49:24 EDT
I updated Date::Manip for F-7 and F-8.

Note You need to log in before you can comment on or make changes to this bug.