Bug 214779 - Amarok crashes when an iPod (nano) is mounted
Amarok crashes when an iPod (nano) is mounted
Status: CLOSED DUPLICATE of bug 211648
Product: Fedora
Classification: Fedora
Component: libgpod (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 214781 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 09:02 EST by Valent Turkovic
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 03:45:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 133411 None None None Never

  None (edit)
Description Valent Turkovic 2006-11-09 09:02:39 EST
Description of problem:
Amarok crashes every time I have my iPod Nano plugged in. I traced the problem 
to a file named "/IPOD/iPod_Control/Device/SysInfo" when this file isn't 
present my Ipod syncs with Amarok just fine. 

I tried it with different Amarok versions and the bug is present in all 
releases so far; 1.4 trough 1.4.4. I tested it on Fedora Core 5, Fedora Core 6 
and SimplyMephis 6.0.

The solution it to upgrade libgpod to version 0.4 so please make new version 
available trough upgrade repositories.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Plug iPod to usb port
2. Wait until it mounts
3. Start Amarok... CRASH :(
  
Actual results:


Expected results:
I expect Amarok to work with iPod

Additional info:
http://bugs.kde.org/show_bug.cgi?id=133411
Comment 1 Ngo Than 2006-11-09 10:44:50 EST
*** Bug 214781 has been marked as a duplicate of this bug. ***
Comment 2 Valent Turkovic 2006-11-09 14:03:44 EST
Sorry for double posting.
Comment 3 eejut 2006-12-09 05:18:18 EST
Upgrading to the 0.4 version from freshrpms fixes the crashing issue, but Amarok
then corrupts the iPod database!

Compiling the fc6 amarok update srpm against the libgpod-devel package from
freshrpms makes amarok work correctly again with new iPod (this includes iPod
video). This package must be upgraded urgently, but also downstream dependant
packages must also be rereleased to avoid corruption
Comment 4 Alexander Larsson 2006-12-11 03:45:34 EST

*** This bug has been marked as a duplicate of 211648 ***
Comment 5 Valent Turkovic 2006-12-11 14:03:13 EST
Is there a solution? When I use libgpod-0.4 all files transfered to my Ipod Nano
can't be played! So I'm back to useing libgpod-0.3 and reaseing that problematci
file that causes amarok libgpod to crash. Can't rememeber the name of the file
because my nano isn't mounted right now.

Note You need to log in before you can comment on or make changes to this bug.