Bug 2148206 - F37: Bootloader installer fails on early-mid-2010s Apple hardware
Summary: F37: Bootloader installer fails on early-mid-2010s Apple hardware
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 37
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-24 15:46 UTC by jworrell
Modified: 2023-01-10 14:29 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-01-10 14:29:02 UTC
Type: Bug


Attachments (Terms of Use)
storage.log with error (234.02 KB, text/plain)
2022-11-24 15:46 UTC, jworrell
no flags Details

Description jworrell 2022-11-24 15:46:01 UTC
Created attachment 1927104 [details]
storage.log with error

Created attachment 1927104 [details]
storage.log with error

Description of problem: Fedora 37 fails to install to late 2013 iMac (also 2015 MacBook Pro, 2012 MacMini, 2014 MacBook Pro -- not sure what these all have in common, see: https://ask.fedoraproject.org/t/bootloader-installer-fails-for-fedora-37-on-macbook-pro-2015-manjaro-installs-fine-on-the-same-machine/28968/3 )


Version-Release number of selected component (if applicable): Unsure how to verify exact Anaconda version, but this was Fedora Workstation 37 iso, downloaded from official site on Wednesday, November 23rd, 2022.


How reproducible:
1. Boot to Live CD
2. Click to install Fedora
3. Proceed with defaults (both reclaiming space/deleting all partitions and starting with an empty partition table produced the same result.) 
4. Continue install after first error (see below)
5. Same error occurs again later in install process, continue install again

Actual results:
Install throws warning "Bootloader installation has failed: Failed to set new efi boot target. This is most likely a kernel or firmware bug." Proceeding regardless does not produce a bootable system.

Expected results:
Fedora installer produces bootable system


Additional info:
Works without error on the same machine on F36

Comment 1 jworrell 2022-11-24 16:35:40 UTC
I modified '/usr/lib64/python3.11/site-packages/pyanaconda/modules/storage/bootloader/efi.py' in place to log its arguments on an exception:

    def _add_single_efi_boot_target(self, partition):
        boot_disk = partition.disk
        boot_part_num = str(partition.parted_partition.number)

        create_method = "-C" if self.keep_boot_order else "-c" # pylint: disable=no-member

        rc = self.efibootmgr(
            create_method, "-w", "-L", productName.split("-")[0],  # pylint: disable=no-member
            "-d", boot_disk.path, "-p", boot_part_num,
            "-l", self.efi_dir_as_efifs_dir + self._efi_binary,  # pylint: disable=no-member
            root=conf.target.system_root
        )
        if rc:
            # ADDED IN-PLACE
            log.error("self.efibootmgr: %s", str((create_method, "-w", "-L", productName.split("-")[0],  # pylint: disable=no-member
            "-d", boot_disk.path, "-p", boot_part_num,
            "-l", self.efi_dir_as_efifs_dir + self._efi_binary, conf.target.system_root)))

            # ADDED IN-PLACE
            log.error("rc: %s", rc)

            raise BootLoaderError("Failed to set new efi boot target. This is most "
                                  "likely a kernel or firmware bug.")


Which produced:
ERROR:anaconda.modules.storage.bootloader.efi:self.efibootmgr: ('-c', '-w', '-L', 'Fedora', '-d', '/dev/sda', '-p', '1', '-l', '\\EFI\\fedora\\shimx64.efi', '/mnt/sysroot')
ERROR:anaconda.modules.storage.bootloader.efi:rc: 5


So I believe I can reproduce the issue on the command line:
[root@localhost-live tmp]# efibootmgr -c -w -L Fedora -d /dev/sda -p 1 -l \\EFI\\fedora\\shimx64.efi /mnt/sysroot
Could not prepare Boot variable: Invalid argument


Here is the verbose output of the above:
[root@localhost-live tmp]# efibootmgr -v999 -c -w -L Fedora -d /dev/sda -p 1 -l \\EFI\\fedora\\shimx64.efi /mnt/sysroot
creator.c:167 efi_va_generate_file_device_path_from_esp(): partition:1
linux.c:387 device_get(): partition:1 dev->part:1
linux.c:428 device_get(): dev->link: ../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
linux.c:173 set_disk_and_part_name(): dev->disk_name:(nil) dev->part_name:(nil)
linux.c:174 set_disk_and_part_name(): dev->part:1
linux.c:175 set_disk_and_part_name(): ultimate:'sda'
linux.c:176 set_disk_and_part_name(): penultimate:'block'
linux.c:177 set_disk_and_part_name(): approximate:'0:0:0:0'
linux.c:178 set_disk_and_part_name(): proximate:'target0:0:0'
linux.c:179 set_disk_and_part_name(): psl5:'host0'
linux.c:215 set_disk_and_part_name(): disk:sda part:sda1
linux.c:446 device_get(): dev->disk_name: sda
linux.c:447 device_get(): dev->part_name: sda1
linux.c:484 device_get(): searching for driver from in sda
linux.c:484 device_get(): trying /sys/block/sda/device/driver
linux.c:484 device_get(): trying /sys/block/sda/device/device/driver
linux.c:512 device_get(): searching for device nodes in ../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
linux.c:526 device_get(): trying pmem
linux-pmem.c:69 parse_pmem(): entry
linux.c:561 device_get(): dev_probes[1]: 0x7f31f2c12020 dev->interface_type: 0
linux.c:526 device_get(): trying acpi_root
linux-acpi-root.c:40 parse_acpi_root(): entry
linux-acpi-root.c:50 parse_acpi_root(): current:'../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:14 pos1:-1
linux.c:561 device_get(): dev_probes[2]: 0x7f31f2c121a0 dev->interface_type: 0
linux.c:526 device_get(): trying pci_root
linux-pci-root.c:38 parse_pci_root(): entry
linux-pci-root.c:46 parse_pci_root(): current:'../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:2 pos0:0 pos1:25
linux-pci-root.c:47 parse_pci_root():          ^^^^^^^^^^^^^^^^^^^^^^^^^ 
linux-acpi.c:28 parse_acpi_hid_uid(): entry
linux-acpi.c:33 parse_acpi_hid_uid(): path:devices/pci0000:00 rc:18
linux-acpi.c:43 parse_acpi_hid_uid(): Setting ACPI root path to '\_SB_.PCI0'
linux-acpi.c:62 parse_acpi_hid_uid(): rc:1 hid:0x00000a08
linux-acpi.c:77 parse_acpi_hid_uid(): acpi root HID:0x0a0341d0
linux-acpi.c:100 parse_acpi_hid_uid(): acpi root UID:0x0 uidstr:'(null)'
linux-pci-root.c:64 parse_pci_root(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' sz:25
linux.c:536 device_get(): pci_root matched '../../devices/pci0000:00/'
linux-pci-root.c:73 dp_create_pci_root(): entry buf:(nil) size:0 off:0
linux-pci-root.c:74 dp_create_pci_root(): returning 0
linux-pci-root.c:89 dp_create_pci_root(): creating acpi_hid dp hid:0x0a0341d0 uid:0x0
linux-pci-root.c:102 dp_create_pci_root(): returning 12
linux-pci-root.c:73 dp_create_pci_root(): entry buf:0x7ffd6d9bba20 size:12 off:0
linux-pci-root.c:74 dp_create_pci_root(): returning 0
linux-pci-root.c:89 dp_create_pci_root(): creating acpi_hid dp hid:0x0a0341d0 uid:0x0
linux-pci-root.c:102 dp_create_pci_root(): returning 12
dp-acpi.c:157 _format_acpi_dn(): formatting ACPI HID 0x0a0341d0
dp-acpi.c:157 _format_acpi_dn(): formatting ACPI HID 0x0a0341d0
linux.c:365 print_dev_dp_node(): Device path node is PciRoot(0x0)
linux.c:552 device_get(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda'
linux.c:521 device_get(): not testing soc_root because flags is 0x5
linux.c:521 device_get(): not testing virtual_root because flags is 0x5
linux.c:526 device_get(): trying pci
linux-pci.c:37 parse_pci(): entry
linux-pci.c:51 parse_pci(): searching for 0000:00:00.0/
linux-pci.c:54 parse_pci(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:4 pos0:0 pos1:13
linux-pci.c:55 parse_pci():          ^^^^^^^^^^^^^ 
linux-pci.c:60 parse_pci(): found pci domain 0000:00:1f.02
linux-pci.c:95 parse_pci(): driver:../../../bus/pci/drivers/ahci
linux-pci.c:51 parse_pci(): searching for 0000:00:00.0/
linux-pci.c:54 parse_pci(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:-1
linux-pci.c:102 parse_pci(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' sz:13
linux.c:536 device_get(): pci matched '0000:00:1f.2/'
linux-pci.c:112 dp_create_pci(): entry buf:(nil) size:0 off:0
linux-pci.c:114 dp_create_pci(): creating PCI device path nodes
linux-pci.c:116 dp_create_pci(): creating PCI device path node 0
linux-pci.c:128 dp_create_pci(): returning 6
linux-pci.c:112 dp_create_pci(): entry buf:0x7ffd6d9bba30 size:6 off:0
linux-pci.c:114 dp_create_pci(): creating PCI device path nodes
linux-pci.c:116 dp_create_pci(): creating PCI device path node 0
linux-pci.c:128 dp_create_pci(): returning 6
linux.c:365 print_dev_dp_node(): Device path node is Pci(0x1f,0x2)
linux.c:552 device_get(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda'
linux.c:526 device_get(): trying virtio block
linux-virtblk.c:41 parse_virtblk(): entry
linux-virtblk.c:43 parse_virtblk(): searching for virtio0/
linux-virtblk.c:45 parse_virtblk(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:0 pos1:-1
linux.c:561 device_get(): dev_probes[7]: 0x7f31f2c12260 dev->interface_type: 0
linux.c:526 device_get(): trying sas
linux-sas.c:149 parse_sas(): entry
linux-scsi.c:36 parse_scsi_link(): entry
linux-scsi.c:88 parse_scsi_link(): searching for host4/
linux-scsi.c:90 parse_scsi_link(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:-1 pos1:-1
linux.c:561 device_get(): dev_probes[8]: 0x7f31f2c122a0 dev->interface_type: 0
linux.c:526 device_get(): trying sata
linux-sata.c:138 parse_sata(): entry
linux-sata.c:148 parse_sata(): searching for ata1/
linux-sata.c:150 parse_sata(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:5
linux-sata.c:151 parse_sata():          ^^^^^ 
linux-sata.c:162 parse_sata(): searching for host0/
linux-sata.c:164 parse_sata(): current:'host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:6
linux-sata.c:165 parse_sata():          ^^^^^^ 
linux-sata.c:171 parse_sata(): searching for target0:0:0:0/
linux-sata.c:174 parse_sata(): current:'target0:0:0/0:0:0:0/block/sda' rc:3 pos0:0 pos1:12
linux-sata.c:175 parse_sata():          ^^^^^^^^^^^^ 
linux-sata.c:181 parse_sata(): searching for 0:0:0:0/
linux-sata.c:184 parse_sata(): current:'0:0:0:0/block/sda' rc:4 pos0:0 pos1:8
linux-sata.c:185 parse_sata():          ^^^^^^^^ 
linux-sata.c:202 parse_sata(): current:'block/sda' sz:31
linux.c:536 device_get(): sata matched 'ata1/host0/target0:0:0/0:0:0:0/'
linux-sata.c:212 dp_create_sata(): entry buf:(nil) size:0 off:0
linux-sata.c:212 dp_create_sata(): entry buf:0x7ffd6d9bba20 size:10 off:0
linux.c:365 print_dev_dp_node(): Device path node is Sata(0,65535,0)
linux.c:552 device_get(): current:'block/sda'
creator.c:217 efi_va_generate_file_device_path_from_esp(): EFIBOOT_ABBREV_HD
creator.c:313 efi_va_generate_file_device_path_from_esp(): = 98
loadopt.c:35 efi_loadopt_create(): entry buf:(nil) size:0 dp:(nil) dp_size:98
creator.c:167 efi_va_generate_file_device_path_from_esp(): partition:1
linux.c:387 device_get(): partition:1 dev->part:1
linux.c:428 device_get(): dev->link: ../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
linux.c:173 set_disk_and_part_name(): dev->disk_name:(nil) dev->part_name:(nil)
linux.c:174 set_disk_and_part_name(): dev->part:1
linux.c:175 set_disk_and_part_name(): ultimate:'sda'
linux.c:176 set_disk_and_part_name(): penultimate:'block'
linux.c:177 set_disk_and_part_name(): approximate:'0:0:0:0'
linux.c:178 set_disk_and_part_name(): proximate:'target0:0:0'
linux.c:179 set_disk_and_part_name(): psl5:'host0'
linux.c:215 set_disk_and_part_name(): disk:sda part:sda1
linux.c:446 device_get(): dev->disk_name: sda
linux.c:447 device_get(): dev->part_name: sda1
linux.c:484 device_get(): searching for driver from in sda
linux.c:484 device_get(): trying /sys/block/sda/device/driver
linux.c:484 device_get(): trying /sys/block/sda/device/device/driver
linux.c:512 device_get(): searching for device nodes in ../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
linux.c:526 device_get(): trying pmem
linux-pmem.c:69 parse_pmem(): entry
linux.c:561 device_get(): dev_probes[1]: 0x7f31f2c12020 dev->interface_type: 0
linux.c:526 device_get(): trying acpi_root
linux-acpi-root.c:40 parse_acpi_root(): entry
linux-acpi-root.c:50 parse_acpi_root(): current:'../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:14 pos1:-1
linux.c:561 device_get(): dev_probes[2]: 0x7f31f2c121a0 dev->interface_type: 0
linux.c:526 device_get(): trying pci_root
linux-pci-root.c:38 parse_pci_root(): entry
linux-pci-root.c:46 parse_pci_root(): current:'../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:2 pos0:0 pos1:25
linux-pci-root.c:47 parse_pci_root():          ^^^^^^^^^^^^^^^^^^^^^^^^^ 
linux-acpi.c:28 parse_acpi_hid_uid(): entry
linux-acpi.c:33 parse_acpi_hid_uid(): path:devices/pci0000:00 rc:18
linux-acpi.c:43 parse_acpi_hid_uid(): Setting ACPI root path to '\_SB_.PCI0'
linux-acpi.c:62 parse_acpi_hid_uid(): rc:1 hid:0x00000a08
linux-acpi.c:77 parse_acpi_hid_uid(): acpi root HID:0x0a0341d0
linux-acpi.c:100 parse_acpi_hid_uid(): acpi root UID:0x0 uidstr:'(null)'
linux-pci-root.c:64 parse_pci_root(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' sz:25
linux.c:536 device_get(): pci_root matched '../../devices/pci0000:00/'
linux-pci-root.c:73 dp_create_pci_root(): entry buf:(nil) size:0 off:0
linux-pci-root.c:74 dp_create_pci_root(): returning 0
linux-pci-root.c:89 dp_create_pci_root(): creating acpi_hid dp hid:0x0a0341d0 uid:0x0
linux-pci-root.c:102 dp_create_pci_root(): returning 12
linux-pci-root.c:73 dp_create_pci_root(): entry buf:0x7ffd6d9bba20 size:12 off:0
linux-pci-root.c:74 dp_create_pci_root(): returning 0
linux-pci-root.c:89 dp_create_pci_root(): creating acpi_hid dp hid:0x0a0341d0 uid:0x0
linux-pci-root.c:102 dp_create_pci_root(): returning 12
dp-acpi.c:157 _format_acpi_dn(): formatting ACPI HID 0x0a0341d0
dp-acpi.c:157 _format_acpi_dn(): formatting ACPI HID 0x0a0341d0
linux.c:365 print_dev_dp_node(): Device path node is PciRoot(0x0)
linux.c:552 device_get(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda'
linux.c:521 device_get(): not testing soc_root because flags is 0x5
linux.c:521 device_get(): not testing virtual_root because flags is 0x5
linux.c:526 device_get(): trying pci
linux-pci.c:37 parse_pci(): entry
linux-pci.c:51 parse_pci(): searching for 0000:00:00.0/
linux-pci.c:54 parse_pci(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:4 pos0:0 pos1:13
linux-pci.c:55 parse_pci():          ^^^^^^^^^^^^^ 
linux-pci.c:60 parse_pci(): found pci domain 0000:00:1f.02
linux-pci.c:95 parse_pci(): driver:../../../bus/pci/drivers/ahci
linux-pci.c:51 parse_pci(): searching for 0000:00:00.0/
linux-pci.c:54 parse_pci(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:-1
linux-pci.c:102 parse_pci(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' sz:13
linux.c:536 device_get(): pci matched '0000:00:1f.2/'
linux-pci.c:112 dp_create_pci(): entry buf:(nil) size:0 off:0
linux-pci.c:114 dp_create_pci(): creating PCI device path nodes
linux-pci.c:116 dp_create_pci(): creating PCI device path node 0
linux-pci.c:128 dp_create_pci(): returning 6
linux-pci.c:112 dp_create_pci(): entry buf:0x7ffd6d9bba30 size:6 off:0
linux-pci.c:114 dp_create_pci(): creating PCI device path nodes
linux-pci.c:116 dp_create_pci(): creating PCI device path node 0
linux-pci.c:128 dp_create_pci(): returning 6
linux.c:365 print_dev_dp_node(): Device path node is Pci(0x1f,0x2)
linux.c:552 device_get(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda'
linux.c:526 device_get(): trying virtio block
linux-virtblk.c:41 parse_virtblk(): entry
linux-virtblk.c:43 parse_virtblk(): searching for virtio0/
linux-virtblk.c:45 parse_virtblk(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:0 pos1:-1
linux.c:561 device_get(): dev_probes[7]: 0x7f31f2c12260 dev->interface_type: 0
linux.c:526 device_get(): trying sas
linux-sas.c:149 parse_sas(): entry
linux-scsi.c:36 parse_scsi_link(): entry
linux-scsi.c:88 parse_scsi_link(): searching for host4/
linux-scsi.c:90 parse_scsi_link(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:-1 pos1:-1
linux.c:561 device_get(): dev_probes[8]: 0x7f31f2c122a0 dev->interface_type: 0
linux.c:526 device_get(): trying sata
linux-sata.c:138 parse_sata(): entry
linux-sata.c:148 parse_sata(): searching for ata1/
linux-sata.c:150 parse_sata(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:5
linux-sata.c:151 parse_sata():          ^^^^^ 
linux-sata.c:162 parse_sata(): searching for host0/
linux-sata.c:164 parse_sata(): current:'host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:6
linux-sata.c:165 parse_sata():          ^^^^^^ 
linux-sata.c:171 parse_sata(): searching for target0:0:0:0/
linux-sata.c:174 parse_sata(): current:'target0:0:0/0:0:0:0/block/sda' rc:3 pos0:0 pos1:12
linux-sata.c:175 parse_sata():          ^^^^^^^^^^^^ 
linux-sata.c:181 parse_sata(): searching for 0:0:0:0/
linux-sata.c:184 parse_sata(): current:'0:0:0:0/block/sda' rc:4 pos0:0 pos1:8
linux-sata.c:185 parse_sata():          ^^^^^^^^ 
linux-sata.c:202 parse_sata(): current:'block/sda' sz:31
linux.c:536 device_get(): sata matched 'ata1/host0/target0:0:0/0:0:0:0/'
linux-sata.c:212 dp_create_sata(): entry buf:(nil) size:0 off:0
linux-sata.c:212 dp_create_sata(): entry buf:0x7ffd6d9bba20 size:10 off:0
linux.c:365 print_dev_dp_node(): Device path node is Sata(0,65535,0)
linux.c:552 device_get(): current:'block/sda'
creator.c:217 efi_va_generate_file_device_path_from_esp(): EFIBOOT_ABBREV_HD
creator.c:313 efi_va_generate_file_device_path_from_esp(): = 98
creator.c:167 efi_va_generate_file_device_path_from_esp(): partition:1
linux.c:387 device_get(): partition:1 dev->part:1
linux.c:428 device_get(): dev->link: ../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
linux.c:173 set_disk_and_part_name(): dev->disk_name:(nil) dev->part_name:(nil)
linux.c:174 set_disk_and_part_name(): dev->part:1
linux.c:175 set_disk_and_part_name(): ultimate:'sda'
linux.c:176 set_disk_and_part_name(): penultimate:'block'
linux.c:177 set_disk_and_part_name(): approximate:'0:0:0:0'
linux.c:178 set_disk_and_part_name(): proximate:'target0:0:0'
linux.c:179 set_disk_and_part_name(): psl5:'host0'
linux.c:215 set_disk_and_part_name(): disk:sda part:sda1
linux.c:446 device_get(): dev->disk_name: sda
linux.c:447 device_get(): dev->part_name: sda1
linux.c:484 device_get(): searching for driver from in sda
linux.c:484 device_get(): trying /sys/block/sda/device/driver
linux.c:484 device_get(): trying /sys/block/sda/device/device/driver
linux.c:512 device_get(): searching for device nodes in ../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda
linux.c:526 device_get(): trying pmem
linux-pmem.c:69 parse_pmem(): entry
linux.c:561 device_get(): dev_probes[1]: 0x7f31f2c12020 dev->interface_type: 0
linux.c:526 device_get(): trying acpi_root
linux-acpi-root.c:40 parse_acpi_root(): entry
linux-acpi-root.c:50 parse_acpi_root(): current:'../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:14 pos1:-1
linux.c:561 device_get(): dev_probes[2]: 0x7f31f2c121a0 dev->interface_type: 0
linux.c:526 device_get(): trying pci_root
linux-pci-root.c:38 parse_pci_root(): entry
linux-pci-root.c:46 parse_pci_root(): current:'../../devices/pci0000:00/0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:2 pos0:0 pos1:25
linux-pci-root.c:47 parse_pci_root():          ^^^^^^^^^^^^^^^^^^^^^^^^^ 
linux-acpi.c:28 parse_acpi_hid_uid(): entry
linux-acpi.c:33 parse_acpi_hid_uid(): path:devices/pci0000:00 rc:18
linux-acpi.c:43 parse_acpi_hid_uid(): Setting ACPI root path to '\_SB_.PCI0'
linux-acpi.c:62 parse_acpi_hid_uid(): rc:1 hid:0x00000a08
linux-acpi.c:77 parse_acpi_hid_uid(): acpi root HID:0x0a0341d0
linux-acpi.c:100 parse_acpi_hid_uid(): acpi root UID:0x0 uidstr:'(null)'
linux-pci-root.c:64 parse_pci_root(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' sz:25
linux.c:536 device_get(): pci_root matched '../../devices/pci0000:00/'
linux-pci-root.c:73 dp_create_pci_root(): entry buf:(nil) size:0 off:0
linux-pci-root.c:74 dp_create_pci_root(): returning 0
linux-pci-root.c:89 dp_create_pci_root(): creating acpi_hid dp hid:0x0a0341d0 uid:0x0
linux-pci-root.c:102 dp_create_pci_root(): returning 12
linux-pci-root.c:73 dp_create_pci_root(): entry buf:0x7ffd6d9bba20 size:12 off:0
linux-pci-root.c:74 dp_create_pci_root(): returning 0
linux-pci-root.c:89 dp_create_pci_root(): creating acpi_hid dp hid:0x0a0341d0 uid:0x0
linux-pci-root.c:102 dp_create_pci_root(): returning 12
dp-acpi.c:157 _format_acpi_dn(): formatting ACPI HID 0x0a0341d0
dp-acpi.c:157 _format_acpi_dn(): formatting ACPI HID 0x0a0341d0
linux.c:365 print_dev_dp_node(): Device path node is PciRoot(0x0)
linux.c:552 device_get(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda'
linux.c:521 device_get(): not testing soc_root because flags is 0x5
linux.c:521 device_get(): not testing virtual_root because flags is 0x5
linux.c:526 device_get(): trying pci
linux-pci.c:37 parse_pci(): entry
linux-pci.c:51 parse_pci(): searching for 0000:00:00.0/
linux-pci.c:54 parse_pci(): current:'0000:00:1f.2/ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:4 pos0:0 pos1:13
linux-pci.c:55 parse_pci():          ^^^^^^^^^^^^^ 
linux-pci.c:60 parse_pci(): found pci domain 0000:00:1f.02
linux-pci.c:95 parse_pci(): driver:../../../bus/pci/drivers/ahci
linux-pci.c:51 parse_pci(): searching for 0000:00:00.0/
linux-pci.c:54 parse_pci(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:-1
linux-pci.c:102 parse_pci(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' sz:13
linux.c:536 device_get(): pci matched '0000:00:1f.2/'
linux-pci.c:112 dp_create_pci(): entry buf:(nil) size:0 off:0
linux-pci.c:114 dp_create_pci(): creating PCI device path nodes
linux-pci.c:116 dp_create_pci(): creating PCI device path node 0
linux-pci.c:128 dp_create_pci(): returning 6
linux-pci.c:112 dp_create_pci(): entry buf:0x7ffd6d9bba30 size:6 off:0
linux-pci.c:114 dp_create_pci(): creating PCI device path nodes
linux-pci.c:116 dp_create_pci(): creating PCI device path node 0
linux-pci.c:128 dp_create_pci(): returning 6
linux.c:365 print_dev_dp_node(): Device path node is Pci(0x1f,0x2)
linux.c:552 device_get(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda'
linux.c:526 device_get(): trying virtio block
linux-virtblk.c:41 parse_virtblk(): entry
linux-virtblk.c:43 parse_virtblk(): searching for virtio0/
linux-virtblk.c:45 parse_virtblk(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:0 pos1:-1
linux.c:561 device_get(): dev_probes[7]: 0x7f31f2c12260 dev->interface_type: 0
linux.c:526 device_get(): trying sas
linux-sas.c:149 parse_sas(): entry
linux-scsi.c:36 parse_scsi_link(): entry
linux-scsi.c:88 parse_scsi_link(): searching for host4/
linux-scsi.c:90 parse_scsi_link(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:0 pos0:-1 pos1:-1
linux.c:561 device_get(): dev_probes[8]: 0x7f31f2c122a0 dev->interface_type: 0
linux.c:526 device_get(): trying sata
linux-sata.c:138 parse_sata(): entry
linux-sata.c:148 parse_sata(): searching for ata1/
linux-sata.c:150 parse_sata(): current:'ata1/host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:5
linux-sata.c:151 parse_sata():          ^^^^^ 
linux-sata.c:162 parse_sata(): searching for host0/
linux-sata.c:164 parse_sata(): current:'host0/target0:0:0/0:0:0:0/block/sda' rc:1 pos0:0 pos1:6
linux-sata.c:165 parse_sata():          ^^^^^^ 
linux-sata.c:171 parse_sata(): searching for target0:0:0:0/
linux-sata.c:174 parse_sata(): current:'target0:0:0/0:0:0:0/block/sda' rc:3 pos0:0 pos1:12
linux-sata.c:175 parse_sata():          ^^^^^^^^^^^^ 
linux-sata.c:181 parse_sata(): searching for 0:0:0:0/
linux-sata.c:184 parse_sata(): current:'0:0:0:0/block/sda' rc:4 pos0:0 pos1:8
linux-sata.c:185 parse_sata():          ^^^^^^^^ 
linux-sata.c:202 parse_sata(): current:'block/sda' sz:31
linux.c:536 device_get(): sata matched 'ata1/host0/target0:0:0/0:0:0:0/'
linux-sata.c:212 dp_create_sata(): entry buf:(nil) size:0 off:0
linux-sata.c:212 dp_create_sata(): entry buf:0x7ffd6d9bba20 size:10 off:0
linux.c:365 print_dev_dp_node(): Device path node is Sata(0,65535,0)
linux.c:552 device_get(): current:'block/sda'
creator.c:217 efi_va_generate_file_device_path_from_esp(): EFIBOOT_ABBREV_HD
creator.c:313 efi_va_generate_file_device_path_from_esp(): = 98
loadopt.c:35 efi_loadopt_create(): entry buf:0x55e0521155b0 size:130 dp:0x55e05211b370 dp_size:98
loadopt.c:46 efi_loadopt_create(): testing buf
loadopt.c:53 efi_loadopt_create(): testing optional data presence
loadopt.c:57 efi_loadopt_create(): testing dp presence
loadopt.c:62 efi_loadopt_create(): testing dp validity
loadopt.c:69 efi_loadopt_create(): testing dp size: dp_size:98 efidp_size(dp):98
Could not prepare Boot variable: Invalid argument
error trace:
 efivarfs.c:445 efivarfs_set_variable(): writing to fd 4 failed: Invalid argument
 lib.c:78 _efi_set_variable_mode(): ops->set_variable() failed: Invalid argument
 efibootmgr.c:331 make_var(): efi_set_variable failed: Invalid argument
 efibootmgr.c:341 make_var(): Could not set variable Boot0000: Invalid argument

Comment 3 John Evans 2022-11-29 15:23:25 UTC
I saw the same thing bug using the official Fedora 37 release on a 2013 imac.  However, in my case I was able to use Fedora-Workstation-Live-x86_64-37_Beta-1.5.iso and that installed just fine.

Comment 4 Frederick Doe 2022-12-04 15:32:32 UTC
I can confirm that this bug affects my 2017 MacBook as well.

Comment 5 Basil Eric Rabi 2022-12-08 07:27:57 UTC
Seem to be fixed now in the live respins

Comment 6 Frederick Doe 2022-12-16 12:18:51 UTC
Has the fix been added to the official Fedora installer? I downloaded the ISO a couple of days ago and compared the SHA256 hash to the hash of the ISO that had the bug. It was identical.

I hope that this gets fixed soon. The look forward to using Fedora on my Mac laptops 🙂

Comment 7 Basil Eric Rabi 2022-12-16 12:25:10 UTC
(In reply to Frederick Doe from comment #6)
> Has the fix been added to the official Fedora installer? I downloaded the
> ISO a couple of days ago and compared the SHA256 hash to the hash of the ISO
> that had the bug. It was identical.
> 
> I hope that this gets fixed soon. The look forward to using Fedora on my Mac
> laptops 🙂

It's fixed in the live respins. I was able to intall it in my Macmini 2014.
I think those images are officially part of the Fedora Project.
https://dl.fedoraproject.org/pub/alt/live-respins/

Comment 8 Martin Kolman 2023-01-10 14:29:02 UTC
(In reply to Basil Eric Rabi from comment #7)
> (In reply to Frederick Doe from comment #6)
> > Has the fix been added to the official Fedora installer? I downloaded the
> > ISO a couple of days ago and compared the SHA256 hash to the hash of the ISO
> > that had the bug. It was identical.
> > 
> > I hope that this gets fixed soon. The look forward to using Fedora on my Mac
> > laptops 🙂
> 
> It's fixed in the live respins. I was able to intall it in my Macmini 2014.
> I think those images are officially part of the Fedora Project.
> https://dl.fedoraproject.org/pub/alt/live-respins/

I think it would be good to note in which component this has been fixed for future refference. But from installer PoV this is now working.


Note You need to log in before you can comment on or make changes to this bug.