Bug 214823 - Crash of Yumex with FC6
Crash of Yumex with FC6
Status: CLOSED DUPLICATE of bug 214831
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 12:14 EST by Greg Douglas
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 12:39:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Douglas 2006-11-09 12:14:48 EST
Sorry for recording against Yum, but for some reason, Yumex is not in the
component list.


Description of problem:

Since upgrading to FC6, Yumex no longer works.  An error message appears and
requests to post the problem to this repository.  Here is the error message:

Component: yumex
Version: 1.1.7
Summary: TBf0b64ae8 updates.py:584:getObsoletesList:AttributeError: Updates
instance has no attribute 'obsoletes'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1102, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 536, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 990, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 449, in
build_package_lists
    updates = self.up.getUpdatesList() + self.up.getObsoletesList()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 584, in
getObsoletesList
    tmplist = self.obsoletes.keys()
AttributeError: Updates instance has no attribute 'obsoletes'

Local variables in innermost frame:
newest: 0
self: <rpmUtils.updates.Updates instance at 0x9e412ec>
arch: None
name: None





Version-Release number of selected component (if applicable):

Version: 1.1.7

How reproducible:

Every time Yumex is loaded.  It worked fine in FC5.

Steps to Reproduce:
1. Open Yumex
2. It crashes during initialization after a few minues.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Greg Douglas 2006-11-09 12:39:18 EST
Please cancel this request, I have found the correct place to post this problem.

Sorry for the inconvenience.

Greg

*** This bug has been marked as a duplicate of 214831 ***

Note You need to log in before you can comment on or make changes to this bug.