Bug 21510 - could not create swap partition
could not create swap partition
Status: CLOSED DUPLICATE of bug 16686
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-30 08:20 EST by shivaji apte
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 12:28:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shivaji apte 2000-11-30 08:20:31 EST
I have an Acer machine (256MB RAM, 9.8GB HD).
I had configured the following partition scheme:
   /hda1   ---> /win (windows partition) 6000MB
   /hda2   ---> /boot                    24MB
   /hda3   ---> swap                     256MB
   /hda4   ---> /usr                     2000MB
   /hda5   ---> /                        1400MB

While installing, it failed giving some error like 'unable to create swap 
partition. This is an exceptional condition and might be a bug....'

The log is attached below:
------------------------------------------------------------------------
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in 
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in 
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 24097
fsystem: ext2
self: <fstab.GuiFstab instance at 84ba848>
msg: Invalid argument
doFormat: 1
errno: 22
device: hda2
instPath: /mnt/sysimage
mntpoint: /boot

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
-----------------------------------------------------------------------

However, the same installation when attempted again went through fine.

Shivaji
Comment 1 Michael Fulbright 2000-11-30 12:20:07 EST
What was your original partitioning scheme before you created the partitions
listed in your bug report?

This is a dupe of bug 16686, and we're having trouble reproducing it. Your info
would really help!
Comment 2 shivaji apte 2000-11-30 23:02:55 EST
The original configuration before I used the fdisk was:
   1 big fat ugly 9.8GB partition with Win2K on it.

Shivaji
Comment 3 Michael Fulbright 2000-12-27 12:28:24 EST

*** This bug has been marked as a duplicate of 16686 ***

Note You need to log in before you can comment on or make changes to this bug.