This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 215110 - gnome-games should be build without its own private gnuchess
gnome-games should be build without its own private gnuchess
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Reopened
Depends On: Merge
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2006-11-10 18:42 EST by Valdis Kletnieks
Modified: 2009-09-21 16:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.18.1.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-21 04:54:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2006-11-10 18:42:22 EST
Description of problem:
gnome-games conflicts with gnuchess, similar to bug #214589

Version-Release number of selected component (if applicable):
gnome-games-2.17.2-2.fc7

How reproducible:


Steps to Reproduce:
1. install gnuchess-5.07-10.fc6
2. Try to install  gnome-games-2.17.2-2.fc7
3.
  
Actual results:


Expected results:


Additional info:
Probably needs a Obsoletes/Provides pair similar to the fix for #214589
Comment 1 Matthias Clasen 2006-11-16 00:33:24 EST
I've added a Provides/Obsoletes in 2.17.2-3.fc7
Comment 2 Chris Ricker 2006-11-16 08:29:52 EST
I'd be happier with a Conflicts instead of Obsoletes, so people who prefer
(non-gnome users ;-) could still install gnuchess
Comment 3 Jeremy Katz 2006-11-16 08:34:36 EST
And wouldn't it have made more sense to actually have gnome-games depend on the
existing gnuchess rather than just sucking it into gnome-games?  Otherwise,
anything that wants to use the gnuchess engine now has to depend on gnome-games
which seems kind of wrong.
Comment 4 Matthias Clasen 2006-11-16 09:54:54 EST
Fair enough. 

We can revisit that once the core/extras wall is falling. I don't think I can
add a requires against an extras package right now. 
And moving things from extras to core would be silly at this point, since
everything is bound to move the other direction soon.
Comment 5 Matthias Clasen 2006-11-16 16:10:45 EST
Changed to Conflicts: for now.
Comment 6 Andreas Røsdal 2006-12-28 16:21:52 EST
Hi! I'd be very interested in suggestions for good ways to solve this. 
Currently there is the --disable-gnuchess parameter which you can pass to
configure if you don't want to compile gnuchess as part of gnome-games.
Comment 7 Ray Strode [halfline] 2006-12-29 02:52:59 EST
Hi,

I guess we can just drop gnuchess from gnome-games and direct people to pull it
from extras.
Comment 8 Jeremy Katz 2007-05-18 13:42:12 EDT
This isn't conflicting now that I can see, correct?
Comment 9 Matthias Clasen 2007-05-19 11:45:37 EDT
Looks like it. 
gnuchess has /usr/bin/gnuchess
gnome-games has /usr/bin/glchess and /usr/bin/gnome-gnuchess
So I guess the conflict got removed by prefixing gnome-.
Still, it would be much better to simply require gnuchess, now that we can,
instead of shipping the same program under 2 different names
Comment 10 Hans de Goede 2007-07-06 16:41:55 EDT
[hans@shalem devel]$ rpm -q gnome-games gnuchess
gnome-games-2.18.1.1-1.fc7.x86_64
gnuchess-5.07-10.fc6.x86_64

And I didn't use --force or anything, closing.
Comment 11 Hans de Goede 2007-07-06 16:43:41 EDT
Hmm, maybe that was to quick, re-opening and changing summary to match what this
bug is now about, sorry.
Comment 12 Hans de Goede 2007-07-06 16:45:14 EDT
Should be easy, add --disable-gnuchess to %configure and a "Requires: gnuchess"
Comment 13 Hans de Goede 2007-07-21 04:54:06 EDT
The next rawhide push will include gnome-games-2.19.4-3.fc8, which fixes this.

Note You need to log in before you can comment on or make changes to this bug.