Bug 215222 - File association changed or otherwise in KDE kmail url in a mail does not open browser correctly
File association changed or otherwise in KDE kmail url in a mail does not ope...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 200842 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 10:55 EST by Mike Cohler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kdepim-3.5.7-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 04:31:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cohler 2006-11-12 10:55:39 EST
Description of problem:If an email received in kmail contains a url then
clicking it does not open correctly in the browser


Version-Release number of selected component (if applicable):kdepim-3.5.5-0.1.fc6


How reproducible:Always


Steps to Reproduce:
1. Receive an email containing a web link such as
http://tomshardware.co.uk/2002/09/04/building_your_own_pc/index.html
2. Click the link within the mail
3. Normally this will open Konquerer but although it opens Konqueror the
location var shows that the file
file:///var/tmp/kdecache-mike/krun/3050.0.index.html has been opened instead of
the correct link

4) Change file association by going to Control Centre->KDE components->File
Associations and under text->html change to firefox instead of Konqueror
5) Now try again - this time Firefox Opens but again the location goes to a file
in the kdecache area and not to the original url.

  
Actual results: Browser opens but the url is to a local kdecache file and not
the original url.


Expected results:The browser should open in the original url correctly.


Additional info:FC6 clean install, kde running and Kontact running otherwise
without problems.  This issue was also present in FC5 for a long time and never
addressed.
Comment 1 Jason Tibbitts 2006-11-12 11:30:37 EST
This does not seem specific to Kmail; I've noticed that this happens often in
Amarok as well.  If has many places to click which open URLs in an external
browser, and these often fail in the same manner.  (Yes, I know Amarok is in
extras and indeed I could be seeing something specific to Amarok which
conicidentally has the same behavior as the Kmail problem reported, but I doubt it.)
Comment 2 Mike Cohler 2006-11-21 11:31:12 EST
*** Bug 200842 has been marked as a duplicate of this bug. ***
Comment 3 Mike Cohler 2007-09-18 04:30:41 EDT
This problem has not occurred in F7 so I am closing this bug as resolved for the
current system.

Note You need to log in before you can comment on or make changes to this bug.