Bug 215249 - Kernel 2.6.18-1.2849.fc6 hangs on booting
Kernel 2.6.18-1.2849.fc6 hangs on booting
Status: CLOSED DUPLICATE of bug 215154
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 16:35 EST by Heiko Adams
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 14:14:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of screnn when bootprocess hangs (1.38 MB, image/jpeg)
2006-11-13 17:00 EST, Heiko Adams
no flags Details
Output from dmesg with kernel 2.6.18-1.2798 which works fine. (12.55 KB, text/plain)
2006-11-20 15:49 EST, Tomas Linden
no flags Details
Boot output from kernel 2.6.18-1.2849 which hangs. (3.51 KB, text/plain)
2006-11-20 15:57 EST, Tomas Linden
no flags Details
Boot output from kernel 2.6.18-1.2849 with APIC option. Does not hang. (11.78 KB, text/plain)
2006-11-20 16:00 EST, Tomas Linden
no flags Details

  None (edit)
Description Heiko Adams 2006-11-12 16:35:33 EST
Description of problem:
After updating the kernel to 2.6.18-1.2849.fc6 I'm unable to boot my system
because the booting progress hangs after uncompressing linux.

Version-Release number of selected component (if applicable):
2.6.18-1.2849.fc6

How reproducible:
allways

Steps to Reproduce:
1. Boot the system on kernel 2.6.18-1.2849.fc6
  
Actual results:
The booting progress hangs after uncompressing linux

Expected results:
The system should boot without hanging
Comment 1 Dan Carpenter 2006-11-12 17:25:21 EST
What was the last kernel release that booted correctly?  Could you boot with
initcall_debug and take a digital photo of the screen?

Comment 2 Tomasz Kepczynski 2006-11-13 02:43:58 EST
I have the same problem.
The last working kernel was the one shipped with FC6 (2789 AFAIR).
The latest update feezes when loading standard kernel,
xen + kernel-xen seem to work fine.
Here I type what I see on the screen:

Calling initcall 0xc076b254: pcibios_assign_resources+0x0/0x81()
PCI: Bridge: 0000:00:01.0
  IO window: disabled.
  MEM window: f8000000-f9ffffff
  PREFETCH window: f0000000-f7777777
PCI: Bridge: 0000:00:03.0
  IO window: a000-afff.
  MEM window: fc000000-fc0fffff
  PREFETCH window: disabled.
PCI: Bridge: 0000:00:1e.0
  IO window: b000-bfff
  MEM window: fa000000-fbffffff
  PREFETCH window: 80000000-800fffff
Calling initcall 0xc076d8ae: inet_init+0x0/0x2d2()
NET: Registered protocol family 2

I skipped some stuff from top of the screen.
Comment 3 Bert DeKnuydt 2006-11-13 05:09:23 EST
I have this too on a VIA EPIA EN-1500 with C7 cpu.  
both with kernel-2.6.18-1.2835.fc6 and kernel-2.6.18-1.2849.fc6

Last signs of life are idential in both cases:

PCI: Bridge: 0000:00:01.0
  IO window: b000-bfff
  MEM window: fb000000-fcffffff
  PREFETCH windw: f4000000-f7ffffff
NET: Registered protocol family 2
Comment 4 Heiko Adams 2006-11-13 14:58:55 EST
I'm sorry but how do I boot my kernel with initcall_debug?

On my system the last working kernel was the one shipped with FC6 (2789).
Comment 5 Konrad Rzeszutek 2006-11-13 15:48:36 EST
It is a bootup option, so in grub you hit 'e' on the kernel you have, scroll to
the line that says 'kernel (hdX,X)/boot/vmlinz...' and hit 'e' again. Append to
the end initcall_debug, hit Enter and hit the letter 'b'. That should do it.
Comment 6 Heiko Adams 2006-11-13 17:00:57 EST
Created attachment 141110 [details]
Photo of screnn when bootprocess hangs
Comment 7 Heiko Adams 2006-11-13 17:05:42 EST
The last line printed on the screen is:
Calling initcall 0xc0764cd9:acpi_init+0x0/0x1fs2()
Comment 8 Dan Carpenter 2006-11-15 02:27:11 EST
Bert, Tomasz,

You have a different bug from Heiko.  Your bug is bug 215154.

Comment 9 Tomas Linden 2006-11-20 15:49:19 EST
Created attachment 141693 [details]
Output from dmesg with kernel 2.6.18-1.2798 which works fine.
Comment 10 Tomas Linden 2006-11-20 15:51:17 EST
I have a Asus P2B-DS motherboard with dual 500 MHz Pentium III CPUs
upgraded from FC5 (initially FC4) to FC6. The stock FC6 kernel
  kernel-2.6.18-1.2798.fc6 
works fine but the first update kernel 
  kernel-2.6.18-1.2849.fc6
hangs on my machine, exactly as described above.

Here is the output from dmesg taken with the default kernel
  kernel-2.6.18-1.2798.fc6
Comment 11 Tomas Linden 2006-11-20 15:55:14 EST
I hooked up a serial console to capture the output before the machine
hangs using kernel
  kernel-2.6.18-1.2849.fc6
The ouput is shown in the next attachment. In the output you can find this line
  "IO/L-APIC disabled because your old system seems to be old
overwrite with "apic"

I added APIC as a kernel parameter and with this option the machine does
not hang using the update kernel, as shown in the last attachment.

The question remains what has caused this regression in the first place
and how it can be fixed without this kernel option workaround?
Comment 12 Tomas Linden 2006-11-20 15:57:43 EST
Created attachment 141694 [details]
Boot output from kernel 2.6.18-1.2849 which hangs.
Comment 13 Tomas Linden 2006-11-20 16:00:11 EST
Created attachment 141695 [details]
Boot output from kernel 2.6.18-1.2849 with APIC option. Does not hang.
Comment 14 Jarod Wilson 2006-11-20 16:20:54 EST
(In reply to comment #10)
> I have a Asus P2B-DS motherboard with dual 500 MHz Pentium III CPUs
> upgraded from FC5 (initially FC4) to FC6. The stock FC6 kernel
>   kernel-2.6.18-1.2798.fc6 
> works fine but the first update kernel 
>   kernel-2.6.18-1.2849.fc6
> hangs on my machine, exactly as described above.

Interesting... One of my test boxes also has a P2B-DS motherboard, and exhibits
the same behavior...
Comment 15 Dan Carpenter 2006-11-20 16:47:08 EST
I'm thinking that bug 215154 might be related after all.  There was a bugfix for
race conditions in init_call applied to the upstream kernel.  It would be cool
if someone could try it out.  (I don't have the bug on my hardware).

http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=735a7ffb739b6efeaeb1e720306ba308eaaeb20e

Comment 16 Brian Morrison 2006-11-21 05:57:06 EST
*** Bug 216553 has been marked as a duplicate of this bug. ***
Comment 17 Jarod Wilson 2006-11-21 14:14:22 EST
Reasonably certain this is indeed a duplicate of bug 215154 and closing
accordingly. Discussing/investigating fixes. Anyone afflicted, please try
booting with the 'apic' option, and if that gets you up and running, attach the
output from 'dmidecode' to bug 215154.

*** This bug has been marked as a duplicate of 215154 ***

Note You need to log in before you can comment on or make changes to this bug.