Bug 216553 - Fujitsu-Siemens Amilo L7300 won't boot kernel-2.6.18-1.2849.fc6
Fujitsu-Siemens Amilo L7300 won't boot kernel-2.6.18-1.2849.fc6
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-20 20:17 EST by Brian Morrison
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 05:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output for 2798 kernel (18.05 KB, text/plain)
2006-11-25 02:58 EST, Brian Morrison
no flags Details

  None (edit)
Description Brian Morrison 2006-11-20 20:17:24 EST
Despite spending 5 or 6 evenings on it, I cannot get my laptop to boot the
-1.2849.fc6 i686 kernel, it is quite happy with -1.2798.fc6 i686.

The last relevant output on the console is:

CPU0: Intel(R) Celeron(R) M processor       1.30GHz stepping 06
weird, boot CPU (#0) not listed by the BIOS.
Total of 1 processors activated (2595.27 BogoMIPS).
Brought up 1 CPUs
checking if image is initramfs... it is
Freeing initrd memory: 1354k freed
NET: Registered protocol family 16
ACPI: Bus type pci registered
PCI: PCI BIOS revision 2.10 entry ar 0xfd90c, last bus=1
PCI: Using configuration type 1
Setting up standard PCI resources.

And that's it, never progresses any further.

I have tried all sorts of kernel parameters, without luck. I've tried:

enforcing=0
acpi=no apic=no
lapic (works with previous FC6 kernel)
pci=acpi
pci=noacpi

which all seemed relevant, but none of them appears to do anything to improve
matters.

I will be trying acpi=verbose and even acpi=debug to see if anything shows up,
but in the meantime would appreciate some suggestions as to what I can do to
debug this further.
Comment 1 Tomas Linden 2006-11-21 03:56:49 EST
Have you tried to boot with the kernel option APIC? This works for me as 
described in Bug 215249.
Comment 2 Brian Morrison 2006-11-21 05:56:52 EST
Ah, thanks for that, I'll try it. I tried noapic, and I usually use lapic, but
that doesn't work either in this case.

*** This bug has been marked as a duplicate of 215249 ***
Comment 3 Brian Morrison 2006-11-22 18:44:19 EST
Right.

Well, I've tried apic on its own, apic lapic, and initcall_debug to see what's
happening.

The dmesg output immediately after a succcessful boot with the 2798 kernel reads:

ACPI: Interpreter enabled

this never appears in the 2849 case, the last initcall_debug output is acpi_init
so that ties in, it's trying to load and initialise the acpi interpreter but fails,

I've also tried the 2856 test kernel from Dave Jones' Redhat people directory
and am seeing exactly the same symptoms.

Please let me know if there is something I can generate from the laptop to fill
in some missing information.
Comment 4 Dave Jones 2006-11-24 19:02:09 EST
it's strange that the ACPI interpretor gets disabled. There isn't an acpi=off on
the boot command line of that kernel that works is there ?
Can you attach the output of dmesg from 2798 ?
Comment 5 Brian Morrison 2006-11-25 02:58:42 EST
Created attachment 142104 [details]
dmesg output for 2798 kernel

As requested, the dmesg output for 2798. No, I don't have acpi=off in the
params for this, the acpi interpreter seems able to run and work out what
everything is.
Comment 6 Brian Morrison 2006-12-21 03:36:34 EST
The newly released 2868 kernel now works for me, but that's only because the
auto-apic stuff has been backed out for now.

I'd be happy to try any new kernels with a modified auto-apic patch and see
whether they work for me.

Note You need to log in before you can comment on or make changes to this bug.